Cerca nel supporto

Attenzione alle mail truffa. Mozilla non chiederà mai di chiamare o mandare messaggi a un numero di telefono o di inviare dati personali. Segnalare qualsiasi attività sospetta utilizzando l'opzione “Segnala abuso”.

Learn More

Questa discussione è archiviata. Inserire una nuova richiesta se occorre aiuto.

Home page setting does not work

  • 7 risposte
  • 36 hanno questo problema
  • 4292 visualizzazioni
  • Ultima risposta di tamjk

more options

When I start Firefox I always get Delta Homes search page. I set my home page to ABC.net.au/news/ and made sure that the Firefox starts with 'Show my home page'. However this makes no difference and I keep getting the Delta Homes page when the Firefox opens. How can I change that?

Soluzione scelta

Bookmark and use this; Download the Mozilla Search Reset {web link} This add-on is very simple: on installation, it backs up and then resets your search preferences and home page to their default values, and then uninstalls itself. This affects the search bar, URL bar searches, and the home page.


Sometimes a problem with Firefox may be a result of malware installed on your computer, that you may not be aware of.

You can try these free programs to scan for malware, which work with your existing antivirus software:

Microsoft Security Essentials is a good permanent antivirus for Windows 7/Vista/XP if you don't already have one.

Further information can be found in the Troubleshoot Firefox issues caused by malware article.

Did this fix your problems? Please report back to us!

Leggere questa risposta nel contesto 👍 1

Tutte le risposte (7)

more options

It looks like one of Firefox's hidden preferences has been changed by something. Try this to resolve that:

  • Type "about:config" into the Firefox address bar.
  • Read the warning carefully and then proceed.
  • In the search box at the top of the page, type "browser.newtab.url". You should end up with just one line, which has a status of "user set" and has a value which referes to delta-homes.
  • Right click on the line and select "Reset".

Let us know how you get on.

more options

That might work, but there is more to this hijacker. It can reinstall itself, it can add their search so even if u use google it goes thru their engine (adding deltahome-search-url to googles search-url. ) Norton isn't allowed to find it because you have accepted the licens for a bundle of program among them Delta-Home. (Search Delta-homes on their site) Malwarebite might help thou. You can google it. http://www.wintips.org/remove-delta-homes-search-hijacker/ has a long solution.

Modificato da user799679 il

more options

Soluzione scelta

Bookmark and use this; Download the Mozilla Search Reset {web link} This add-on is very simple: on installation, it backs up and then resets your search preferences and home page to their default values, and then uninstalls itself. This affects the search bar, URL bar searches, and the home page.


Sometimes a problem with Firefox may be a result of malware installed on your computer, that you may not be aware of.

You can try these free programs to scan for malware, which work with your existing antivirus software:

Microsoft Security Essentials is a good permanent antivirus for Windows 7/Vista/XP if you don't already have one.

Further information can be found in the Troubleshoot Firefox issues caused by malware article.

Did this fix your problems? Please report back to us!

more options

I did not found anything specific to Delta Homes but I found program webssearches installed. After uninstalling it (bit tricky) everything is back to normal. Thanks.

more options

Great to hear.

more options

Beware that this hijacker has returned on my computer after some time! You should bookmark this guide as well if Delta Homes happens to show up on your computer again, it saved me: http://www.2-spyware.com/remove-delta-homes-com.html

more options

I also used AdwCleaner to good effect.

But my concern now (after destroying all suspect adware) is that when I go to about : config and look at the entries there, I still see some entries related to either Delta-Homes or - strangely - Google Chrome . . .

Now, with Chrome being Firefox's biggest rival, I don't see why Firefox would go to the bother of having special entries for it on its configuration file . . . .

If nothing else, the danger is that any infection of the Chrome browser by a hijacker, virus, etc would be ferried across into Firefox as a a result of these connections.

I can't see why Firefox would take this additional risk.

Can anyone advise on modifying or removing these entries ? The Modify option allows me to blank them but I'm afraid that a blank entry would cause new problems to the browser . . . And I don't know what sort of neutral or safe entry would be.