Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

A requirement for Firefox 5.0 is support for SSE2. The CPU in my laptop only supports SSE. Would I be better off to not download Firefox 5.0?

  • 3
  • 3
  • 53 views
  • Nzaghachi ikpeazụ nke cor-el

more options

Dear Sir:

I am currently running Firefox 4.0.1 on my laptop. This browser works great.

Per the SSE2/SSE issue noted above, I would like to determine whether I should download Firefox 5.0.

Please let me know if there is information that you require beyond what is included to the right.

Thanks, Steven Katz

Dear Sir: I am currently running Firefox 4.0.1 on my laptop. This browser works great. Per the SSE2/SSE issue noted above, I would like to determine whether I should download Firefox 5.0. Please let me know if there is information that you require beyond what is included to the right. Thanks, Steven Katz

Edeziri site na Firefox_man

Asịsa ahọpụtara

If 4.0.1 works satisfactorily then Firefox 5 shouldn't pose problems, so give it a try.

Gụọ azịza a na nghọta 👍 0

All Replies (3)

more options

Asịsa Ahọpụtara

If 4.0.1 works satisfactorily then Firefox 5 shouldn't pose problems, so give it a try.

more options

Hey cor-el:

I did not check the requirements for Firefox 4.0; I just downloaded it. Thanks for pointing out the similarity in requirements.

Just downloaded 5.0 and it runs okay.

Regards, Firefox_man

more options

You're welcome