Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Can't download - nothing happening....

  • 5 replies
  • 0 have this problem
  • 10 views
  • Nzaghachi ikpeazụ nke jan187

more options

When using a download link (everywhere) nothing is happening. No errors no 'nothing'

I was working before: 103.0.1 (64-bit)

Download is working in chrome and other browsers.

Any idea where to look ?

Best

Jan

When using a download link (everywhere) nothing is happening. No errors no 'nothing' I was working before: 103.0.1 (64-bit) Download is working in chrome and other browsers. Any idea where to look ? Best Jan

All Replies (5)

more options

FF was working before ... not I  :-)

Helpful?

more options

Do you have Firefox set to ask you where to save files, or are you using one of the "Save [something] as..." menu items? In that case, this could be related to the file/directory picker.

I don't know which versions of Linux are affected, but some users need to make either of these two changes to make the file/directory picker appear. As a Windows user, I can't verify this myself

(A) Install xdg-desktop-portal

This would be from your package manager, I think.

(B) Turn off auto-detection of the GTK portal

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

More info on about:config: Configuration Editor for Firefox. The moderators would like us to remind you that changes made through this back door aren't fully supported and aren't guaranteed to continue working in the future.

(2) In the search box in the page, type or paste widget.use-xdg-desktop-portal.file-picker and pause while the list is filtered

(3) Double-click the preference to display an editing field, and change the value to 0 then press Enter or click the blue check mark button to save the change. For reference, these are the valid values:

  • 0 => Never
  • 1 => Always
  • 2 => Auto-detect

Now... there are a bunch of other preferences starting with widget.use-xdg-desktop-portal. and I have no idea what those do. If your distribution has a support site with a Firefox board or active Firefox discussions, you might search there for more tips.

Helpful?

more options

Hi jscher2000

Thanks for your fast reply.

The download path is /home/jbi/Hentet (danish for Download) an "always ask" is checked.

The widget.use-xdg-desktop-portal.file-picker is == 2

Thanks again. It is very kind of you :-)

Best Jan

Helpful?

more options

Hi Jan, did changing widget.use-xdg-desktop-portal.file-picker to zero work for you?

Helpful?

more options

Hi

Sorry I didn't tried ... but now I did and yes, it is working now :-)

Thanks - that was very good thinking from you :-)

Best and thanks again

Jan

Helpful?

Jụọ ajụjụ

Ị ga-abanyerịrị n'akaụntụ gị iji zaghachi mbisa. Biko bido otu ajụjụ ọhụrụ, ọ bụrụ na ị nwebeghị akaụntụ.