Mozilla Support में खोजें

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

youtube only loads the video, and not the page?

  • 10 प्रत्युत्तर
  • 18
  • 988 views
  • के द्वारा अंतिम प्रतियुतर FredMcD

more options

Since about two days ago, Youtube has stopped loading the entire page in Firefox. It loads JUST the video, and nothing else. The video works and plays just fine, but I can't see recommendations, comments, or the video description. The menu drop box in the top left corner works, and the home page loads and displays everything just fine. Yesterday a furious process of refreshing and clicking random videos, and a bevy of other attempts like updating Adobe, updating Firefox, checking plugins, options, permissions, etc, randomly got some videos to work correctly. Once a few did, the rest seemed to be working just fine. Now its busted again, and I find it conspicuous that this started happening recently, almost exactly when youtube seems to have re-skinned several things on the pages. Is there a lasting fix for this? or just keep refreshing and opening different videos? Because that doesn't seem to be working today, and I can't remember what else I tried, since Firefox and Adobe are both up to date.

Since about two days ago, Youtube has stopped loading the entire page in Firefox. It loads JUST the video, and nothing else. The video works and plays just fine, but I can't see recommendations, comments, or the video description. The menu drop box in the top left corner works, and the home page loads and displays everything just fine. Yesterday a furious process of refreshing and clicking random videos, and a bevy of other attempts like updating Adobe, updating Firefox, checking plugins, options, permissions, etc, randomly got some videos to work correctly. Once a few did, the rest seemed to be working just fine. Now its busted again, and I find it conspicuous that this started happening recently, almost exactly when youtube seems to have re-skinned several things on the pages. Is there a lasting fix for this? or just keep refreshing and opening different videos? Because that doesn't seem to be working today, and I can't remember what else I tried, since Firefox and Adobe are both up to date.

चुने गए समाधान

It could be the work of one of your add-ons. Type about:addons<enter> in the address bar to open your Add-ons Manager. Hot key; <Control> (Mac=<Command>) <Shift> A)

In the Add-ons Manager, on the left, select Extensions. Disable a few add-ons, then Restart Firefox.

Some added toolbar and anti-virus add-ons are known to cause Firefox issues. Disable All Of them.

If the problem continues, disable some more (restarting FF). Continue until the problem is gone. After, you know what group is causing the issue. Re-enable the last group ONE AT A TIME (restarting FF) until the problem returns.

Once you think you found the problem, disable that and re-enable all the others, then restart again. Let us know who the suspect is, detective.

संदर्भ में यह जवाब पढ़ें 👍 2

All Replies (10)

more options

http://imgur.com/a/FWn2p

Seems like my image didn't attach properly to the question so here's a reference image via imgur.

more options

Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?


Many site issues can be caused by corrupt cookies or cache.

  • Clear the Cache and
  • Remove Cookies

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

Type about:preferences<enter> in the address bar.

  • Cookies; Select Privacy. Under History, select

Firefox will Use Custom Settings. Press the button on the right side called Show Cookies. Use the search bar to look for the site. Note; There may be more than one entry. Remove All of them.

  • Cache; Select Advanced > Network. Across from

Cached Web Content, Press Clear Now.

If there is still a problem, Start Firefox in Safe Mode {web link} A small dialog should appear. Click Start In Safe Mode (not Refresh). While you are in safe mode;

Type about:preferences#advanced<enter> in the address bar.

Under Advanced, Select General. Look for and turn off Use Hardware Acceleration.

Then restart. Poke around safe websites. Are there any problems?

more options

Restarting in Safe Mode fixed it...sort of. The video is up almost instantaneously, ready to play all the way to the end, like usual. It takes about a full minute for the recommendations to load after the video is up. The description a while after that, and then about another full minute for the comments to load. My time estimates are probably over-large, but you get the idea. I went ahead and deleted all of the cookies that came up for a Youtube search, and restarted out of safe mode. No dice. Restarting back into safe mode continues to slow-work.

more options

Oh, and I couldn't find an option for hardware acceleration in the place you listed, but I feel like I turned that off a year or so ago. I suppose updates since then might have re-enabled it, but where is it at? It's not in my advanced General tab, or any of the other tabs in there as well.

more options

My instructions were for the old Firefox. Sorry.

Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches.

You will need to restart Firefox for this to take effect so save all work first (e.g., mail you are composing, online documents you're editing, etc.,) and then perform these steps:

In Firefox 54 and below:

  1. Click the menu button New Fx Menu and select Options (Windows) or Preferences (Mac, Linux).
  2. Select the Advanced panel and the General tab.
  3. Uncheck Use hardware acceleration when available.
  4. Close Firefox completely and then restart Firefox to see if the problem persists.

In Firefox 55 and above:

  1. Click the menu button New Fx Menu and select Options (Windows) or Preferences (Mac, Linux).
  2. Select the General panel.
  3. Under Performance, uncheck Use recommended performance settings. Additional settings will be displayed.
    Fx55Performance-disableHWA
  4. Uncheck Use hardware acceleration when available.
  5. Close Firefox completely and then restart Firefox to see if the problem persists.

Did this fix your problems? Please report back to us!

If the problem is resolved, you should check for updates for your graphics driver by following the steps mentioned in these Knowledge base articles:

Thank you.

more options

चयनित समाधान

It could be the work of one of your add-ons. Type about:addons<enter> in the address bar to open your Add-ons Manager. Hot key; <Control> (Mac=<Command>) <Shift> A)

In the Add-ons Manager, on the left, select Extensions. Disable a few add-ons, then Restart Firefox.

Some added toolbar and anti-virus add-ons are known to cause Firefox issues. Disable All Of them.

If the problem continues, disable some more (restarting FF). Continue until the problem is gone. After, you know what group is causing the issue. Re-enable the last group ONE AT A TIME (restarting FF) until the problem returns.

Once you think you found the problem, disable that and re-enable all the others, then restart again. Let us know who the suspect is, detective.

more options

If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block (wanted) content (e.g. Adblock Plus, NoScript, Ghostery, uBlock Origin) always make sure such extensions do not block (wanted) content.

Note that hardware acceleration can be found here:

  • Options/Preferences -> General: Performance
    remove checkmark: [ ] "Use recommended performance settings"
    "Use hardware acceleration when available"
more options

As of late Friday night YouTube changed their page content layout and since then I have experienced slow loading of all but the main video. A few times I have watched an entire 4 minute video and when I tried to scroll down to read the comments they would just start to load when I got done to where they should be showing, and did take quite awhile to completely load the first 10 or 12 comments. And then clicking for "More comments" might be slow to respond and load the comments, too. Overall, the YouTube pages feel sluggish or slow to respond to "clicks" even when a page is completely loaded, where before that "upgrade" it was always "snappy" when responding to user input for selections.

I hope this isn't a "pro-Google Chrome" situation where they make it harder for users of other browsers to use YouTube, as has happened with Google Maps earlier this year when they removed some features that had been available to Firefox users. And about the same time Google removed the "historical views" (timeline of past satellite images) from Google Maps entirely from all web browsers. Now people need to use the Google Earth application to see the older satellite images from the timeline.

more options

Found the problem, It was SmartVideo for Youtube!

Dunno why I didn't think of that first. Had to have been in the Add-ons tab almost a dozen times, and not even considered it. I've only got 3 add-ons, and I thought maybe it was adblock, even though I have it exclude youtube by default. How my brain failed to think "Add-on last updated in 2016, directly affects Youtube, may be a problem" I have no idea.

I suspect this is a result of the new Youtube update as edmeister pointed out. I figured that was the catalyst, just needed to find the source. I'm going to miss my videos being force-buffered to full...but hopefully he'll update the add-on.

Thanks for the help guys! At least I wasn't as bad as a "try turning it off and on again" level solution.

more options

That was very good work. Well done. Please flag your last post as Solved Problem so others will know.