Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Smooth scrolling in Firefox / Windows 10 / Huawei Matebook

more options

Hello,

My scrolling experience is not as smooth as before on Firefox on Windows 10.

Previously had a perfect smooth scrolling capability, but now the scroll is more laggy. I don't have the issue with Microsoft Edge : completely smooth. I'm using a logitech mouse M390 with smooth scroll feature enabled.

I suspect something has changed in latest release of Firefox on Windows which impact the scrolling experience. Anyone has noticed the same behavior ?

Just reinstalled my laptop from scratch : same issue.

Thanks for your feedback ! Have a pleasant day !

J.

All Replies (4)

more options

hello Jérôme Caron,

Using Windows 10 on an Asus laptop. I have problems with Firefox hanging, and with scrolling. It is bad on the New York Times web site. First nothing happens when I try to scroll down, then it scrolls too far. I have also had problems with "unresponsive scripts" and I don't know if upgrading to 10 has changed it. What can I do? Actually it is slow right now. I am typing very slowly and have to wait for the letters to appear.

You can try to disable hardware acceleration in Firefox. Tools > Options > Advanced > General > Browsing: "Use hardware acceleration when available" You need to close and restart Firefox after toggling this setting. https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes You can check if there is an update for your graphics display driver and check for hardware acceleration related issues. https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration

Helpful?

more options

Hello,

I am glad to hear that your problem has been resolved.

If you have not already, please mark this thread as solved by marking the solution. This will help other users experiencing similar problems find help faster and more efficiently.

I hope you continue using our products and thank you for contacting Mozilla Support

Helpful?

more options

hi ,jerome

these steps help you get the smooth scrolling .

Turn on 'Smooth Scrolling' Start Firefox. Click Tools, Options. Click the Advanced icon, then look in the Browsing section. Enable Use smooth scrolling, then click OK.

you can try this also

To enable the smooth scrolling function on Mozilla Firefox, follow the simple guidelines below:

Launch Firefox. Type about:preference in the address bar and then hit the Enter key.firefox about preferences Smooth Scrolling On the displayed window, locate Browsing and check the Use smooth scrolling box under it. This will enable the smooth scrolling feature.

And you are good to go! After enabling the feature, you can try and reconfigure the browser‘s settings to further optimize the smooth scrolling function.

To do this, go through the step-by-step guidelines below:

Start Firefox. Type about:config in the address box, and press Enter. This should bring up a list of settings. On the next window, enter general.smoothScroll.currentVelocityWeighting in the designated search box, and press Enter. Double-click on the entry from the list of results, and set its value to 0.

Set general.smoothScroll.mouseWheel.durationMaxMS to 250. Set genral.smoothScroll.stopDecelerationWeighting to 0.75. Lastly, you need to set mousewheel.min_line_scroll_amount to 28. And you are all set!

i hope it is helpful for you.

Modified by Himanshu prabhakar

Helpful?

more options

Hii

Okay, did some experimenting and found a setting in about:config that makes Smooth Scrolling both smooth and fast: look in about:config for mousewheel.min_line_scroll_amount. By default that has a value of 5. I changed that into 50 and now the Smooth Scrolling looks and feels like before.

Hope it would resolve your problem...

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.