חיפוש בתמיכה

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox is allowing a pop-up to open for one site https://www.roomkey.com

  • 10 תגובות
  • 1 has this problem
  • 5 views
  • תגובה אחרונה מאת McCoy

more options

When I go to https://www.wyndhamhotels.com/#, search for hotels, and then click on a hotel, a pop-up opens to https://www.roomkey.com/hotels (usually to a specific hotel).

I usually use Chrome for accessing https://www.wyndhamhotels.com/# because I do not get a pop-up when doing the same thing in Chrome.

I have pop-ups disabled in Firefox.

כל התגובות (10)

more options

Go to the Mozilla Add-ons Web Page {web Link} (There’s a lot of good stuff here) and search for a good ad blocker.

more options

I thought I listed in my plugins in the form (extensions) adgaurd ad blocker installed. I just made sure its filtering on that site. Same in chrome - adblocker adguard. Regardless why would firefox allow a popup?

more options

Can you post the steps to replicate this issue with a popup (i.e. what button to click or possible form data) ?

more options

Firefox allows sites to open popup windows after certain users actions, such as clicks. I think what these hotel sites do is when you click a link or button to search availability, they open Roomkey or other site in a new window as a pop-under. You can remove the exception so Firefox does not let clicks open popups without your specific approval. However, that might be more painful than useful?

more options

cor-el said

Can you post the steps to replicate this issue with a popup (i.e. what button to click or possible form data) ?

See my OP

more options

jscher2000 said

Firefox allows sites to open popup windows after certain users actions, such as clicks. I think what these hotel sites do is when you click a link or button to search availability, they open Roomkey or other site in a new window as a pop-under. You can remove the exception so Firefox does not let clicks open popups without your specific approval. However, that might be more painful than useful?

With pop-ups disabled in Firefox options???

It is a pop under, but thought that would fall under block pop-ups.

Where would I set it to prompt for popups? Doesn't sound like a real option...

more options

Mitprak65 said

I thought I listed in my plugins in the form (extensions) adgaurd ad blocker installed.

AdGuard AdBlocker 3.3.8 (adguardadblocker@adguard.com) (Inactive)

more options

Hello mitprak65,

FWIW, here it says :

"RoomKey is a hotel booking service backed and, at least partially, owned by Choice, Hilton, Hyatt, IHG, Marriott and Wyndham. "

Further down it says :

" Ad blocking services like AdBlock, which I use, are unable to prevent this site launching these annoying pop ups. "

Then they give you instructions on how to solve the problem.

(note that this was written in 2013)

more options

Mitprak65 said

jscher2000 said
Firefox allows sites to open popup windows after certain users actions, such as clicks. I think what these hotel sites do is when you click a link or button to search availability, they open Roomkey or other site in a new window as a pop-under. You can remove the exception so Firefox does not let clicks open popups without your specific approval. However, that might be more painful than useful?

With pop-ups disabled in Firefox options???

It is a pop under, but thought that would fall under block pop-ups.

Where would I set it to prompt for popups? Doesn't sound like a real option...

Popup windows are blocked unless they were triggered by a user action such as a click. There is a list of user actions allowed to generate popups that you can edit if you like. I don't recommend it, but:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box above the list, type or paste popup and pause while the list is filtered

(3) Double-click the dom.popup_allowed_events preference to open a field with the current list of events allowed to trigger popups, separated by spaces. Delete any events you do not want to be automatic exceptions, then either press Enter or click the blue checkmark button to complete the change.

To restore the original value, use the Reset button (left-pointing arrow) at the far right end of that row.

more options

You might find this interesting (especially the section under "Operations") :

https://en.wikipedia.org/wiki/Roomkey

And also :

https://www.roomkey.com/blog/why-was-roomkey-created