חיפוש בתמיכה

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Since updating Firefox, can't access one website - the html error message is displayed

  • 4 תגובות
  • 1 has this problem
  • 12 views
  • תגובה אחרונה מאת cor-el

more options

The website in question is http://emgs.org It has two protected folders ... /331 and /dev - these are protected with cPanel Directory Privacy. The root folder is not protected. As part of the protection, some changes to the .htaccess file are made (ErrorDocument 401 /error.html and ErrorDocument 403/error.html) ... and the file error.html is in the root. If someone tries to access the /331 or /dev folders they are presented with a login panel ... if they can't complete it, they are served the error.html file.

The site is accessible from other browsers ... Chrome. Vivaldi, Pale Moon. Firefox can access other websites we manage (though on a different host) that have the same cPanel Privacy areas and settings.

I've cleared the Firefox cache and cookies. I've uninstalled Firefox and re-installed. I've tried several versions ... were were using the latest ESR version. This problem exists on all the other PCs with the same ESR version. If I load an old version of Firefox (say 49), then the website emgs.org IS accessible.

So ... what is it in the latest versions of ESR which are causing this particular website/host to throw a 403 error?

I've I remove the "ErrorDocument 403/error.html" line from .htaccess, I get the following error message:

Forbidden You don't have permission to access / on this server. Additionally, a 403 Forbidden error was encountered while trying to use an ErrorDocument to handle the request.

The hosting support say it is a browser issue as they are unable to reproduce with any other browser.

Your help would be much appreciated.

Regards, David

The website in question is http://emgs.org It has two protected folders ... /331 and /dev - these are protected with cPanel Directory Privacy. The root folder is not protected. As part of the protection, some changes to the .htaccess file are made (ErrorDocument 401 /error.html and ErrorDocument 403/error.html) ... and the file error.html is in the root. If someone tries to access the /331 or /dev folders they are presented with a login panel ... if they can't complete it, they are served the error.html file. The site is accessible from other browsers ... Chrome. Vivaldi, Pale Moon. Firefox can access other websites we manage (though on a different host) that have the same cPanel Privacy areas and settings. I've cleared the Firefox cache and cookies. I've uninstalled Firefox and re-installed. I've tried several versions ... were were using the latest ESR version. This problem exists on all the other PCs with the same ESR version. If I load an old version of Firefox (say 49), then the website emgs.org IS accessible. So ... what is it in the latest versions of ESR which are causing this particular website/host to throw a 403 error? I've I remove the "ErrorDocument 403/error.html" line from .htaccess, I get the following error message: Forbidden You don't have permission to access / on this server. Additionally, a 403 Forbidden error was encountered while trying to use an ErrorDocument to handle the request. The hosting support say it is a browser issue as they are unable to reproduce with any other browser. Your help would be much appreciated. Regards, David

כל התגובות (4)

more options

I do notice it is very slow to load on ver 57 and no errors. Your pics need to have # of colors reduced for faster loading.

W3C.org (World Wide Web Consortium) in charge of standards and practices and future development of web pages and web browsers make the rules on code. Mozilla Firefox follows these rules. HTML - ERRORS https://validator.w3.org/nu/?doc=http%3A%2F%2Fwww.emgs.org%2F CSS - ERRORS https://jigsaw.w3.org/css-validator/validator?uri=http%3A%2F%2Femgs.org&profile=css3svg&usermedium=all&warning=1&vextwarning=&lang=en

Please let us know if this solved your issue or if need further assistance.

more options

Sorry ... don't see that your reply addresses the error when visiting the site.

I'm not getting as far as WordPress ... the loading speed of images isn't relevant.

Looking at the error message listed above ... Firefox is saying "You don't have permission to access / on this server" ... so what is it sending to the host that makes this happen?

What is different about the way Firefox is sending the request in the latest ESR version ... compared to older version?

This has to be some change in Firefox.

more options

I've also found I can't log into Zoho mail ... after entering the email address and password, I just get returned to the login page - there are no messages from either Zoho or Firefox to suggest there's anything wrong.

I also have installed Developer Edition 58.0b15 (64-bit) - using this, I can get to the emgs.org website, and login to Zoho mail.

This must mean that something stored in the ESR 52 settings that is preventing access to some web servers.

As stated before, I have uninstalled and cleared the cache, history and cookies.

I don't see a lot of feedback on this ... is there NO help out there?

Where do I look? In the registry?

more options

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Appearance
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window

If you have login issues then you may suffer from blocked or corrupted cookies.

You can try these steps in case of issues with web pages:

You can reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • hold down the Shift key and left-click the Reload button
  • press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • press "Command + Shift + R" (Mac)

Clear the cache and remove the cookies from websites that cause problems via the "3-bar" Firefox menu button (Options/Preferences).

"Clear the cache:

  • Options/Preferences -> Privacy & Security -> Cached Web Content: "Clear Now"

"Remove the cookies" from websites that cause problems.

  • Options/Preferences -> Privacy & Security -> "Use custom settings for history" -> Cookies: "Show Cookies"

You can remove all data stored in Firefox from a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History -> Show All History" or "View -> Sidebar -> History").

Using "Forget About This Site" will remove all data stored in Firefox from that domain like bookmarks and history and cookies and passwords and cache and exceptions, so be cautious. If you have a password or other data from that domain that you do not want to lose then make sure to backup this data or make a note.

You can't recover from this 'forget' unless you have a backup of involved files.

If you revisit a 'forgotten' website then data from that website will be saved once again.