Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

mozilla.cfg not being applied in Firefox 4

  • 2 replies
  • 34 have this problem
  • 9 views
  • Last reply by amcdougall

more options

I am trying to get certain settings configured and locked using mozilla.cfg. We have used this exact method in Firefox 3.x but for some reason it is ignoring mozilla.cfg.

Here is my mozilla.cfg

//
try {
lockPref("app.update.enabled", false);
lockPref("app.update.autoUpdateEnabled", false);
lockPref("extensions.update.enabled", true);
lockPref("extensions.update.autoUpdateEnabled", true);
lockPref("network.automatic-ntlm-auth.trusted-uris", "shpt1-ed1, sharepoint");
lockPref("network.cookie.alwaysAcceptSessionCookies", true);
lockPref("network.cookie.cookieBehavior", 1);
} catch(e) {
displayError("lockedPref", e);
}


and the appropriate all.js lines

pref("general.config.obscure_value", 0); // for MCD .cfg files
pref("general.config.filename", "mozilla.cfg");
I am trying to get certain settings configured and locked using mozilla.cfg. We have used this exact method in Firefox 3.x but for some reason it is ignoring mozilla.cfg. Here is my mozilla.cfg <pre><nowiki>// try { lockPref("app.update.enabled", false); lockPref("app.update.autoUpdateEnabled", false); lockPref("extensions.update.enabled", true); lockPref("extensions.update.autoUpdateEnabled", true); lockPref("network.automatic-ntlm-auth.trusted-uris", "shpt1-ed1, sharepoint"); lockPref("network.cookie.alwaysAcceptSessionCookies", true); lockPref("network.cookie.cookieBehavior", 1); } catch(e) { displayError("lockedPref", e); }</nowiki></pre> and the appropriate all.js lines pref("general.config.obscure_value", 0); // for MCD .cfg files pref("general.config.filename", "mozilla.cfg");

Modified by cor-el

Chosen solution

You can place a js file (local-settings.js) in the defaults\pref folder in the Firefox program folder. Firefox 4 no longer uses all.js , but packs all files in a special compressed (optimized) omni.jar archive and it is best not to tamper with that file.

See http://kb.mozillazine.org/Locking_preferences

Read this answer in context 👍 3

All Replies (2)

more options

Chosen Solution

You can place a js file (local-settings.js) in the defaults\pref folder in the Firefox program folder. Firefox 4 no longer uses all.js , but packs all files in a special compressed (optimized) omni.jar archive and it is best not to tamper with that file.

See http://kb.mozillazine.org/Locking_preferences

more options

Awesome! Thanks!