Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Why does Firefox pass session off to login machine?

  • 3 replies
  • 4 have this problem
  • 10 views
  • Last reply by cousins

more options

Running Linux on two machines, if I ssh -X over to the second machine and run the "firefox" command on the second machine firefox starts up but it is running on the first machine. This happens only if I have a firefox session running on the first machine already. Why? and How do I stop this?

I just downloaded the latest 3.6 version of Firefox on both machines

Running Linux on two machines, if I ssh -X over to the second machine and run the "firefox" command on the second machine firefox starts up but it is running on the first machine. This happens only if I have a firefox session running on the first machine already. Why? and How do I stop this? I just downloaded the latest 3.6 version of Firefox on both machines

Chosen solution

Try using the -no-remote command line argument when starting that second Firefox process. You'll need to include the name of the Profile on that 2nd PC.

http://kb.mozillazine.org/Opening_a_new_instance_of_Firefox_with_another_profile

Read this answer in context 👍 0

All Replies (3)

more options

Chosen Solution

Try using the -no-remote command line argument when starting that second Firefox process. You'll need to include the name of the Profile on that 2nd PC.

http://kb.mozillazine.org/Opening_a_new_instance_of_Firefox_with_another_profile

more options

That is what I was after. Thanks very much. I should have seen that with -help.

more options

I'm a bit curious about how and why it attaches to the remote session. How would the remote session even know about the session running on my local workstation? Why would the default be to attach to a process running on a different machine?