Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

My Firefox is showing foreign language in ONLY SOME of the lines of text on the pages but all of my settings are strictly English.

  • 2 fhreagra
  • 0 leis an bhfadhb seo
  • 1 view
  • Freagra is déanaí ó cor-el

more options

My Firefox browser is somehow corrupted with foreign language features. See in the picture that much of the text is in English - the selected and preferred language. It is what the Settings are set to. But notice that bits and pieces are in some other language. I recently made a trip to Spain and used translation features while there - but those was all reset to English. I've gone into Troubleshooting mode; I've restarted; I've reset and restarted. But I can't seem to get rid of the gibberish. WTH!!!! All copies of Firefox, on all owned Mac machines (i-Phone; Mac Mini; I-Mac Pro; I pads) are set to English. About the only thing I haven't done it uninstall and reinstall Firefox. Thanks for any help you can offer.

My Firefox browser is somehow corrupted with foreign language features. See in the picture that much of the text is in English - the selected and preferred language. It is what the Settings are set to. But notice that bits and pieces are in some other language. I recently made a trip to Spain and used translation features while there - but those was all reset to English. I've gone into Troubleshooting mode; I've restarted; I've reset and restarted. But I can't seem to get rid of the gibberish. WTH!!!! All copies of Firefox, on all owned Mac machines (i-Phone; Mac Mini; I-Mac Pro; I pads) are set to English. About the only thing I haven't done it uninstall and reinstall Firefox. Thanks for any help you can offer.
Attached screenshots

All Replies (2)

more options

Possibly there is a mismatch in your Google language settings (for their website). Could you check here:

https://www.google.com/preferences?lang=1

You also can check that your Firefox is set to tell websites that English (or U.S. English) is your preferred language. This article should get you to that area of the Settings page: https://support.mozilla.org/en-US/kb/use-firefox-another-language#w_set-an-order-of-preference-for-languages

Helpful?

more options

Clear the Cache and remove the Cookies for websites that cause problems via the "3-bar" Firefox menu button (Settings), click the padlock icon (Clear cookies and site data) for the domain in the selected tab.

"Remove the Cookies" for websites that cause problems:

  • Settings -> Privacy & Security
    Cookies and Site Data: "Manage Data"

"Clear the Cache":

  • Settings -> Privacy & Security
    Cookies and Site Data -> Clear Data -> [X] Cached Web Content -> Clear

Helpful?

Cuir ceist

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.