Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox and YouTube

  • 6 fhreagra
  • 0 leis an bhfadhb seo
  • 32 views
  • Freagra is déanaí ó cor-el

more options

I have a YouTube loading problem, it works on all other browsers except Firefox. When you go to the YouTube homepage, the whole screen is blank with black and grey colours, on the homepage no video loads, no words on the screen, no ads, just blank. it works like normal on Chrome,Opera,Internet Explorer.

I am on windows 8, all blockers are off, on the latest version 115.9.1. no other problems on my PC.

Any ideas, Thanks

I have a YouTube loading problem, it works on all other browsers except Firefox. When you go to the YouTube homepage, the whole screen is blank with black and grey colours, on the homepage no video loads, no words on the screen, no ads, just blank. it works like normal on Chrome,Opera,Internet Explorer. I am on windows 8, all blockers are off, on the latest version 115.9.1. no other problems on my PC. Any ideas, Thanks
Attached screenshots

All Replies (6)

more options

Try clearing site cookies.

Does it still happen in Troubleshoot Mode?

Helpful?

more options

You can remove all data stored in Firefox for a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History -> Show All History" or "View -> Sidebar -> History").

Using "Forget About This Site" will remove all data stored in Firefox for this domain like history and cookies and passwords and exceptions and cache, so be careful. If you have a password or other data for that domain that you do not want to lose, make sure to backup this data or make a note.

You can't recover from this 'forget' unless you have a backup of involved files.

If you revisit a 'forgotten' website, data for that website will be saved once again.


You can check the Web Console (Tools -> Web Developer) for messages about blocked content and about the presence of mixed or unsafe content.

You can check the Network Monitor to see if content is blocked or otherwise fails to load.

If necessary use "Ctrl+F5" or "Ctrl+Shift+R" (Mac: Command+Shift+R) to reload the page and bypass the cache to generate a fresh log.

Helpful?

more options

Thanks for the replies, i cleared the cookies and now i get a white screen lol exactly like the picture i uploaded but the whole screen is white and nothing loads, no words/pictures/thumbnails?

Helpful?

more options

i tried this ....

"You can remove all data stored in Firefox for a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History -> Show All History" or "View -> Sidebar -> History")."

i get a blank white screen, you can't click on anything lol

Helpful?

more options

inter_kooler said

Thanks for the replies, i cleared the cookies and now i get a white screen lol exactly like the picture i uploaded but the whole screen is white and nothing loads, no words/pictures/thumbnails?

Did you try the troubleshooting mode as was requested by @zeroknight? Did it work there?

Also try to create a new profile, do not add any plugins/extensions, do not log into Mozilla sync account in that new profile or change any setting, and then check if YouTube opens up.

Helpful?

more options

You can check the Web Console (Tools -> Web Developer) for messages about blocked content and about the presence of mixed or unsafe content.

You can check the Network Monitor to see if content is blocked or otherwise fails to load.

If necessary use "Ctrl+F5" or "Ctrl+Shift+R" (Mac: Command+Shift+R) to reload the page and bypass the cache to generate a fresh log.

Helpful?

Cuir ceist

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.