X
Tap here to go to the mobile version of the site.

Fóram Tacaíochta

UI glitch: black box in the top-left corner

Postáilte

When maximized, a block box in the top-left corner of the browser covers the favicon of the first tab. When not maximized, the tabs shift to the right such that the box is no longer covering any part of the first tab.

When I start with add-ons disabled, the black box disappears. However, setting my theme to default, removing all my add-ons, refreshing and then re-installing Firefox didn't fix the problem.

I also noticed that if I enable the menu bar, the black box leaves the tabs alone and instead covers the 'File' menu.

Any idea how to get rid of it?

When maximized, a block box in the top-left corner of the browser covers the favicon of the first tab. When not maximized, the tabs shift to the right such that the box is no longer covering any part of the first tab. When I start with add-ons disabled, the black box disappears. However, setting my theme to default, removing all my add-ons, refreshing and then re-installing Firefox didn't fix the problem. I also noticed that if I enable the menu bar, the black box leaves the tabs alone and instead covers the 'File' menu. Any idea how to get rid of it?
Attached screenshots

Réiteach roghnaithe

jscher2000 said

Hi Priddles, thank you for testing and reporting back. There may be some minor incompatibility with your graphics card/chipset driver software. (I say minor because Firefox is not crashing.) Firefox 68 enabled a new feature called WebRender, so since it is graphics related, perhaps another workaround would be to disable only WebRender. These are the related preferences, but I can't test it myself (WebRender isn't enabled on laptops, it seems): (1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk. (2) In the search box above the list, type or paste webren and pause while the list is filtered Near the bottom: (3) If the gfx.webrender.enabled preference is true, double-click it to toggle it to false (4) Double-click the gfx.webrender.force-disabled preference to switch the value from false to true Meanwhile, re-enable hardware acceleration on the Options page, then exit and restart Firefox. Any difference?

gfx.webrender.enabled and gfx.webrender.force-disabled were both false and setting gfx.webrender.force-disabled to true did nothing.

However! Setting gfx.webrender.enabled to true seems to have fixed the problem entirely!

Read this answer in context 3
Luaigh

Tuilleadh mionsonraí faoin chóras

Breiseáin Shuiteáilte

None.

Feidhmchlár

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/75.0.3770.142 Safari/537.36

Tuilleadh Eolais

My_Cheese_Is_Slippin'
  • Top 10 Contributor
56 réiteach 705 freagra

Hi Priddles, Is it a Pinned Tab? Right click on it and see if there is an option to Unpin Tab.

Hi Priddles, Is it a Pinned Tab? Right click on it and see if there is an option to Unpin Tab.
An bhfuil an freagra seo cabhrach? 0
Luaigh
cor-el
  • Top 10 Contributor
  • Moderator
17418 réiteach 157376 freagra

Do you see a tooltip if you hover this area? You can also check this area in customize mode.

Are you possibly using a userChrome.css file?

I would normally expect the window controls (minimize, maximize, close) to appear at the right end of the Tab bar when the Menu bar and Title bar are hidden. Because your screenshot only shows the left end, it is not possible to see whether the control buttons are visible elsewhere.

I see a hidden (collapsed) tab-drag-indicator in the source code in this area.

Do you see a tooltip if you hover this area? You can also check this area in customize mode. Are you possibly using a userChrome.css file? I would normally expect the window controls (minimize, maximize, close) to appear at the right end of the Tab bar when the Menu bar and Title bar are hidden. Because your screenshot only shows the left end, it is not possible to see whether the control buttons are visible elsewhere. I see a hidden (collapsed) tab-drag-indicator in the source code in this area. *https://dxr.mozilla.org/mozilla-release/source/browser/base/content/tabbrowser.xml#14 *chrome://browser/skin/tabbrowser/tabDragIndicator.png
An bhfuil an freagra seo cabhrach? 0
Luaigh

Úinéir na ceiste

My_Cheese_Is_Slippin' said

Hi Priddles, Is it a Pinned Tab? Right click on it and see if there is an option to Unpin Tab.

Unfortunately not.

cor-el said

Do you see a tooltip if you hover this area? You can also check this area in customize mode. Are you possibly using a userChrome.css file? I would normally expect the window controls (minimize, maximize, close) to appear at the right end of the Tab bar when the Menu bar and Title bar are hidden. Because your screenshot only shows the left end, it is not possible to see whether the control buttons are visible elsewhere. I see a hidden (collapsed) tab-drag-indicator in the source code in this area.

I cannot interact with the box in any way. All actions are directed to the actual tab underneath. All my control buttons are present in the top-right corner of the window.

I have no idea what a userChrome.css file is. I'll Google that now.

EDIT: No, I am not using a userChrome.css.

EDIT2: I forgot to mention that the black box does show up in the customization screen, but is still just as intangible.

'''''My_Cheese_Is_Slippin' [[#answer-1242300|said]]''''' <blockquote> Hi Priddles, Is it a Pinned Tab? Right click on it and see if there is an option to Unpin Tab. </blockquote> Unfortunately not. '''''cor-el [[#answer-1242312|said]]''''' <blockquote> Do you see a tooltip if you hover this area? You can also check this area in customize mode. Are you possibly using a userChrome.css file? I would normally expect the window controls (minimize, maximize, close) to appear at the right end of the Tab bar when the Menu bar and Title bar are hidden. Because your screenshot only shows the left end, it is not possible to see whether the control buttons are visible elsewhere. I see a hidden (collapsed) tab-drag-indicator in the source code in this area. *https://dxr.mozilla.org/mozilla-release/source/browser/base/content/tabbrowser.xml#14 *chrome://browser/skin/tabbrowser/tabDragIndicator.png </blockquote> I cannot interact with the box in any way. All actions are directed to the actual tab underneath. All my control buttons are present in the top-right corner of the window. I have no idea what a ''userChrome.css'' file is. I'll Google that now. '''EDIT:''' No, I am not using a ''userChrome.css''. '''EDIT2:''' I forgot to mention that the black box does show up in the customization screen, but is still just as intangible.

Athraithe ag Priddles ar

An bhfuil an freagra seo cabhrach?
Luaigh
cor-el
  • Top 10 Contributor
  • Moderator
17418 réiteach 157376 freagra

Maybe check this in the Browser Toolbox.

Maybe check this in the Browser Toolbox. *https://developer.mozilla.org/en-US/Tools/Browser_Toolbox
An bhfuil an freagra seo cabhrach? 0
Luaigh

Úinéir na ceiste

cor-el said

Maybe check this in the Browser Toolbox.

Even with the Browser Toolbox, the stupid thing is intangible. Worse, I noticed it's been showing up on any Firefox window, including the Developer Tools window (when it's undocked).

''cor-el [[#answer-1242326|said]]'' <blockquote> Maybe check this in the Browser Toolbox. *https://developer.mozilla.org/en-US/Tools/Browser_Toolbox </blockquote> Even with the Browser Toolbox, the stupid thing is intangible. Worse, I noticed it's been showing up on any Firefox window, including the Developer Tools window (when it's undocked).
An bhfuil an freagra seo cabhrach?
Luaigh
Pranjal Jain 0 réiteach 2 freagra

Priddles said

cor-el said
Maybe check this in the Browser Toolbox.

Even with the Browser Toolbox, the stupid thing is intangible. Worse, I noticed it's been showing up on any Firefox window, including the Developer Tools window (when it's undocked).

I am facing the same problem since yesterday, the black box is not just in full screen it's everywhere, even the refresh dialog box which is tiny had a speck of black at the same position(upper-left corner) but it doesn't seem to appear in safe mode though, so this should mean that it is fixable by a refresh, right? WRONG, I refreshed my Firefox but the box is still there, right in my face, laughing at me. For the moment I am using FF in safe mode but I can't keep this up, life without my extensions(*cough*uBlock*cough*) is tough.

''Priddles [[#answer-1242355|said]]'' <blockquote> ''cor-el [[#answer-1242326|said]]'' <blockquote> Maybe check this in the Browser Toolbox. *https://developer.mozilla.org/en-US/Tools/Browser_Toolbox </blockquote> Even with the Browser Toolbox, the stupid thing is intangible. Worse, I noticed it's been showing up on any Firefox window, including the Developer Tools window (when it's undocked). </blockquote> I am facing the same problem since yesterday, the black box is not just in full screen it's everywhere, even the refresh dialog box which is tiny had a speck of black at the same position(upper-left corner) but it doesn't seem to appear in safe mode though, so this should mean that it is fixable by a refresh, right? WRONG, I refreshed my Firefox but the box is still there, right in my face, laughing at me. For the moment I am using FF in safe mode but I can't keep this up, life without my extensions(*cough*uBlock*cough*) is tough.
An bhfuil an freagra seo cabhrach? 0
Luaigh
cor-el
  • Top 10 Contributor
  • Moderator
17418 réiteach 157376 freagra
Can you locate this black box in the Browser Toolbox? *https://developer.mozilla.org/en-US/Tools/Browser_Toolbox *https://developer.mozilla.org/en-US/docs/Tools/Page_Inspector/How_to/Select_an_element#With_the_node_picker
An bhfuil an freagra seo cabhrach? 0
Luaigh
jscher2000
  • Top 10 Contributor
8637 réiteach 70667 freagra

Hi Priddles and Pranjal Jain, if a Refresh or manually disabling extensions didn't help, and you don't have a userChrome.css file, another feature of Firefox's Safe Mode is disabling Firefox from using hardware acceleration. This is a potential workaround for incompatibilities between Firefox and your graphics card/chipset driver software.

You could try that in "regular" mode to see whether it eliminates the black box. This article describes where to make that change: Firefox's performance settings. This will take effect the next time you exit Firefox and start it up again. Any difference?

Hi Priddles and Pranjal Jain, if a Refresh or manually disabling extensions didn't help, and you don't have a userChrome.css file, another feature of Firefox's Safe Mode is disabling Firefox from using hardware acceleration. This is a potential workaround for incompatibilities between Firefox and your graphics card/chipset driver software. You could try that in "regular" mode to see whether it eliminates the black box. This article describes where to make that change: [[Firefox's performance settings]]. This will take effect the next time you exit Firefox and start it up again. Any difference?
An bhfuil an freagra seo cabhrach? 1
Luaigh
My_Cheese_Is_Slippin'
  • Top 10 Contributor
56 réiteach 705 freagra

Hi Priddles, Something else that you can try: Launch firefox in Safe Mode (Restart with add-ons Disabled). Go into your extensions and disable all of them. Click on the three dot button and select Disable. Close Firefox. Start Firefox again normally. Is the box still absent?

Hi Priddles, Something else that you can try: Launch firefox in Safe Mode (Restart with add-ons Disabled). Go into your extensions and disable all of them. Click on the three dot button and select Disable. Close Firefox. Start Firefox again normally. Is the box still absent?
An bhfuil an freagra seo cabhrach? 0
Luaigh

Úinéir na ceiste

cor-el said

Can you locate this black box in the Browser Toolbox?

Already tried sadly. Cannot interact with the black box in any way. I couldn't find it in the HTML either.

''cor-el [[#answer-1242467|said]]'' <blockquote> Can you locate this black box in the Browser Toolbox? *https://developer.mozilla.org/en-US/Tools/Browser_Toolbox *https://developer.mozilla.org/en-US/docs/Tools/Page_Inspector/How_to/Select_an_element#With_the_node_picker </blockquote> Already tried sadly. Cannot interact with the black box in any way. I couldn't find it in the HTML either.
An bhfuil an freagra seo cabhrach?
Luaigh

Úinéir na ceiste

My_Cheese_Is_Slippin' said

Hi Priddles, Something else that you can try: Launch firefox in Safe Mode (Restart with add-ons Disabled). Go into your extensions and disable all of them. Click on the three dot button and select Disable. Close Firefox. Start Firefox again normally. Is the box still absent?

Have done this and more already. Please refer to original post.

''My_Cheese_Is_Slippin' [[#answer-1242749|said]]'' <blockquote> Hi Priddles, Something else that you can try: Launch firefox in Safe Mode (Restart with add-ons Disabled). Go into your extensions and disable all of them. Click on the three dot button and select Disable. Close Firefox. Start Firefox again normally. Is the box still absent? </blockquote> Have done this and more already. Please refer to original post.
An bhfuil an freagra seo cabhrach?
Luaigh

Úinéir na ceiste

jscher2000 said

Hi Priddles and Pranjal Jain, if a Refresh or manually disabling extensions didn't help, and you don't have a userChrome.css file, another feature of Firefox's Safe Mode is disabling Firefox from using hardware acceleration. This is a potential workaround for incompatibilities between Firefox and your graphics card/chipset driver software. You could try that in "regular" mode to see whether it eliminates the black box. This article describes where to make that change: Firefox's performance settings. This will take effect the next time you exit Firefox and start it up again. Any difference?

Thank you! This got rid of the black box.

Unfortunately, this is just a stop-gap solution and hopefully it will be eventually patched. I've been using Firefox on this machine for many months and it only started happening recently. I wonder if my graphics driver is to blame?

''jscher2000 [[#answer-1242742|said]]'' <blockquote> Hi Priddles and Pranjal Jain, if a Refresh or manually disabling extensions didn't help, and you don't have a userChrome.css file, another feature of Firefox's Safe Mode is disabling Firefox from using hardware acceleration. This is a potential workaround for incompatibilities between Firefox and your graphics card/chipset driver software. You could try that in "regular" mode to see whether it eliminates the black box. This article describes where to make that change: [[Firefox's performance settings]]. This will take effect the next time you exit Firefox and start it up again. Any difference? </blockquote> Thank you! This got rid of the black box. Unfortunately, this is just a stop-gap solution and hopefully it will be eventually patched. I've been using Firefox on this machine for many months and it only started happening recently. I wonder if my graphics driver is to blame?
An bhfuil an freagra seo cabhrach?
Luaigh
jscher2000
  • Top 10 Contributor
8637 réiteach 70667 freagra

Freagra Cabhrach

Hi Priddles, thank you for testing and reporting back. There may be some minor incompatibility with your graphics card/chipset driver software. (I say minor because Firefox is not crashing.)

Firefox 68 enabled a new feature called WebRender, so since it is graphics related, perhaps another workaround would be to disable only WebRender.

These are the related preferences, but I can't test it myself (WebRender isn't enabled on laptops, it seems):

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste webren and pause while the list is filtered

Near the bottom:

(3) If the gfx.webrender.enabled preference is true, double-click it to toggle it to false

(4) Double-click the gfx.webrender.force-disabled preference to switch the value from false to true

Meanwhile, re-enable hardware acceleration on the Options page, then exit and restart Firefox.

Any difference?

Hi Priddles, thank you for testing and reporting back. There may be some minor incompatibility with your graphics card/chipset driver software. (I say minor because Firefox is not crashing.) Firefox 68 enabled a new feature called WebRender, so since it is graphics related, perhaps another workaround would be to disable only WebRender. These are the related preferences, but I can't test it myself (WebRender isn't enabled on laptops, it seems): (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk. (2) In the search box above the list, type or paste '''webren''' and pause while the list is filtered ''Near the bottom:'' (3) If the '''gfx.webrender.enabled''' preference is true, double-click it to toggle it to false (4) Double-click the '''gfx.webrender.force-disabled''' preference to switch the value from false to true Meanwhile, re-enable hardware acceleration on the Options page, then exit and restart Firefox. Any difference?
An bhfuil an freagra seo cabhrach? 2
Luaigh

Réiteach Roghnaithe

jscher2000 said

Hi Priddles, thank you for testing and reporting back. There may be some minor incompatibility with your graphics card/chipset driver software. (I say minor because Firefox is not crashing.) Firefox 68 enabled a new feature called WebRender, so since it is graphics related, perhaps another workaround would be to disable only WebRender. These are the related preferences, but I can't test it myself (WebRender isn't enabled on laptops, it seems): (1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk. (2) In the search box above the list, type or paste webren and pause while the list is filtered Near the bottom: (3) If the gfx.webrender.enabled preference is true, double-click it to toggle it to false (4) Double-click the gfx.webrender.force-disabled preference to switch the value from false to true Meanwhile, re-enable hardware acceleration on the Options page, then exit and restart Firefox. Any difference?

gfx.webrender.enabled and gfx.webrender.force-disabled were both false and setting gfx.webrender.force-disabled to true did nothing.

However! Setting gfx.webrender.enabled to true seems to have fixed the problem entirely!

''jscher2000 [[#answer-1242818|said]]'' <blockquote> Hi Priddles, thank you for testing and reporting back. There may be some minor incompatibility with your graphics card/chipset driver software. (I say minor because Firefox is not crashing.) Firefox 68 enabled a new feature called WebRender, so since it is graphics related, perhaps another workaround would be to disable only WebRender. These are the related preferences, but I can't test it myself (WebRender isn't enabled on laptops, it seems): (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk. (2) In the search box above the list, type or paste '''webren''' and pause while the list is filtered ''Near the bottom:'' (3) If the '''gfx.webrender.enabled''' preference is true, double-click it to toggle it to false (4) Double-click the '''gfx.webrender.force-disabled''' preference to switch the value from false to true Meanwhile, re-enable hardware acceleration on the Options page, then exit and restart Firefox. Any difference? </blockquote> '''gfx.webrender.enabled''' and '''gfx.webrender.force-disabled''' were both ''false'' and setting '''gfx.webrender.force-disabled''' to ''true'' did nothing. However! Setting '''gfx.webrender.enabled''' to ''true'' seems to have fixed the problem entirely!

Athraithe ag Priddles ar

An bhfuil an freagra seo cabhrach? 3
Luaigh
Pranjal Jain 0 réiteach 2 freagra

Priddles said

gfx.webrender.enabled and gfx.webrender.force-disabled were both false and setting gfx.webrender.force-disabled to true did nothing. However! Setting gfx.webrender.enabled to true seems to have fixed the problem entirely!

This worked for me too!

''Priddles [[#answer-1242923|said]]'' <blockquote> '''gfx.webrender.enabled''' and '''gfx.webrender.force-disabled''' were both ''false'' and setting '''gfx.webrender.force-disabled''' to ''true'' did nothing. However! Setting '''gfx.webrender.enabled''' to ''true'' seems to have fixed the problem entirely! </blockquote> This worked for me too!
An bhfuil an freagra seo cabhrach? 1
Luaigh
B 0 réiteach 1 freagra

All I really had to do was turn off Firefox's performance settings in General >options

Performance Unchecked Use recommended performance settings Learn more These settings are tailored to your computer’s hardware and operating system. Unchecked Use hardware acceleration when available. and that solved my problem I did not have to change gfx.webrender.enabled or gfx.webrender.force-disabled How does Mozilla not support. Intel® HD Graphics 530 acceleration????????

All I really had to do was turn off Firefox's performance settings in General >options '''Performance''' Unchecked Use recommended performance settings Learn more These settings are tailored to your computer’s hardware and operating system. Unchecked Use hardware acceleration when available. and that solved my problem I did not have to change gfx.webrender.enabled or gfx.webrender.force-disabled How does Mozilla not support. Intel® HD Graphics 530 acceleration????????
An bhfuil an freagra seo cabhrach? 1
Luaigh
Cuir ceist

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.