Where did you install Firefox from? Help Mozilla uncover 3rd party websites that offer problematic Firefox installation by taking part in our campaign. There will be swag, and you'll be featured in our blog if you manage to report at least 10 valid reports!

Sykje yn Support

Mij stipescams. Wy sille jo nea freegje in telefoannûmer te beljen, der in sms nei ta te stjoeren of persoanlike gegevens te dielen. Meld fertochte aktiviteit mei de opsje ‘Misbrûk melde’.

Learn More

Dizze konversaasje is argivearre. Stel in nije fraach as jo help nedich hawwe.

Why are all my keyboard shortcuts using the "Alt" key instead of the "Ctrl" key? I'm using Windows 7 and Firefox 5.0.1.

  • 8 antwurd
  • 3 hawwe dit probleem
  • 3 werjeftes
  • Lêste antwurd fan jennifleac

more options

I recently downloaded Firefox 5 and noticed that all my keyboard shortcuts default to using "Alt" key instead of the "Ctrl" key (so, for example, opening a new tab is Alt + T instead of Ctrl + T).

I noticed that this is even true for copying and pasting within Firefox (Alt + C and Alt + P are the only commands that work).

Any idea why this is happening? I am running Windows 7 and Firefox 5.0.1.

I recently downloaded Firefox 5 and noticed that all my keyboard shortcuts default to using "Alt" key instead of the "Ctrl" key (so, for example, opening a new tab is Alt + T instead of Ctrl + T). I noticed that this is even true for copying and pasting within Firefox (Alt + C and Alt + P are the only commands that work). Any idea why this is happening? I am running Windows 7 and Firefox 5.0.1.

Keazen oplossing

I had this problem. I found that a Roaming profile directory was installed that contained a user.js file in it that changed the shortcut key from CTRL to ALT. I deleted the randomly-named profile folder in c:/Users/[myuser]/AppData/Roaming/Mozilla/Firefox/Profiles and then I pasted in the one from c:/Users/[myuser]/AppData/Local/Mozilla/Firefox/Profiles.

This bad user.js file was making a few other settings, including setting the user agent string to "Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.0; hi, Mom) Gecko/20020604"

The user.js file is (or was similar to) the one listed here: https://www-archive.mozilla.org/unix/customizing.html

Dit antwurd yn kontekst lêze 👍 1

Alle antwurden (8)

more options

You can check these prefs and if they are bold then reset them via the right-click context menu

To open the about:config page, type about:config in the location (address) bar and press the "Enter" key, just like you type the url of a website to open a website.
If you see a warning then you can confirm that you want to access that page.

  • Use the Filter bar at to top of the about:config page to locate a preference more easily.
  • Preferences that have been modified show as bold(user set).
  • Preferences can be reset to the default or changed via the right-click context menu.
more options

Neither of those preferences is bold. Any idea what else might be causing the shortcut change?

more options

An extension can change that behavior.

Start Firefox in Diagnose Firefox issues using Troubleshoot Mode to check if one of the extensions is causing the problem (switch to the DEFAULT theme: Firefox (Tools) > Add-ons > Appearance/Themes).

more options

It wasn't an extension or add-on. I had to manually set those ui.key... preferences in my user.js file. I'm not really sure why this was happening in the first place but I never had issues with Firefox on the Mac (this was the first time in a long time that I was using Firefox for PC).

To be quite honest, it seems far too complex of a solution (ie: if I wasn't a developer, would I have been able to figure it out? probably not). I wish the about:config would've worked but when I tried making changes there, they never stuck so I was forced to go in and edit the js file.

more options

It shouldn't be necessary to make such changes by using user.js to set prefs.
Either some prefs got corrupted or an extension or theme made those changes happen.

Did you copy any files in the Mac profile folder to the PC (Windows) profile folder?

more options

Nope, this was a clean install of Firefox.

more options

Keazen oplossing

I had this problem. I found that a Roaming profile directory was installed that contained a user.js file in it that changed the shortcut key from CTRL to ALT. I deleted the randomly-named profile folder in c:/Users/[myuser]/AppData/Roaming/Mozilla/Firefox/Profiles and then I pasted in the one from c:/Users/[myuser]/AppData/Local/Mozilla/Firefox/Profiles.

This bad user.js file was making a few other settings, including setting the user agent string to "Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.0; hi, Mom) Gecko/20020604"

The user.js file is (or was similar to) the one listed here: https://www-archive.mozilla.org/unix/customizing.html

Bewurke troch eveostay op

more options

Thanks, eveostay! That worked. (And for the record, what a crazy user agent string...)