Join the AMA (Ask Me Anything) with Firefox leadership team to talk about Firefox priorities in 2024. Mark your calendar! Thursday, June 13, 17:00 - 19:00 UTC.

Sykje yn Support

Mij stipescams. Wy sille jo nea freegje in telefoannûmer te beljen, der in sms nei ta te stjoeren of persoanlike gegevens te dielen. Meld fertochte aktiviteit mei de opsje ‘Misbrûk melde’.

Learn More

Dizze konversaasje is argivearre. Stel in nije fraach as jo help nedich hawwe.

cannot disable dark mode without changing theme

  • 4 antwurd
  • 1 hat dit probleem
  • 61 werjeftes
  • Lêste antwurd fan trav

more options

Hi. I'd like to have websites display as light mode but use a dark theme in Firefox. However, depending on if I'm using a dark or light theme, sites are all displaying light/dark according to the theme.

I have: browser.in-content.dark-mode set to false ui.systemUsesDarkTheme set to ""0"" widget.content.allow-gtk-dark-theme set to ""true"" widget.disable-dark-scrollbar set to ""true"" widget.gtk.alt-theme.dark set to ""false""

I'm on Fedora 34 with Firefox 95.0

I wonder if my profile might be corrupt? I was getting some crashes lately and when I restarted firefox sometimes it would load an older tab state. It's fine now when I quit and re-open... but I do wonder :/

thanks for your help!

Hi. I'd like to have websites display as light mode but use a dark theme in Firefox. However, depending on if I'm using a dark or light theme, sites are all displaying light/dark according to the theme. I have: browser.in-content.dark-mode set to '''false''' ui.systemUsesDarkTheme set to ""0"" widget.content.allow-gtk-dark-theme set to ""true"" widget.disable-dark-scrollbar set to ""true"" widget.gtk.alt-theme.dark set to ""false"" I'm on Fedora 34 with Firefox 95.0 I wonder if my profile might be corrupt? I was getting some crashes lately and when I restarted firefox sometimes it would load an older tab state. It's fine now when I quit and re-open... but I do wonder :/ thanks for your help!

Keazen oplossing

You can change this pref on the about:config page from 3 to 2 to revert to the Firefox 94 behavior.

  • layout.css.prefers-color-scheme.content-override
    Dark (0), light (1), system (2) or browser (3)

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

See also this pref:

  • ui.systemUsesDarkTheme [0:light; 1:dark; 2:no-preference]
Dit antwurd yn kontekst lêze 👍 0

Alle antwurden (4)

more options

Have you tried Firefox in Safe Mode? https://support.mozilla.org/en-US/kb/diagnose-firefox-issues-using-troubleshoot-mode#w_how-to-start-firefox-in-4troubleshoot-modesf5safe-modesf

Try downloading another copy of Firefox and run it from the folder. Do not sign into your Firefox account and see if you have the same issue.

https://www.mozilla.org/en-US/firefox/all/#product-desktop-release

more options

There have been many such reports. Evidently the default value of a preference was changed so you need to reset it. https://support.mozilla.org/en-US/questions/1360536#answer-1465159

more options

Keazen oplossing

You can change this pref on the about:config page from 3 to 2 to revert to the Firefox 94 behavior.

  • layout.css.prefers-color-scheme.content-override
    Dark (0), light (1), system (2) or browser (3)

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

See also this pref:

  • ui.systemUsesDarkTheme [0:light; 1:dark; 2:no-preference]
more options

cor-el said

You can change this pref on the about:config page from 3 to 2 to revert to the Firefox 94 behavior.
  • layout.css.prefers-color-scheme.content-override
    Dark (0), light (1), system (2) or browser (3)
You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue. See also this pref:
  • ui.systemUsesDarkTheme [0:light; 1:dark; 2:no-preference]

this was the about:config I was looking for: `layout.css.prefers-color-scheme.content-override`

thanks so much!!