Sykje yn Support

Mij stipescams. Wy sille jo nea freegje in telefoannûmer te beljen, der in sms nei ta te stjoeren of persoanlike gegevens te dielen. Meld fertochte aktiviteit mei de opsje ‘Misbrûk melde’.

Learn More

Dizze konversaasje is argivearre. Stel in nije fraach as jo help nedich hawwe.

If Google is my search default, do I have to go in and change it if I want to do a GMaps search; only the default is in the search drop box.

  • 10 antwurd
  • 1 hat dit probleem
  • 39 werjeftes
  • Lêste antwurd fan jscher2000

more options

If Google is my search default, do I have to go in and change it if I want to do a GMaps search; only the default is in the search drop box. So I have to change the default to Google Maps then back to Google for the one search.

Keazen oplossing

Got it! It was all about the about:config "hiddenoneoffs" where the 3 items google, maps and mcafee were included. There was no space between Google and Maps. I put one in i.e., Google Maps. It popped into the first one-ff box but no secure search in the second one-off box. Went back to the about:one-offs. Secure Search was shown with a space after Secure. I took out the Space. Secure search popped up in the 2nd one-off search box! Weird! This is contrary to how they show in Search Settings. I may have messed this when Firefox was resetting all search engines on an update but I don't think so. By the way I tried the Clean Re-instal but the file comes down as a .dmg which I am not familiar with and neither is Win 8.0 apparently because it could not open it. Thank you again.

Dit antwurd yn kontekst lêze 👍 0

Alle antwurden (10)

more options

The idea behind the design of the drop-down was to let you easily use a different search engine by clicking its icon, without changing your default. (Screen shot example attached.) Yours doesn't work that way?

If it's missing from the one-off buttons in the drop down, double-check that your Google Maps plugin is "checked" in the large scrolling box on the Options page, Search panel. That's the section below the default search engine setting.

more options

Understand and agree the search drop box was to let you do a one-off search with another engine and I am pretty certain I could do that at one time. Tools!Options!Search does include Google, Google Maps, and Mcafee and Google is set as my default but I only see Google in the search drop box which made me think I adjusted settings on the drop box itself so I right-clicked it and selected Put in the Menu. Gone. Don't know if it meant a Google Menu or a Firefox menu. Getting hazy with those two. Found it in Google icons and dragged it to the "menu bar" where it took up a new line the width of the screen. Deleted it. I can do a search in the url field now and Google(my default) searches but I still cannot do a one-off with Maps.

more options

Let's try to get your search bar back and see whether that works for you.

If you used right-click > Move to Menu, it should be in a square on the graphical application menu (the one you access using the "3-bar" menu button). If you find it there, you could right-click > Move to Toolbar to get it back close to where it was before.

Does that work?

If it's not there, or won't move, you could try using the "Restore defaults" button in the Customize screen. This will remove toolbar customizations and restore the original layout. Add-ons may or may not reposition there buttons in the default positions, but you can move them where you want them. This article has more information on using Customize: Customize Firefox controls, buttons and toolbars.

more options

My short search bar is back on the same line as the URL entry. Feelings of gratitude and grandeur BUT the search drop box still only drops Google even though I have defined Google, Google Maps, and McAfee Safe Search under Tools!Options!Search. I sense I have done something outside of the Tools menu. When I right click the actual drop box now it no longer show the option to move it to the Menu knowing of course what a bollicks I made of this the last time. Since I suspect I previously had the option to select one-off engines from the drop box and I have somehow screwed it, do you think I should just uninstal, re-download, and let whatever happens to me happen. I have children.

more options

Is the whole one-off section of your search bar drop-down missing? There are ways to customize Firefox to hide it, but if you didn't hide it on purpose, then it could be a program malfunction.

Did this problem start after a Firefox update? Sometimes Firefox is broken in weird, random ways after an update because of mixed files in the Firefox program folder. If there is no rational explanation for the problem, we recommend:

Clean Reinstall

We use this name, but it's not about removing your settings, it's about making sure the program files are clean (no inconsistent, corrupted, or alien code files). As described below, this process does not disturb your existing settings. Do NOT uninstall Firefox, that's not needed.

(A) Download a fresh installer for Firefox 42.0 from https://www.mozilla.org/firefox/all/ to a convenient location. (Scroll down to your preferred language.)

(B) Exit out of Firefox (if applicable).

(C) Rename just the current program folder, either:

(64-bit Windows folder names)

C:\Program Files (x86)\Mozilla Firefox

to

C:\Program Files (x86)\OldFirefox

(32-bit Windows folder names)

C:\Program Files\Mozilla Firefox

to

C:\Program Files\OldFirefox

(D) Run the installer you downloaded in (A). It should automatically connect to your existing settings.

Does Firefox work more normally?

Note: Some plugins may exist only in that OldFirefox folder. If something essential is missing, look in these folders:

  • \OldFirefox\Plugins
  • \OldFirefox\browser\plugins

Otherwise, there's no reason to keep the old folder except research/curiosity.

more options

Oh, regarding the right-click: if you right-click the area where you would be typing, you get a menu specific to the search bar. If you right-click the magnifying glass icon at the left end, then you get the generic menu for toolbar buttons.

If you have a "g" at the left end instead of a magnifying glass, you may have switched back to the older search bar style. That is an about:config setting:

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the search box that appears above the list, type or paste search and pause while the list is filtered

(3) If the browser.search.showOneOffButtons preference is bolded and "user set" to false, Double-click it to switch it back to true

This doesn't affect the current window, but each new window you open (Ctrl+n) will have the new Search bar.

more options

I do have the mag glass in the search box. I really thought altering the browser.search.showoneoffbuttons parameter was going to do it. Nope. Not even after restart. I did a Firefox refresh a few months ago not for this reason and I regretted it afterward so I am not inclined to do it again for this problem. I will live with it in the hope the next version/update will fix anything I might have done. Thank you for your kind interest and efforts.

more options

sanfranksisco said

I did a Firefox refresh a few months ago not for this reason and I regretted it afterward so I am not inclined to do it again for this problem.

I'm not sure a Refresh would help. But if you decide you can't put up with it, please try the Clean Reinstall (that doesn't touch your settings).

more options

Keazen oplossing

Got it! It was all about the about:config "hiddenoneoffs" where the 3 items google, maps and mcafee were included. There was no space between Google and Maps. I put one in i.e., Google Maps. It popped into the first one-ff box but no secure search in the second one-off box. Went back to the about:one-offs. Secure Search was shown with a space after Secure. I took out the Space. Secure search popped up in the 2nd one-off search box! Weird! This is contrary to how they show in Search Settings. I may have messed this when Firefox was resetting all search engines on an update but I don't think so. By the way I tried the Clean Re-instal but the file comes down as a .dmg which I am not familiar with and neither is Win 8.0 apparently because it could not open it. Thank you again.

more options

Glad to hear you got it straightened out.

For future reference, a DMG installer is for a Mac. There should be an EXE download for Windows users.