Rechercher dans l’assistance

Évitez les escroqueries à l’assistance. Nous ne vous demanderons jamais d’appeler ou d’envoyer un SMS à un numéro de téléphone ou de partager des informations personnelles. Veuillez signaler toute activité suspecte en utilisant l’option « Signaler un abus ».

Learn More

How to Disable Transparency in Menu Bar and Tabs

  • 6 réponses
  • 13 ont ce problème
  • 191 vues
  • Dernière réponse par Philip

more options

I have Firefox 35 installed on a Windows 8 pc. When Firefox last updated about a month ago, I think it went from about version 31 to the current 35. When this happened, all of my Inactive Tabs and the Menu Bar went completely transparent so I could not see what sites were in my Inactive Tabs and I could not even see the Min/Max/Close Window options at the top-right.

On the Windows 8 pc (my primary pc): - I only had a couple Extensions installed: Colorzilla, LastPass, WOT - I had only the Default Theme and 2 other Themes.

The Active Tab, Bookmarks Toolbar, & the URL still display fine with the default background color. I already tried using the Refresh Firefox tool. It removed my couple of Extensions & Themes, but the only other thing that changed is that now my Inactive Tabs are completely black instead of transparent so I still cannot see what sites they have open. The Menu Bar is still transparent.

I attached a screenshot. You can see the Black Inactive Tabs. I don't know if you can tell, but the Menu Bar is transparent.

I can't even use Firefox like this. Any ideas how to fix this?

FYI, I also have Firefox on a Windows 7 pc and it had no Extensions and no Themes installed at all and the same thing happened with the recent update. I tried the Refresh Firefox on this one and got the same exact result so it does not appear to be a Windows 8 issue.

Captures d’écran jointes

Toutes les réponses (6)

more options

Are there any customizations that have been added to the active profile?

  • For example, any user.js files that may change the color of the inactive tabs, or any themes that may be changing the default color?
  • Are there any Windows themes that do not show these tabs as black?

In the past versions this was an issue with the Windows themes with these settings: "dark color Windows theme, then in the Colors and Appearance dialog, slide the "Color intensity" slider all the way to the left" (bug 1004576)

Does changing the theme clear up the issue?

more options

I have not customized anything. All my other browsers are fine, it is only Firefox that has this issue and it's on 2 different pc's.

I have tried using the default theme and even downloaded, enabled, & disabled 3-4 other themes and none of them effect the transparency or the blacked out tabs.

more options

If this also does not happen in Safe ModeDiagnose Firefox issues using Troubleshoot Mode Please disable each extension one by one to make sure its not an extension. (extensions are not disabled in Safe Mode)

more options

Hi, I have the same or similar problem and think I can provide more info to troubleshoot.

  • As mentioned, it's not just black tabs/menu, but in full screen mode the top window bar shows an imprint/ghost of the previous full screen program. In other words, Windows is "painting" both Window bars. When you leave full screen mode, those areas and inactive tabs turn black.
  • I'm running Windows 8.1 fully patched, latest graphics card drivers.
  • I also have Thunderbird installed and it shows a similar issue with top window bar/tabs.
  • One of the causes appears to be Thunderbird reminders popping up. Sometimes the entire screen will go black for a second or two, and when it goes away the tab bar problem appears.
  • If the window is minimized, I don't think this problem happens, but if it's up - even if it's fully covered by another window - it appears.
  • New windows (Ctrl-N) will not show the problem.

Graphics info:

Graphics


Adapter Description: Intel(R) HD Graphics 4000 Adapter Description (GPU #2): NVIDIA GeForce GT 650M Adapter Drivers: igdumdim64 igd10iumd64 igd10iumd64 igdumdim32 igd10iumd32 igd10iumd32 Adapter Drivers (GPU #2): nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um Adapter RAM: Unknown Adapter RAM (GPU #2): 2048 Device ID: 0x0166 Device ID (GPU #2): 0x0fd1 DirectWrite Enabled: false (6.3.9600.17415) Driver Date: 9-30-2014 Driver Date (GPU #2): 4-8-2015 Driver Version: 10.18.10.3958 Driver Version (GPU #2): 9.18.13.5012 GPU #2 Active: false GPU Accelerated Windows: 0/3 Basic (OMTC) Subsys ID: 05781028 Subsys ID (GPU #2): 05781028 Vendor ID: 0x8086 Vendor ID (GPU #2): 0x10de WebGL Renderer: Google Inc. -- ANGLE (Intel(R) HD Graphics 4000 Direct3D11 vs_5_0 ps_5_0) windowLayerManagerRemote: true AzureCanvasBackend: skia AzureContentBackend: cairo AzureFallbackCanvasBackend: cairo AzureSkiaAccelerated: 0

more options

You can try to disable hardware acceleration in Firefox.

  • Tools > Options > Advanced > General > Browsing: "Use hardware acceleration when available"

You need to close and restart Firefox after toggling this setting.


If you use a non standard windows theme or made other appearance changes then try to revert those changes and use a (different) standard theme or Windows wallpaper.

  • Control Panel > Personalization > Theme & Window Color and Appearance
more options

Sorry, should have mentioned I already disabled hardware acceleration in both Firefox and Thunderbird (via advanced config). And verified it's not an extension or theme issue (never messed with themes).

I will add that when hardware acceleration was enabled, the browser "body" window would also be black. Now it's just the top bar, but still makes it unusable if you're used to tabs.