X
Appuyez ici pour vous rendre sur la version mobile du site.
An updated version of Firefox is available to address the issues with Add-ons disabled or fail to install on Firefox. You can download the update for your OS here: https://www.mozilla.org/firefox/new/ For Known Issues and Workarounds, please check out the update at https://support.mozilla.org/kb/add-ons-disabled-or-fail-to-install-firefox

Forum d’assistance

Why does v31.0 claim that it requires High Perf GPU on my MacBook Pro with Mavericks OS?

Publié

According to Activity Monitor, a utility that is part of Mavericks, Thunderbird requires the High Performance GPU on my MacBook Pro - it's the only program I run all the time that does. I think this is a new problem with this version and suspect it is a cause of increased battery drain.

According to Activity Monitor, a utility that is part of Mavericks, Thunderbird requires the High Performance GPU on my MacBook Pro - it's the only program I run all the time that does. I think this is a new problem with this version and suspect it is a cause of increased battery drain.

Solution choisie

I think I may have the solution.

The bug report here: https://bugzilla.mozilla.org/show_bug.cgi?id=693852 says in its last comment (8) that the "Hardware acceleration has now been disabled by default for TB 9".

It isn't disabled by default anymore.

However if I use the Config Editor to 'set layers.acceleration.disabled preference to "true"', as suggested in the first comment on bug 693852, the High Perf GPU problem goes away.

Lire cette réponse dans son contexte 2
Fabián Rodríguez 67 solutions 531 réponses

This may be caused by a specific extension.

To diagnose performance hogs caused by specific extensions, restart Thunderbird with add-ons disabled (Thunderbird Safe Mode).

On the Help menu, click on Restart with Add-ons Disabled. If Thunderbird works normally, there is an Add-on or Theme interfering with normal operations.

You will need to re-enable add-ons one at a time until you locate the offender.

This may be caused by a specific extension. To diagnose performance hogs caused by specific extensions, restart Thunderbird with add-ons disabled (Thunderbird Safe Mode). On the Help menu, click on '''Restart with Add-ons Disabled'''. If Thunderbird works normally, there is an Add-on or Theme interfering with normal operations. You will need to re-enable add-ons one at a time until you locate the offender.

Auteur de la question

Thank you for your reply.

Starting Thunderbird in Safe Mode does change the Activity Monitor status so that it reports that the High Performance GPU is no longer required.

Unfortunately when not in Safe Mode, but with all Add-ons (Plug-ins and Extensions) disabled the Activity Monitor again reports that the High Performance GPU is required - suggesting that it is a problem with the configuration of Thunderbird itself.

(I'm using the Default 31.0 theme.)

Thank you for your reply. Starting Thunderbird in Safe Mode does change the Activity Monitor status so that it reports that the High Performance GPU is no longer required. Unfortunately when not in Safe Mode, but with all Add-ons (Plug-ins and Extensions) disabled the Activity Monitor again reports that the High Performance GPU is required - suggesting that it is a problem with the configuration of Thunderbird itself. (I'm using the Default 31.0 theme.)

Modifié le par GBriggs

Toad-Hall
  • Top 10 Contributor
1647 solutions 10962 réponses

Have a look at this link: https://wiki.mozilla.org/Thunderbird:Testing:Memory_Usage_Problems

under 'Steps' heading there is quite a list of things to check.

Have a look at this link: https://wiki.mozilla.org/Thunderbird:Testing:Memory_Usage_Problems under 'Steps' heading there is quite a list of things to check.

Auteur de la question

Thank you. I've been through the steps, my memory usage appears to be quite normal. There was a suggestion to try a beta version but the only betas I can find are all older than the current version I have.

I also run Firefox 31.0 (with similar add-ons) and that does not exhibit the GPU problem at all.

The bug appears to be raised here: https://bugzilla.mozilla.org/show_bug.cgi?id=689742 . It starts life as an issue on OS X and turns into a fix for Windows. If it is the issue I'm seeing It doesn't fix OS X.

Thank you. I've been through the steps, my memory usage appears to be quite normal. There was a suggestion to try a beta version but the only betas I can find are all older than the current version I have. I also run Firefox 31.0 (with similar add-ons) and that does not exhibit the GPU problem at all. The bug appears to be raised here: [https://bugzilla.mozilla.org/show_bug.cgi?id=689742 https://bugzilla.mozilla.org/show_bug.cgi?id=689742] . It starts life as an issue on OS X and turns into a fix for Windows. If it is the issue I'm seeing It doesn't fix OS X.

Solution choisie

I think I may have the solution.

The bug report here: https://bugzilla.mozilla.org/show_bug.cgi?id=693852 says in its last comment (8) that the "Hardware acceleration has now been disabled by default for TB 9".

It isn't disabled by default anymore.

However if I use the Config Editor to 'set layers.acceleration.disabled preference to "true"', as suggested in the first comment on bug 693852, the High Perf GPU problem goes away.

I think I may have the solution. The bug report here: [https://bugzilla.mozilla.org/show_bug.cgi?id=693852 https://bugzilla.mozilla.org/show_bug.cgi?id=693852] says in its last comment (8) that the "Hardware acceleration has now been disabled by default for TB 9". It isn't disabled by default anymore. However if I use the Config Editor to 'set layers.acceleration.disabled preference to "true"', as suggested in the first comment on bug 693852, the High Perf GPU problem goes away.
Toad-Hall
  • Top 10 Contributor
1647 solutions 10962 réponses

I was just going through a load of bug reports when you found the answer ahead of me. Many thanks for the excellent reporting and feedback. I'm sure this could be of assistance to others.

I was just going through a load of bug reports when you found the answer ahead of me. Many thanks for the excellent reporting and feedback. I'm sure this could be of assistance to others.
Fabián Rodríguez 67 solutions 531 réponses

Hello,

I am glad to hear that your problem has been resolved. If you haven't already, please select the answer that solves the problem. This will help other users with similar problems find the solution more easily.

Thank you for contacting Mozilla Support.

Hello, I am glad to hear that your problem has been resolved. If you haven't already, please select the answer that solves the problem. This will help other users with similar problems find the solution more easily. Thank you for contacting Mozilla Support.