Voir les fichiers PDF dans Firefox sans les télécharger

Firefox comprend un lecteur PDF intégré qui permet d'afficher les fichiers PDF dans la fenêtre du navigateur. Cet article explique comment utiliser le lecteur PDF intégré, comment utiliser un autre lecteur de PDF et comment corriger les problèmes courants que vous pourriez rencontrer.

Utiliser le lecteur PDF intégré

Firefox comprend un lecteur PDF intégré qui vous permet de visualiser la majorité des fichiers PDF du Web, sans recourir à un plugin. Le lecteur PDF intégré est activé par défaut.

lecteur-pdf.png

Fonctions de la barre d'outils du lecteur PDF

  • Voir les vignettes des pages ou les signets du document - Le bouton à l'extrême gauche ouvre un panneau latéral avec les vignettes des pages du document. Certains documents possèdent également des signets qui sont affichables. À l'aide de ces derniers, vous pouvez naviguer facilement dans un long document.
    panneau-latéral-lecteur-pdf.png
  • Naviguer - Vous pouvez utiliser les flèches vers le bas et vers le haut pour avancer ou reculer d'une page ou saisir le numéro de la page sur laquelle vous voulez aller.
    naviguer-lecteur-pdf.png
  • Changer la taille du document - Utilisez les boutons + et - pour agrandir ou réduire le document ou choisissez un réglage de zoom avec le menu déroulant.
    zoom-lecteur-pdf.png
  • Mode présentation - Cliquez sur le bouton du mode présentation pour autoriser le fichier PDF à s'afficher sur tout l'écran. Appuyez sur Échap pour sortir du mode présentation.
    PDF Fullscreen
  • Imprimer - Cliquez sur le bouton de l'imprimante pour ouvrir la boîte de dialogue des paramètres d'impression.
    PDF Print
  • Télécharger - Cliquez sur le bouton de téléchargement pour enregistrer le fichier PDF sur votre ordinateur ou l'ouvrir avec un programme lecteur de PDF.
    PDF Download
  • Copier l'affichage courant - Faites un clic droitMaintenez la touche Ctrl enfoncée pendant que vous cliquez sur le bouton d'affichage courant pour ouvrir le document dans un autre onglet ou une autre fenêtre.
    PDF Copy

Raccourcis claviers du lecteur PDF

Commande Raccourci
Page suivante N ou K ou
Page précédente P ou J ou
Zoom avant Ctrl + +commande + +
Zoom arrière Ctrl + -commande + -
Zoom automatique Ctrl + 0commande + 0
Rotation horaire du document R
Rotation anti-horaire Maj + R

Résoudre des problèmes avec le lecteur PDF

  • Avec certains types de fichiers PDF, le lecteur PDF peut avoir des problèmes pour afficher les polices, les couleurs ou le document en entier. Si certains fichiers PDF s'affichent mal ou sont vierges, cliquez sur le bouton de téléchargement à droite de l'en-tête du document afin de l'ouvrir avec l'application lecteur de PDF par défaut sur votre ordinateur.

Utiliser un autre lecteur PDF

Vous pouvez utiliser un lecteur de PDF différent de celui intégré, si vous préférez. Pour passer du lecteur PDF intégré à un autre lecteur de PDF :

  1. En haut de la fenêtre de Firefox, cliquez sur le bouton Firefox, puis sélectionnez Options.En haut de la fenêtre de Firefox, cliquez sur le menu Outils, puis sélectionnez Options.Sur la barre de menus, cliquez sur le menu Firefox, puis sélectionnez Préférences….En haut de la fenêtre de Firefox, cliquez sur le menu Édition, puis sélectionnez Préférences.

    Cliquez sur le bouton de menu New Fx Menu et sélectionnez OptionsPréférences

  2. Sélectionnez le panneau Applications.
  3. Trouvez Portable Document Format (PDF) dans la liste et cliquez sur le type de contenu pour le sélectionner.
  4. Cliquez sur la flèche du menu déroulant dans la colonne Action pour le type de contenu ci-dessus. Comme option, Action affiche Aperçu dans Firefox lorsque vous utilisez le lecteur PDF intégré.
    • Pour utiliser une application externe pour visualiser les fichiers PDF, sélectionnez comme option l'application PDF que vous souhaitez utiliser, comme Utiliser Aperçu or Utiliser Adobe Reader.
    • Pour utiliser un plugin disponible pour visualiser les fichiers PDF dans Firefox, sélectionnez Utiliser nom plugin PDF (dans Firefox).
Attention : le plugin « Adobe Acrobat NPAPI Plug-in » est connu pour causer des problèmes dans Firefox. Pour plus de détails, consultez Les fichiers PDF sont vides et ne peuvent être téléchargés sur Mac.

Utiliser un plugin lecteur PDF

Attention : Mozilla prévoit d'abandonner la prise en charge de tous les plugins NPAPI excepté Flash en mars 2017, quand sera publiée la version 52 de Firefox. Consultez cet article (en anglais) et ce billet de blog pour avoir davantage de détails.

Ce qui suit ne s'applique pas à Firefox 64-bit, qui a une prise en charge plugin limitée.

Vous pouvez utiliser un plugin PDF comme Adobe Acrobat, Lecteur de PDF Nitro ou Sumatra PDF comme Adobe Acrobat, MozPlugger, ou KParts plugin, si disponible, pour visualiser les fichiers PDF dans Firefox. Si vous avez déjà installé un plugin lecteur de PDF, mais vous avez des problèmes en l'utilisant dans Firefox, essayez ces solutions :

Activer le plugin PDF

Votre plugin PDF est peut-être désactivé dans Firefox. Pour l'activer :

  1. En haut de la fenêtre Firefox, cliquez sur le bouton FirefoxSur la barre de menus, cliquez sur le menu OutilsEn haut de la fenêtre Firefox, cliquez sur le menu Outils, puis cliquez sur Modules complémentaires. L'onglet du « Gestionnaire de modules complémentaires » s'ouvre. Cliquez sur le bouton menu New Fx Menu et choisissez Modules. L'onglet du « Gestionnaire de modules complémentaires » s'ouvre.

  2. Dans l'onglet du « Gestionnaire de modules complémentaires », sélectionnez le panneau Catalogue.
  3. Sélectionnez votre plugin PDF.
  4. Sélectionnez Toujours Activer dans son menu déroulant.

Réinitialiser les actions de téléchargement

  1. Ouvrez votre dossier de profil :

    En haut de la fenêtre Firefox, cliquez sur le bouton Firefox, allez sur le menu AideSur la barre de menus, cliquez sur le menu AideEn haut de la fenêtre Firefox, cliquez sur le menu Aide, puis sélectionnez Informations de dépannage. L'onglet « Informations de dépannage » s'ouvre.Cliquez sur le bouton menu New Fx Menu , puis cliquez sur le bouton Aide Help-29 et sélectionnez Informations de dépannage. L'onglet « Informations de dépannage » s'ouvre.

  2. Sous la section Paramètres de base de l'application, cliquez sur le bouton Afficher le dossierOuvrir le dossierAfficher dans le FinderOuvrir le dossier correspondant. Une fenêtre avec vos fichiersvotre dossier de profil s'ouvre.
  3. Note : si vous n'arrivez pas à ouvrir ou utiliser Firefox, suivez les instructions dans Trouver votre profil sans ouvrir Firefox.

  4. En haut de la fenêtre, cliquez sur le bouton Firefox, puis sélectionnez QuitterEn haut de la fenêtre de Firefox, cliquez sur le menu Fichier, puis sélectionnez QuitterSur la barre de menus, cliquez sur le menu Firefox, puis sélectionnez Quitter FirefoxEn haut de la fenêtre de Firefox, cliquez sur le menu Fichier, puis sélectionnez Quitter

    Cliquez sur le bouton de menu New FX Menu puis, en bas du menu, cliquez sur le bouton Quitter bouton Quitter Firefox fx29

  5. Supprimez (ou renommez) le fichier mimetypes.rdf.

Autres solutions

  • Si le plugin PDF est fourni avec une application, vérifiez les préférences de l'application pour voir si il y a un paramètre Internet pour activer le plugin ou pour afficher les fichiers PDF dans le navigateur.

Cet article vous a-t-il été utile ? Veuillez patienter…

Ces formidables personnes ont aidé à écrire cet article : Goofy_BZ, scoobidiver, Banban, irahal, nicodel, cecilebertin. Vous pouvez également aider - découvrez comment.