Gestion des profils dans Thunderbird

Thunderbird enregistre vos informations personnelles telles que les messages, les carnets d’adresses, les mots de passe et les préférences dans un ensemble de fichiers appelé « profil », qui est stocké dans un emplacement différent des fichiers de programme de Thunderbird. Bien qu’il soit possible d’utiliser de multiples profils, la majorité des utilisateurs se contentent d’utiliser le profil par défaut (voir Utiliser plusieurs profils utilisateurs pour plus d’informations).

Qu’est-ce qu’un profil ?

Dans Thunderbird, le profil enregistre principalement deux catégories de fichiers. Tout d’abord, il contient les mails stockés en local, et éventuellement des copies des messages situés sur le serveur (en fonction des paramètres de compte). Ensuite, il contient tous les changements effectués lors de l’utilisation de Thunderbird (par exemple, les entrées du carnet d’adresses, les filtres, les paramètres de compte, la configuration des barres d’outils…).

Lors de l’installation de Thunderbird, il crée un profil nommé « Utilisateur par défaut». Ce profil est utilisé automatiquement, à moins que vous n’utilisiez le Gestionnaire de Profils pour créer un nouveau profil.

Où mon profil est-il stocké ?

Les fichiers du profil sont stockés séparément des fichiers de programme de Thunderbird. C’est pourquoi la suppression ou la mise à jour de Thunderbird n’entraîne pas la perte des messages ou autres paramètres.

Chaque profil est stocké sur le disque dur dans un répertoire de profil. Ce répertoire est nommé suivant les conventions suivantes :

<chaine_aléatoire>.<nom_du_profil>

…où « <chaine_aléatoire> » est une suite de 8 lettres et chiffres générée aléatoirement par Thunderbird et « <nom_du_profil> » est le nom défini pour ce profil. L’emplacement du répertoire de profil varie en fonction du système d’exploitation utilisé (et aussi dans le cas où vous auriez défini un emplacement non standard lors de la création du profil) :

Récapitulation : l’emplacement du profil

%APPDATA%\Thunderbird\Profiles\xxxxxxxx.Utilisateur par défaut\

  • %APPDATA% est un raccourci pour l’accès direct au dossier de C :\Users\<nom d’utilisateur>\AppData\Roaming\C :\Documents and Settings\<nom d’utilisateur>\Application Data\, qui dépend de votre nom de compte d’utilisateur Windows

~/Library/Thunderbird/Profiles/xxxxxxxx.Utilisateur par défaut/

  • Le caractère tilde (~) se réfère à l’accueil du dossier de l’utilisateur courant, donc ~ / Library est le dossier / Macintosh HD / Users / <nom d’utilisateur> / Bibliothèque.

~/.thunderbird/xxxxxxxx.Utilisateur par défaut/

Comment trouver son profil ?

  1. Ouvrez le menu Aide, cliquez Informations de dépannage.
  2. Dans Paramètres de l’application, ligne Dossier de ProfilRépertoire de profil, cliquez sur Afficher le dossier Ouvrir le dossier correspondant Voir dans le FinderOuvrir le dossier correspondant.
  3. La fenêtre des fichiers de l’ explorateur Windows du Mac Finder vous montrera le nom du profil ainsi que le chemin du répertoire où il se trouve.

Trouver son profil sans lancer Thunderbird

Thunderbird place votre dossier de profil à cet emplacement su votre ordinateur, par défaut :
C:\Users\<nom d’utilisateur Windows>\AppData\Roaming\Thunderbird\Profiles\
Windows cache le dossier AppData par défaut, mais vous pouvez trouver votre dossier de profil ainsi :

  1. Pressez les touches Windows Key +R du clavier. La boîte de dialogue Exécuter s’ouvre.
  2. Saisissez-y :
    %APPDATA%\Thunderbird\Profiles\
  3. Cliquez sur OK. Une fenêtre s’ouvre contenant les dossiers de profil.
  4. Effectuez un double-clic sur le dossier de profil que vous souhaitez ouvrir. Si vous n’avez qu’un dossier de profil, son nom contient « défaut ».
  1. Dans l’écran de démarrage, cliquez sur la tuile Bureau. La vue du bureau s’affiche.
  2. Sur le bureau, survolez avec la souris le coin inférieur droit pour atteindre les charmes.
  3. Sélectionnez le charme Rechercher. La barre latérale de recherche s’affiche.
  4. Dans la zone de recherche, saisissez :
    %APPDATA%\Thunderbird\Profiles\
    sans presser la touche Entrée. Une liste des dossiers de profil apparaît.
  5. Cliquez sur celui que vous voulez ouvrir (il va s’ouvrir dans une fenêtre). Si vous n’avez qu’un dossier profil, son nom contient « défaut ».
  1. Cliquez sur le bouton Démarrer de Windows. Le menu Démarrer s’ouvre.
  2. Dans la zone de recherche au bas du menu Démarrer, saisissez :
    %APPDATA%\Thunderbird\Profiles\
    sans presser la touche Entrée. Une liste des profils apparaît en haut du menu Démarrer.
  3. Cliquez sur celui que vous voulez ouvrir (il va s’ouvrir dans une fenêtre). Si vous n’avez qu’un dossier profil, son nom contient « défaut ».
  • Autrement, vous pouvez trouver votre profil en pressant la touche Windows Key puis en commençant à saisir : %APPDATA%\Thunderbird\Profiles\
Remarque : pour paramétrer Windows pour qu’il affiche le dossier AppData et les autres dossiers et fichiers cachés, reportez-vous à l’article Afficher les fichiers cachés du support Windows.
  1. Cliquez sur le bouton Démarrer de Windows et choisissez Exécuter…

    win-run.png
  2. Saisissez :
    %APPDATA%\Thunderbird\Profiles\
    puis cliquez sur OK.
    Une fenêtre s’ouvre contenant les dossiers de profil.
    win-rundialog.png
  3. Effectuez un double-clic sur le dossier de profil que vous souhaitez ouvrir. Si vous n’avez qu’un dossier de profil, son nom contient « défaut ».
  1. Cliquez sur l’icône du Finder dans le dock. Sur la barre de menu, cliquez sur le menu Aller, maintenez pressée la touche option ou alt et sélectionnez Bibliothèque.
  2. Ouvrez le dossier Thunderbird puis le dossier Profiles.
  3. Votre dossier de profil s’y trouve. Si vous n’avez qu’un dossier de profil, son nom contient « défaut ».
  1. (Ubuntu) Cliquez sur le menu Emplacements en haut à droite de l’écran et choisissez Dossier personnel. Une fenêtre de navigateur de fichiers apparaît.
  2. Cliquez sur le menu Affichage et sélectionner Montrer les fichiers cachés si ce n’est pas déjà choisi.
  3. Effectuez un double clic sur le dossier nommé .thunderbird. Votre dossier de profil s’y trouve. Si vous n’avez qu’un dossier de profil, son nom contient « défaut ».


Sauvegarder un profil

Pour sauvegarder votre profil, quittez Thunderbird et ensuite faites un Copier/Coller du dossier contenant votre profil sur votre emplacement de sauvegarde (supports externes de préférence).

  1. Localisez votre profil comme expliqué ci-dessus (via le menu Aide).
  2. Quittez Thunderbird.
  3. Allez un niveau au-dessus du dossier de votre profil à savoir %APPDATA%\Thunderbird\Profiles\~/Library/Thunderbird/Profiles/~/.mozilla/Thunderbird/
  4. Clic droit sourisMaintenez la touche Ctrl tout en cliquant sur le dossier de votre profil (par exemple xxxxxxxx.Utilisateur par défaut), et sélectionnez Copier.
  5. Clic droit sourisMaintenez la touche Ctrl pendant que vous cliquez à l’emplacement de sauvegarde (par exemple un disque USB, une clé USB, ou un disque vierge CD-RW)), et sélectionnez Coller item.

Restaurer une sauvegarde

  1. Quittez Thunderbird
  2. Si votre dossier du profil existant et votre dossier du profil sauvegardé ont le même nom, remplacez simplement le dossier du profil existant par la sauvegarde du profil, puis démarrez Thunderbird.
    Important : les noms de dossier de profils doivent correspondre exactement, y compris la chaîne aléatoire de 8 caractères. Si les noms ne correspondent pas ou si vous restaurez une sauvegarde vers un autre emplacement, suivez les étapes ci-dessous.

Restaurer vers un autre emplacement

Si les noms de dossier du profil ne correspondent pas ou si vous souhaitez déplacer ou restaurer un profil à un autre emplacement, procédez comme suit :

  1. Fermez complètement Thunderbird.
  2. Utilisez le gestionnaire de profils de Thunderbird pour créer un nouveau profil dans votre emplacement désiré, puis quittez le gestionnaire de profils.
    Note : si vous venez d’installer Thunderbird sur un nouvel ordinateur, vous pouvez utiliser le profil par défaut qui est automatiquement créé lorsque vous exécutez Thunderbird, au lieu de créer un nouveau profil
    .
  3. Localisez le dossier du profil sauvegardé sur votre disque dur ou support de sauvegarde (par exemple, votre clé USB).
  4. Ouvrir le dossier de sauvegarde du profil (par exemple, xxxxxxxx.Utilisateur par défaut).
  5. Copiez tout le “contenu” de la sauvegarde du dossier, comme les fichiers mimeTypes.rdf, prefs.js, abook.mab etc.
  6. Localisez et ouvrez le nouveau dossier de profil comme expliqué ci-dessus (via le menu Aide) puis fermez Thunderbird (si ouvert).
  7. Cliquer sur le dossier Profiles (un niveau au-dessus du dossier de votre profil.
  8. Sélectionnez le dossier du profil que vous avez créé précédement (par exemple, xxxxxxxx.Utilisateur par défaut).
  9. Collez le contenu du dossier de profil sauvegardé dans le nouveau dossier de profil, écrasez les fichiers existants du même nom.
  10. Démarrez Thunderbird.

Déplacer un profil

Éventuellement, vous pourriez vouloir déplacer un profil ou demander à Thunderbird d’utiliser un profil stocké dans un autre emplacement.

  1. Quittez Thunderbird.
  2. Localisez votre profil comme expliqué ci-dessus (via le menu Aide).
  3. Cliquer sur le dossier Profiles (un niveau au-dessus du dossier de votre profil.
  4. Déplacez le dossier du profil à l’emplacement désiré. Par exemple, sur Windows, déplacer le profil de %AppData%\Thunderbird\Profiles\xxxxxxxx.Utilisateur par défaut vers D :\MonProfilTB . (Si vous retournez à un profil sauvegardé, cette étape n’est pas nécessaire. Il suffit de noter l’emplacement actuel du profil que vous souhaitez restaurer.)
  5. Ouvrez le fichier profiles.ini dans un éditeur de texte. Le fichier se trouve dans le dossier de données de Thunderbird :
    • Ce fichier est dans le dossier %AppData%\Thunderbird\  ; pour Windows~/.thunderbird/ ; pour Linux{filepath ~/Library/Thunderbird/} ; pour Mac OS X
  6. Dans le fichier profiles.ini, localisez la section du profil que vous venez de déplacer. Modifiez la ligne Path= pour indiquer le nouvel emplacement.
  7. Si vous passez d’un chemin relatif à un chemin non-relatif, la direction des barres obliques devra peut-être changer. Par exemple, dans Windows, des chemins non relatifs utilisent la barre oblique inverse (\), tandis que celles relatives utilisent le slash (/). Modifiez la ligne qui contient IsRelative=1 pour mettre ceci : IsRelative=0.
  8. Enregistrez profiles.ini, et redémarrez Thunderbird.

Voir aussi

// Ces formidables personnes ont aidé à écrire cet article :Vincent, Goofy, Banban, J2m06, Yanick, YD. Vous pouvez également aider — découvrez comment.

Cet article vous a-t-il été utile ? Veuillez patienter…

Devenir bénévole pour l’assistance de Mozilla