Les plugins Java, Silverlight, Adobe Acrobat ne marchent plus, pourquoi ?

La prise en charge des plugins NPAPI dans Firefox, à l'exception d'Adobe Flash, cessera à partir de mars 2017, lorsque la version 52 de Firefox sortira.Depuis la version 52 de Firefox, les plugins NPAPI, sauf Adobe Flash, ne sont plus pris en charge. Parmi les plugins qui ne seront plus pris en charge, on trouve : Java, Microsoft Silverlight et Adobe Acrobat. Consultez ce document sur la compatibilité (en anglais) pour davantage d'informations.

Au cours de ces dernières années, Firefox a mis en œuvre diverses API web pour que les sites web puissent faire les mêmes choses que d'habitude mais sans les plugins, de sorte que vous ne puissiez pas ressentir de différence dans vos habitudes de navigation.

Pourquoi Firefox se comporte-t-il ainsi ?

Internet regorge de sites web qui vont bien au-delà des pages statiques, avec des vidéos, des sons, des jeux… Les plugins NPAPI, et Flash en particulier, ont contribué à l'émergence de ces pages interactives. Toutefois, ils ont aussi rendu votre navigation plus lente, moins sûre et plus susceptible de planter.

Ces derniers temps, Firefox a travaillé dur pour créer des substituts de ces plugins. Leur nom générique est API web. Ils sont conçus pour remplacer les fonctions de ces plugins sans dégrader la sécurité, les performances et la stabilité de votre navigateur.

Auparavant, ces API web n'étaient pas tout à fait prêtes, alors Firefox a commencé la transition en chargeant les plugins manuellement (avec un clic pour les activer).

Aujourd'hui, elles sont prêtes. Beaucoup de sites les ont adoptées et presque toutes vos pages préférées peuvent être appréciées sans utiliser des plugins anciens et dangereux. Firefox rejoint la politique des autres navigateurs modernes comme Google Chrome et Microsoft Edge pour mettre fin à la prise en charge de ces plugins NPAPI.

Je rencontre des problèmes

Dans le cas où vous ne seriez pas encore prêt⋅e pour cette transition, l'ESR (Extended Support Release) de Firefox 52 continuera à prendre en charge ces plugins jusqu'au début de 2018. Rendez-vous sur cette page pour télécharger Firefox ESR.

Important : La version 64 bits pour Windows de Firefox 52 ESR ne prend en charge que les plugins Adobe Flash et Microsoft Silverlight. Si vous avez aussi besoin de Java ou d'autres plugins, optez pour le téléchargement de la version 32 bits pour Windows.

Par défaut, Firefox 52 ESR utilisera les mêmes données de profil utilisateur que les autres versions de Firefox. Installer Firefox 52 ESR après avoir utilisé la version 55 de Firefox ou supérieure peut causer des problèmes comme des messages d'erreur, des éléments de Firefox cassés et des problèmes avec certains sites web. Vous devez soit créer un nouveau profil à utiliser avec Firefox 52 ESR soit réinitialiser Firefox après l'installation de Firefox 52 ESR.

Cet article vous a-t-il été utile ? Veuillez patienter…

Ces formidables personnes ont aidé à écrire cet article : Goofy_BZ, Mozinet, irahal, cecilebertin, user1378574. Vous pouvez également aider - découvrez comment.