Diagnostiquer et résoudre des problèmes de Firefox

Beaucoup de problèmes avec Firefox peuvent être résolus avec les procédures de résolution des problèmes décrites ci-dessous. Essayez-les dans l'ordre. Si une ne fonctionne pas, passez à la suivante. Si vous avez besoin d'aide supplémentaire, posez votre question.

1. Redémarrer votre ordinateur

Parfois, les problèmes peuvent être simplement résolus en redémarrant votre ordinateur, puis en démarrant de nouveau Firefox.

2. Effacer vos cookies et votre cache

Beaucoup de problèmes de chargement de pages web peuvent être résolus en effaçant les cookies et le cache de Firefox.

  1. En haut de la fenêtre de Firefox, cliquez sur le bouton Firefox, survolez le menu Historique, puis sélectionnez Supprimer l'historique récent…Sur la barre de menus, cliquez sur le menu Outils, puis sélectionnez Supprimer l'historique récent…En haut de la fenêtre de Firefox, cliquez sur le menu Outils, puis sélectionnez Supprimer l'historique récent…
  2. Dans la liste déroulante Intervalle à effacer : , sélectionnez tout.
  3. Cliquez sur la flèche à gauche de Détails pour afficher la liste des éléments susceptibles d'être supprimés.
  4. Sélectionnez Cookies et Cache.
  5. Cliquez sur Effacer maintenant
  1. En haut de la fenêtre de Firefox, cliquez sur le bouton Firefox, survolez le menu Historique, puis sélectionnez Supprimer l'historique récent…Sur la barre de menus, cliquez sur le menu Historique, puis sélectionnez Supprimer l'historique récent…En haut de la fenêtre de Firefox, cliquez sur le menu Historique, puis sélectionnez Supprimer l'historique récent…
  2. Dans la liste déroulante Intervalle à effacer : , sélectionnez tout.
  3. Cliquez sur la flèche à gauche de Détails pour afficher la liste des éléments susceptibles d'être supprimés.
  4. Sélectionnez Cookies et Cache.
  5. Cliquez sur Effacer maintenant
  1. Cliquez sur le bouton menu New Fx Menu , puis sur Historique et sélectionnez Effacer l'historique récent…
  2. Dans la liste déroulante Intervalle à effacer : , sélectionnez tout.
  3. Cliquez sur la flèche à gauche de Détails pour afficher la liste des éléments susceptibles d'être effacés.
  4. Sélectionnez Cookies et Cache.
  5. Cliquez sur Effacer maintenant
Pour plus d'informations, consultez Supprimer l’historique récent de navigation, des recherches et des téléchargements.

3. Redémarrer Firefox en mode sans échec

Le mode sans échec de Firefox est un mode de diagnostic qui désactive toutes les extensions et l'accélération graphique matérielle, utilise le thème par défaut et les paramètres des barres d'outils par défaut, entre autres choses. Pour démarrer Firefox en mode sans échec :

  1. En haut de la fenêtre de Firefox, cliquez sur le bouton Firefox, survolez le menu AideSur la barre de menus, cliquez sur le menu AideEn haut de la fenêtre de Firefox, cliquez sur le menu Aide?, puis sélectionnez Redémarrer, modules désactivés…. Firefox démarrera alors avec la boite de dialogue du mode sans échec de Firefox.
    Note : Vous pouvez également démarrer Firefox en mode sans échec en maintenant la touche Maj enfoncée tout en démarrant Firefox.maintenant la touche Option () enfoncée tout en démarrant Firefox.quittant Firefox, puis en ouvrant un Terminal et en exécutant : firefox -safe-mode
    Il vous sera peut-être nécessaire de spécifier le chemin d'installation de Firefox (par exemple /usr/lib/firefox).
    Cliquez sur le bouton menu New Fx Menu , puis cliquez sur Help-29 et sélectionnez Redémarrer, modules désactivés…. Firefox démarrera avec la boîte de dialogue Mode sans échec.
    Note : Vous pouvez aussi démarrer Firefox en mode sans échec en maintenant la touche Maj appuyée au démarrage de Firefox. maintenant la touche Option () appuyée au démarrage de Firefox.quittant Firefox puis aller dans la fenêtre Terminal pour y saisir la ligne de commande : firefox -safe-mode
    Il est possible que vous ayez à saisir le chemin vers le répertoire d'installation de Firefox (p. ex. /usr/lib/firefox)
  2. Dans la boîte de dialogue du mode sans échec, cliquez sur Démarrer en mode sans échec
  3. Vérifiez si votre problème se produit encore en mode sans échec.

4. Diagnostiquer vos plugins

Parfois, les plugins utilisés dans Firefox (comme Adobe Reader, Flash, Java, Silverlight et QuickTime) peuvent causer des problèmes. Souvent, c'est parce qu'ils ne sont pas à jour. Pour vérifier si vous avez les dernières versions des plugins, rendez-vous sur la page de vérification des plugins de Mozilla. Si un de vos plugins n'est pas à jour, cliquez sur Mettre à jour, puis suivez les instructions pour mettre à jour ce plugin. Après avoir mis à jour tous vos plugins, redémarrez Firefox :

En haut de la fenêtre, cliquez sur le bouton Firefox, puis sélectionnez QuitterEn haut de la fenêtre de Firefox, cliquez sur le menu Fichier, puis sélectionnez QuitterSur la barre de menus, cliquez sur le menu Firefox, puis sélectionnez Quitter FirefoxEn haut de la fenêtre de Firefox, cliquez sur le menu Fichier, puis sélectionnez Quitter

Cliquez sur le bouton de menu New FX Menu puis, en bas du menu, cliquez sur le bouton Quitter bouton Quitter Firefox fx29

puis démarrez Firefox de nouveau. Si le problème persiste, désactivez tous vos plugins pour voir si l'un d'entre eux est en cause :

  1. En haut de la fenêtre Firefox, cliquez sur le bouton FirefoxSur la barre de menus, cliquez sur le menu OutilsEn haut de la fenêtre Firefox, cliquez sur le menu Outils, puis cliquez sur Modules complémentaires. L'onglet du « Gestionnaire de modules complémentaires » s'ouvre. Cliquez sur le bouton menu New Fx Menu et choisissez Modules. L'onglet du « Gestionnaire de modules complémentaires » s'ouvre.

  2. Dans l'onglet du « Gestionnaire de modules complémentaires », sélectionnez le panneau Plugins.
  3. Cliquez sur chaque plugin dans la liste, puis choisissez Ne jamais activer dans le menu déroulant.
  4. Vérifiez si votre problème se produit quand tous vos plugins sont désactivés.

Si votre problème est parti quand tous vos plugins ont été désactivés, consultez l'article Résoudre des problèmes de Firefox avec les plugins comme Flash ou Java pour apprendre à affiner la cause.

5. Réinstaller Firefox

Certains problèmes de Firefox peuvent être causés par un problème avec un des fichiers du programme Firefox. Suivez cette procédure pour supprimer et réinstaller complètement Firefox. Ceci ne supprimera pas les données de votre profil Firefox (comme les marque-pages et mots de passe) ; ces informations sont désormais enregistrées à un autre endroit.

Note : vous devriez imprimer cette procédure ou l'afficher dans un autre navigateur.
  1. Téléchargez la dernière version officielle de Firefox depuis mozilla.org/firefox.
  2. Quittez Firefox :

    En haut de la fenêtre, cliquez sur le bouton Firefox, puis sélectionnez QuitterEn haut de la fenêtre de Firefox, cliquez sur le menu Fichier, puis sélectionnez QuitterSur la barre de menus, cliquez sur le menu Firefox, puis sélectionnez Quitter FirefoxEn haut de la fenêtre de Firefox, cliquez sur le menu Fichier, puis sélectionnez Quitter

    Cliquez sur le bouton de menu New FX Menu puis, en bas du menu, cliquez sur le bouton Quitter bouton Quitter Firefox fx29

  3. Désinstaller Firefox de votre ordinateur.
  4. Supprimez le dossier du programme de Firefox qui est par défaut :
    • C:\Program files\Mozilla Firefox
    • C:\Program Files (x86)\Mozilla Firefox
  5. Réinstallez Firefox - consultez Installer Firefox sous Windows pour les instructions.
  1. Téléchargez la dernière version officielle de Firefox depuis mozilla.org/firefox.
  2. Quittez Firefox :

    En haut de la fenêtre, cliquez sur le bouton Firefox, puis sélectionnez QuitterEn haut de la fenêtre de Firefox, cliquez sur le menu Fichier, puis sélectionnez QuitterSur la barre de menus, cliquez sur le menu Firefox, puis sélectionnez Quitter FirefoxEn haut de la fenêtre de Firefox, cliquez sur le menu Fichier, puis sélectionnez Quitter

    Cliquez sur le bouton de menu New FX Menu puis, en bas du menu, cliquez sur le bouton Quitter bouton Quitter Firefox fx29

  3. # Désinstaller Firefox de votre ordinateur en ouvrant le dossier « Applications » dans le « Finder » et en déposant l'application Firefox dans la corbeille.
  4. Réinstallez Firefox - consultez Installer Firefox sur Mac pour les instructions.
  1. Téléchargez la dernière version officielle de Firefox depuis mozilla.org/firefox.
  2. Quittez Firefox :

    En haut de la fenêtre, cliquez sur le bouton Firefox, puis sélectionnez QuitterEn haut de la fenêtre de Firefox, cliquez sur le menu Fichier, puis sélectionnez QuitterSur la barre de menus, cliquez sur le menu Firefox, puis sélectionnez Quitter FirefoxEn haut de la fenêtre de Firefox, cliquez sur le menu Fichier, puis sélectionnez Quitter

    Cliquez sur le bouton de menu New FX Menu puis, en bas du menu, cliquez sur le bouton Quitter bouton Quitter Firefox fx29

  3. Désinstallez Firefox - si vous avez installé Firefox avec le gestionnaire de paquets basé sur la distribution, vous devriez utiliser le même moyen pour le désinstaller - consultez Installer Firefox sous Linux pour les détails. Si vous avez téléchargé et installé le paquet binaire depuis la page de téléchargement de Firefox, supprimez simplement le dossier firefox dans votre répertoire d'accueil pour désinstaller Firefox.
  4. Réinstallez Firefox - consultez Installer Firefox sous Linux pour les instructions.

Maintenant, démarrez Firefox et vérifiez si votre problème est résolu. Si ce n'est pas le cas, continuez avec la procédure suivante de résolution des problèmes.

6. Réinitialiser Firefox

La fonction de réinitialisation de Firefox peut résoudre de nombreux problèmes en restaurant votre profil Firefox à son état par défaut tout en sauvegardant vos informations essentielles.

Note : lors de la procédure de réparation, vos marque-pages, historique de navigation, onglets ouverts, fenêtres, mots de passe, cookies et informations auto-complétées de formulaires web sont sauvegardés. Cependant, les extensions et thèmes que vous avez installés seront supprimés et vos préférences seront réinitialisées.lors de la procédure de réinitialisation, vos marque-pages, historique de navigation, onglets ouverts, fenêtres, mots de passe, cookies et informations auto-complétées de formulaires web sont sauvegardés. Cependant, les extensions et thèmes que vous avez installés seront supprimés et vos préférences seront réinitialisées. lors de la procédure de réinitialisation, vos marque-pages, historique de navigation, mots de passe, cookies et informations auto-complétées de formulaires web sont sauvegardés. Cependant, les extensions et thèmes seront supprimés ; les fenêtres, onglets et groupes d'onglets ouverts ne seront pas sauvegardés et vos préférences seront réintialisées. En savoir plus….
  1. Cliquez directement sur ce bouton Rafraîchir Firefox, si vous voyez cette page dans Firefox.
    Ceci ne fonctionnera pas si vous utilisez un autre navigateur ou un appareil mobile.
    • Vous pouvez également trouver un bouton Réparer Firefox en haut à droite de la fenêtre about:support intitulée Informations de dépannage
  2. Pour continuer, cliquez sur Réparer Firefox dans la fenêtre de confirmation qui s'ouvre.
  3. Firefox se ferme alors et se réinitialise. Une fois l'opération terminée, une fenêtre s'affiche, listant les données importées. Cliquez sur Terminer pour que Firefox se rouvre.

Note : il existe aussi un bouton Réparer Firefox dans la fenêtre du mode sans échec, si vous ne parvenez pas à démarrer Firefox normalement. S'il vous est impossible de trouver le bouton Réparer Firefox dans votre version du navigateur, vous pouvez aussi pratiquer une réinitialisation manuelle en créant un nouveau profil. L'article Utiliser le gestionnaire de profils pour créer et supprimer les profils de Firefox vous indique comment faire.

6. Réinitialiser Firefox

La fonction de réinitialisation de Firefox peut résoudre de nombreux problèmes en restaurant votre profil Firefox à son état par défaut tout en sauvegardant vos informations essentielles.

Note : lors de la procédure de réparation, vos marque-pages, historique de navigation, onglets ouverts, fenêtres, mots de passe, cookies et informations auto-complétées de formulaires web sont sauvegardés. Cependant, les extensions et thèmes que vous avez installés seront supprimés et vos préférences seront réinitialisées.lors de la procédure de réinitialisation, vos marque-pages, historique de navigation, onglets ouverts, fenêtres, mots de passe, cookies et informations auto-complétées de formulaires web sont sauvegardés. Cependant, les extensions et thèmes que vous avez installés seront supprimés et vos préférences seront réinitialisées. lors de la procédure de réinitialisation, vos marque-pages, historique de navigation, mots de passe, cookies et informations auto-complétées de formulaires web sont sauvegardés. Cependant, les extensions et thèmes seront supprimés ; les fenêtres, onglets et groupes d'onglets ouverts ne seront pas sauvegardés et vos préférences seront réintialisées. En savoir plus….
  1. Cliquez directement sur ce bouton Rafraîchir Firefox, si vous voyez cette page dans Firefox.
    Ceci ne fonctionnera pas si vous utilisez un autre navigateur ou un appareil mobile.
    • Vous pouvez également trouver un bouton Réparer Firefox en haut à droite de la fenêtre about:support intitulée Informations de dépannage
  2. Pour continuer, cliquez sur Réparer Firefox dans la fenêtre de confirmation qui s'ouvre.
  3. Firefox se ferme alors et se réinitialise. Une fois l'opération terminée, une fenêtre s'affiche, listant les données importées. Cliquez sur Terminer pour que Firefox se rouvre.

Note : il existe aussi un bouton Réparer Firefox dans la fenêtre du mode sans échec, si vous ne parvenez pas à démarrer Firefox normalement. S'il vous est impossible de trouver le bouton Réparer Firefox dans votre version du navigateur, vous pouvez aussi pratiquer une réinitialisation manuelle en créant un nouveau profil. L'article Utiliser le gestionnaire de profils pour créer et supprimer les profils de Firefox vous indique comment faire.

7. Créer un nouveau profil Firefox

Il peut arriver que certains fichiers de votre profil Firefox – contenant des informations essentielles que la réparationrestauration de Firefox ne supprime pas (comme les marque-pages et l'historique de navigation) – posent des problèmes. Vous pouvez créer un nouveau profil supplémentaire qui ne contiendra aucune des données du précédent. Consultez Utiliser le gestionnaire de profils pour créer et supprimer les profils de Firefox pour savoir comment faire.

Autres solutions

Si vous avez essayé toutes ces procédures de résolution des problèmes et que vous en avez encore, le problème peut être dû à un autre logiciel ou à votre matériel.

Cette section ne contient pas d'instructions pas à pas. Pour plus d'informations sur n'importe laquelle de ces solutions, veuillez consulter la documentation associée.

Vérifier les conflits avec votre logiciel de sécurité Internet

Certains logiciels de sécurité Internet (incluant les programmes antivirus, ceux contre les logiciels espions et les pare-feux) peuvent causer des problèmes avec Firefox, notamment le blocage de sites web, des plantages, etc. Souvent, vous pouvez ouvrir les paramètres du programme, supprimer Firefox de la liste des programmes sûrs ou autorisés, puis le laisser détecter de nouveau Firefox, les choses fonctionneront alors de nouveau. Si votre programme est listé dans l'article Configurer les pare-feux afin que Firefox puisse accéder à Internet, vous pouvez obtenir des instructions spécifiques sur la manière de le reconfigurer correctement.

Analyser votre système à la recherche de virus et logiciels espions

Périodiquement, vous devriez faire une analyse de votre système à la recherche de virus, logiciels espions ou autres logiciels malveillants. Ces outils de suppression de logiciels malveillants gratuits sont souvent utiles :

Si vous avez besoin de plus d'aide pour supprimer les logiciels malveillants, consultez Résoudre des problèmes de Firefox causés par des logiciels malveillants.

Vérifier les erreurs sur votre disque dur et la mémoire vive

Un problème avec le disque dur ou la mémoire vive (RAM) de votre ordinateur peut empêcher Firefox de s'exécuter ou le faire planter de manière répétée. Voici des instructions ou utilitaires pour vérifier :



Basé sur des informations de Standard diagnostic - Firefox (mozillaZine KB)

Cet article vous a-t-il été utile ? Veuillez patienter…

Ces formidables personnes ont aidé à écrire cet article : Goofy_BZ, scoobidiver, Banban, Mozinet, irahal. Vous pouvez également aider - découvrez comment.