Corriger les problèmes de connexion aux sites Internet qui nécessitent un identifiant et un mot de passe

Si vous constatez que vous ne pouvez pas vous connecter à un site web qui demande un identifiant et un mot de passe, suivez les étapes décrites dans cet article.

Activer les cookies pour le site web

Assurez-vous que les cookies sont activés pour le site en question :

  1. En haut de la fenêtre de Firefox, cliquez sur le bouton Firefox, puis sélectionnez OptionsEn haut de la fenêtre de Firefox, cliquez sur le menu Outils, puis sélectionnez OptionsSur la barre de menus, cliquez sur le menu Firefox, puis sélectionnez Préférences…En haut de la fenêtre de Firefox, cliquez sur le menu Édition, puis sélectionnez Préférences

    Cliquez sur le bouton menu New Fx Menu et sélectionnez OptionsPréférences

  2. Sélectionnez le panneau Vie privée.

  3. Dans la zone Historique, pour l'option Règles de conservation, sélectionnez utiliser les paramètres personnalisés pour l'historique. sélectionnez Firefox utilise des paramètres personnalisés pour l'historique
    utiliser-paramètres-personnalisés-historique.png

    Custom History - Mac

    Custom History - Linux

    Utiliser paramètres personnalisés historique Fx21

    Custom History Fx21 Mac

    Custom History Fx21 Linux
  4. Assurez-vous que la case Accepter les cookies est cochée.
  5. Assurez-vous que la case Accepter les cookies tiers est cochée.
    • Désactiver les cookies tiers peut causer des problèmes avec certains sites web. Activer ce paramètre pour l'exclure comme origine de votre problème.
  6. Cliquez sur Exceptions….
  7. Assurez-vous que le site auquel vous essayez d'accéder n'est pas listé.
    • S'il est listé, cliquez sur son entrée, puis cliquez sur Supprimer le site.
  8. Cliquez sur OK pour fermer la fenêtre « Options »Cliquez sur Fermer pour fermer la fenêtre « Préférences »Fermez la fenêtre « Préférences » .
  1. En haut de la fenêtre de Firefox, cliquez sur le bouton Firefox, puis sélectionnez OptionsEn haut de la fenêtre de Firefox, cliquez sur le menu Outils, puis sélectionnez OptionsSur la barre de menus, cliquez sur le menu Firefox, puis sélectionnez Préférences…En haut de la fenêtre de Firefox, cliquez sur le menu Édition, puis sélectionnez Préférences

    Cliquez sur le bouton menu New Fx Menu et sélectionnez OptionsPréférences

    .
  2. Sélectionnez le panneau Vie privée.

  3. Dans la zone Historique, pour l'option Règles de conservation, sélectionnez utiliser les paramètres personnalisés pour l'historique. sélectionnez Firefox utilise des paramètres personnalisés pour l'historique
    utiliser-paramètres-personnalisés-historique.png

    Custom History - Mac

    Custom History - Linux

    Utiliser paramètres personnalisés historique Fx21

    Custom History Fx21 Mac

    Custom History Fx21 Linux
  4. Assurez-vous que la case Accepter les cookies est cochée.
  5. Assurez-vous que la case Accepter les cookies tiers est positionnée à Toujours.
    • Désactiver les cookies tiers peut causer des problèmes avec certains sites web. Toujours accepter les cookies tiers permet de l'exclure comme origine possible de votre problème.
  6. Cliquez sur Exceptions….
  7. Assurez-vous que le site auquel vous essayez d'accéder n'est pas listé.
    • S'il est listé, cliquez sur son entrée, puis sur le bouton Supprimer le site.
  8. Cliquez sur OK pour fermer la fenêtre « Options »Cliquez sur Fermer pour fermer la fenêtre « Préférences »Fermez la fenêtre « Préférences » .

Si vous avez changé n'importe quel paramètre, essayez de vous connecter de nouveau au site.

Effacer l'historique pour ce site

Les cookies et données temporaires déjà stockés sur votre ordinateur peuvent causer le problème. Supprimez-les, puis testez votre problème :

  1. En haut de la fenêtre Firefox, cliquez sur le bouton Firefox, allez sur le menu Historique, puis sélectionnez Afficher l'historique pour ouvrir la fenêtre « Bibliothèque ».Sur la barre de menus, cliquez sur le menu Historique, puis sélectionnez Afficher l'historique pour ouvrir la fenêtre « Bibliothèque ».En haut de la fenêtre de Firefox, cliquez sur le menu Historique, puis sélectionnez Afficher l'historique pour ouvrir la fenêtre « Bibliothèque ».

    Cliquez sur le bouton menu New Fx Menu , sélectionnez Historique puis cliquez sur Afficher l'historique en bas de la liste pour ouvrir la fenêtre « Bibliothèque ».

  2. Dans le coin supérieur droit, saisissez le nom du site web que vous souhaitez oublier dans le champ Rechercher dans l'historique, puis appuyez sur EntréeRetour.
  3. Dans la liste résultante, faites un clic droitmaintenez la touche Ctrl enfoncée pendant que vous cliquez sur le site que vous souhaitez oublier, puis sélectionnez Oublier ce site.
    fenêtre-bibliothèque-oublier-site.png

    History Mac6

    History Lin6
  4. Fermez la fenêtre « Bibliothèque ».

Effacer tous les cookies et le cache

Si l'effacement des cookies pour le site à problèmes n'a pas corrigé l'erreur, effacez tous les cookies stockés sur votre ordinateur, ainsi que le cache de Firefox :

  1. En haut de la fenêtre de Firefox, cliquez sur le bouton Firefox, survolez le menu Historique, puis sélectionnez Supprimer l'historique récent…Sur la barre de menus, cliquez sur le menu Outils, puis sélectionnez Supprimer l'historique récent…En haut de la fenêtre de Firefox, cliquez sur le menu Outils, puis sélectionnez Supprimer l'historique récent…
  2. Dans la liste déroulante Intervalle à effacer : , sélectionnez tout.
  3. Cliquez sur la flèche à gauche de Détails pour afficher la liste des éléments susceptibles d'être supprimés.
  4. Sélectionnez Cookies et Cache.
  5. Cliquez sur Effacer maintenant
  1. En haut de la fenêtre de Firefox, cliquez sur le bouton Firefox, survolez le menu Historique, puis sélectionnez Supprimer l'historique récent…Sur la barre de menus, cliquez sur le menu Historique, puis sélectionnez Supprimer l'historique récent…En haut de la fenêtre de Firefox, cliquez sur le menu Historique, puis sélectionnez Supprimer l'historique récent…
  2. Dans la liste déroulante Intervalle à effacer : , sélectionnez tout.
  3. Cliquez sur la flèche à gauche de Détails pour afficher la liste des éléments susceptibles d'être supprimés.
  4. Sélectionnez Cookies et Cache.
  5. Cliquez sur Effacer maintenant
  1. Cliquez sur le bouton menu New Fx Menu , puis sur Historique et sélectionnez Effacer l'historique récent…
  2. Dans la liste déroulante Intervalle à effacer : , sélectionnez tout.
  3. Cliquez sur la flèche à gauche de Détails pour afficher la liste des éléments susceptibles d'être effacés.
  4. Sélectionnez Cookies et Cache.
  5. Cliquez sur Effacer maintenant

Vérifier les extensions et plugins

Des extensions peuvent causer des problèmes avec la connexion aux sites web, particulièrement les extensions associées avec certains sites web. Par exemple :

Certains plugins peuvent également causer des problèmes de connexion aux sites web. Consultez l'article Résoudre des problèmes de Firefox avec les plugins comme Flash ou Java pour des instructions sur la manière de déterminer quel plugin est à l'origine de votre problème.

L'application de sécurité bloque les cookies

Certaines applications de sécurité Internet et de protection de la vie privée ont des fonctionnalités qui bloquent les cookies. Vérifiez la documentation fournie avec votre logiciel ou consultez le site d'assistance du fournisseur du logiciel pour voir si votre application comprend une fonctionnalité de contrôle de cookie et comment vous pouvez changer ces paramètres.

Supprimer le fichier de cookies corrompu

Si vous ne pouvez pas vous connecter aux sites web après la suppression de ses cookies, l'effacement de votre cache de Firefox, la désactivation des extensions et des plugins et la vérification du logiciel de sécurité, vous pouvez avoir un fichier des cookies corrompu dans votre dossier de profil de Firefox.

Ceci supprimera tous vos cookies stockés et vous déconnectera de toutes les sessions enregistrées sur tous les sites web.
  1. Ouvrez votre dossier de profil :

    En haut de la fenêtre Firefox, cliquez sur le bouton Firefox, allez sur le menu AideSur la barre de menus, cliquez sur le menu AideEn haut de la fenêtre Firefox, cliquez sur le menu Aide, puis sélectionnez Informations de dépannage. L'onglet « Informations de dépannage » s'ouvre.Cliquez sur le bouton menu New Fx Menu , puis cliquez sur le bouton Aide Help-29 et sélectionnez Informations de dépannage. L'onglet « Informations de dépannage » s'ouvre.

  2. Sous la section Paramètres de base de l'application, cliquez sur le bouton Ouvrir le dossier correspondantAfficher dans le FinderOuvrir le dossier correspondant. Une fenêtre avec vos fichiersvotre dossier de profil s'ouvre.
  3. Note : Si vous n'arrivez pas à ouvrir ou utiliser Firefox, suivez les instructions dans Trouver votre profil sans ouvrir Firefox.

  4. En haut de la fenêtre, cliquez sur le bouton Firefox, puis sélectionnez QuitterEn haut de la fenêtre de Firefox, cliquez sur le menu Fichier, puis sélectionnez QuitterSur la barre de menus, cliquez sur le menu Firefox, puis sélectionnez Quitter FirefoxEn haut de la fenêtre de Firefox, cliquez sur le menu Fichier, puis sélectionnez Quitter

    Cliquez sur le bouton menu New FX Menu puis, en bas du menu, cliquez sur le bouton Quitter bouton Quitter Firefox fx29

  5. Supprimez le fichier cookies.sqlite et tous les fichiers cookies.sqlite-journal.
  6. Redémarrez Firefox.




Basé sur des informations de Websites report cookies are disabled (mozillaZine KB)



Partager cet article : http://mzl.la/OzTeNj

Cet article vous a-t-il été utile ? Veuillez patienter…

Ces formidables personnes ont aidé à écrire cet article : Goofy_BZ, scoobidiver, irahal. Vous pouvez également aider - découvrez comment.