Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

ChromeOS Firefox - hardware acceleration

more options

I just got a chromebook! Details:

Device name: Lenovo Flex 3 12.2" chromebook, 8GB ram. Intel N100 Device code name: IP Flex 3 CB 12 (pujjo, version 123.15786.0) Firefox version: 124.0.2 (flatpak) OS version: Version 123.0.6312.112 (Official Build) (64-bit) Chrome: Version 123.0.6312.112 (Official Build) (64-bit)

When I watch a youtube video with chrome my cpu usage is 20-30% When I do the same with firefox my cpu usage is 50%

Running `about:support` and going into `webrender_compositor` I get the following errors under `env`: 1. Blocklisted by gfxInfo 2. Blocklisted; failure code 3. FEATURE_FAILURE_WEBRENDER_COMPOSITOR_DISABLED

I have set almost all these force renders = True and even granted gpu access to firefox flathub but still no difference in performance. I am asking now because I am just going in circles in the rabbit hole.

I just got a chromebook! Details: Device name: Lenovo Flex 3 12.2" chromebook, 8GB ram. Intel N100 Device code name: IP Flex 3 CB 12 (pujjo, version 123.15786.0) Firefox version: 124.0.2 (flatpak) OS version: Version 123.0.6312.112 (Official Build) (64-bit) Chrome: Version 123.0.6312.112 (Official Build) (64-bit) When I watch a youtube video with chrome my cpu usage is 20-30% When I do the same with firefox my cpu usage is 50% Running `about:support` and going into `webrender_compositor` I get the following errors under `env`: 1. Blocklisted by gfxInfo 2. Blocklisted; failure code 3. FEATURE_FAILURE_WEBRENDER_COMPOSITOR_DISABLED I have set almost all these force renders = True and even granted gpu access to firefox flathub but still no difference in performance. I am asking now because I am just going in circles in the rabbit hole.

All Replies (2)

more options

Don't force-enable the compositor, revert those settings back to default.

For more efficient video playback, you need hardware accelerated decoding. Change media.ffmpeg.vaapi.enabled to true in about:config then restart the browser.

Check your hardware support for different video codecs in about:support:

HARDWARE_VIDEO_DECODING
VP8_HW_DECODE
VP9_HW_DECODE
H264_HW_DECODE
AV1_HW_DECODE


You can disable codecs that are not supported in hardware (eg media.av1.enabled set to false).

Flatpak needs ffmpeg to be installed for best results with a runtime that matches Firefox (23.08):

flatpak install org.freedesktop.Platform.ffmpeg-full//23.08

Helpful?

more options

I reset chrome by pressing `refresh firefox` under `give firefox a tune-up` in `about:support`. I followed everything you said and attached is the screenshot of supported codecs firefox and chrome.

In firefox it says hardware decoding is not supported but it is in chrome.

Modified by FirefoxFanWhisky

Helpful?

یک سؤال بپرسید

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.