Back up and restore information in Firefox profiles

No one has helped translate this article yet. If you already know how localizing for SUMO works, start translating now. If you want to learn how to translate articles for SUMO, please start here.

Mozilla Firefox stores all your personal settings, such as bookmarks, passwords and extensions, in a profile folder on your computer, in a location separate from the Firefox program. This article explains how to back up your profile, restore it, or move your profile to a new location or computer.

Locate your profile folder

At the top of the Firefox window, click on the Firefox button, go over to the Help menuOn the menu bar, click on the Help menuAt the top of the Firefox window, click on the Help menu and select Troubleshooting Information. The Troubleshooting Information tab will open.Click the menu button New Fx Menu , click help Help-29 and select Troubleshooting Information. The Troubleshooting Information tab will open.

  • Under the Application Basics section, click on Show FolderShow in FinderOpen Directory. A window with your profile filesfolder will open.
  • Note: If you are unable to open or use Firefox, follow the instructions in Finding your profile without opening Firefox.

    Backing up your profile

    To back up your profile, first close Firefox if it is open and then copy the profile folder to another location.

    1. At the top of the Firefox window, click on the Firefox button and then select ExitAt the top of the Firefox window, click on the File menu and then select ExitOn the menu bar, click on the Firefox menu and select Quit FirefoxAt the top of the Firefox window, click on the File menu and select Quit

      Click the menu button New Fx Menu and then click ExitQuit Close 29

    2. Locate your profile folder, as explained above.
    3. Go to one level above your profile's folder, i.e. to %APPDATA%\Mozilla\Firefox\Profiles\~/Library/Application Support/Firefox/Profiles/~/.mozilla/firefox/
    4. Right-clickHold down the Ctrl key while you click on your profile folder (e.g. xxxxxxxx.default), and select Copy.
    5. Right-clickHold down the Ctrl key while you click the backup location (e.g. a USB-stick or a blank CD-RW disc), and select Paste item.

    Restoring a profile backup

    1. At the top of the Firefox window, click on the Firefox button and then select ExitAt the top of the Firefox window, click on the File menu and then select ExitOn the menu bar, click on the Firefox menu and select Quit FirefoxAt the top of the Firefox window, click on the File menu and select Quit

      Click the menu button New Fx Menu and then click ExitQuit Close 29

    2. If your existing profile folder and profile backup folder have the same name, simply replace the existing profile folder with the profile backup, then start Firefox.
      Important: The profile folder names must match exactly for this to work, including the random string of 8 characters. If the names do not match or if you are restoring a backup to a different location, follow the steps below.

    Restoring to a different location

    If the profile folder names do not match or if you want to move or restore a profile to a different location, do the following:

    1. Completely close Firefox, as explained above.
    2. Use the Firefox Profile Manager to create a new profile in your desired location, then exit the Profile Manager.
      Note: If you just installed Firefox on a new computer, you can use the default profile that is automatically created when you first run Firefox, instead of creating a new profile.
    3. Locate the backed up profile folder on your hard drive or backup medium (e.g., your USB-stick).
    4. Open the profile folder backup (e.g., the xxxxxxxx.default backup).
    5. Copy the entire contents of the profile folder backup, such as the mimeTypes.rdf file, prefs.js file, bookmarkbackups folder, etc.
    6. Locate and open the new profile folder as explained above and then close Firefox (if open).
    7. Paste the contents of the backed up profile folder into the new profile folder, overwriting existing files of the same name.
    8. Start Firefox.


    Share this article: http://mzl.la/1xKrFsk

    این مقاله مفید بود؟ لطفاً صبر کنید...

    These fine people helped write this article: AliceWyman, Chris_Ilias, Tonnes, Verdi, scoobidiver, Swarnava, PetjaTouru, greasemonkey, Matt_G, deb.bhattacharya6, erinereardon. You can help too - find out how.