Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Tab Close button "X" on hover

  • 2 vastust
  • 2 on selline probleem
  • 394 views
  • Viimati vastas Neo2x

more options

Till version 112 I used this in my userChrome.css to get back the close buttons on tabs, but only when I hover over them (active or inactive tabs): .tab-close-button{ display: none } .tabbrowser-tab:not([pinned]):hover .tab-close-button{

   display: -moz-box !important

}

But now with version 113.0.1 it doesn't work at all and no X appears when I hover over my tabs.

I tried adding #tabbrowser-tabs[closebuttons="activetab"] on top of the previous code, but it made the X appear all the time.

How could I update this code so I get the desired result only when I hover over a tab?

Till version 112 I used this in my userChrome.css to get back the close buttons on tabs, but only when I hover over them (active or inactive tabs): .tab-close-button{ display: none } .tabbrowser-tab:not([pinned]):hover .tab-close-button{ display: -moz-box !important } But now with version 113.0.1 it doesn't work at all and no X appears when I hover over my tabs. I tried adding #tabbrowser-tabs[closebuttons="activetab"] on top of the previous code, but it made the X appear all the time. How could I update this code so I get the desired result only when I hover over a tab?

Valitud lahendus

Try this code:

.tabbrowser-tab:not([pinned]) .tab-close-button {
  display: none !important
}
.tabbrowser-tab:not([pinned]):hover .tab-close-button {
  display: inline-flex !important
}

Loe vastust kontekstis 👍 3

All Replies (2)

more options

Valitud lahendus

Try this code:

.tabbrowser-tab:not([pinned]) .tab-close-button {
  display: none !important
}
.tabbrowser-tab:not([pinned]):hover .tab-close-button {
  display: inline-flex !important
}

more options

Thank you! That did it :D.