Buscar en Ayuda

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

imesh.com's search toolbar preventing display of Firefox's home page. imesh's uninstall doesn't completely remove their software. Same problems with other browsers. Is Firefox aware of this problem, and what are they doing to address this matter?

  • 5 respuestas
  • 68 tienen este problema
  • 1 visita
  • Última respuesta de Malaika545

more options

Dear Firefox,

      Recently, I had a difficult time removing the imesh search toolbar from your browser, and also other browsers.  Imesh/imesh.com’s uninstall doesn’t completely remove the imesh software, and it takes over the browser, preventing the browser from displaying its homepage.  You can search imesh online with any search engine and find many topics about them.  Is Firefox aware of this problem, and what are they doing to address this matter?

Sincerely, Chuck Lara/Logolinkads.com

Solución elegida

To revert to Google as your preferred search engine, please do the following.

  • In the location bar, type about:config and hit Enter.

  • In the filter at the top, type: keyword.URL

  • Double click it and remove whatever's in there and replace it with http://www.google.com/search?q=

The URL to add in "keyword.URL" becomes a link in this post, so right click it and choose "Copy Link Location" to copy it to the Windows clipboard. Then hit CTRL+V to paste it. Saves you having to type the whole thing.


To reset your home page, do the following.

  • Go to the site you want to set as your homepage.

  • Click the orange Firefox button and go to Options | Options | General.

  • Make sure it says "Show My Homepage" in the first dropdown menu.

  • Click the button called "Use Current Pages" to set the homepage to the one you have on the screen.

After you complete the above steps, install this add-on to prevent another search engine from modifying your preferences: https://addons.mozilla.org/en-US/firefox/addon/browserprotect/

Leer esta respuesta en su contexto 👍 7

Todas las respuestas (5)

more options

Solución elegida

To revert to Google as your preferred search engine, please do the following.

  • In the location bar, type about:config and hit Enter.

  • In the filter at the top, type: keyword.URL

  • Double click it and remove whatever's in there and replace it with http://www.google.com/search?q=

The URL to add in "keyword.URL" becomes a link in this post, so right click it and choose "Copy Link Location" to copy it to the Windows clipboard. Then hit CTRL+V to paste it. Saves you having to type the whole thing.


To reset your home page, do the following.

  • Go to the site you want to set as your homepage.

  • Click the orange Firefox button and go to Options | Options | General.

  • Make sure it says "Show My Homepage" in the first dropdown menu.

  • Click the button called "Use Current Pages" to set the homepage to the one you have on the screen.

After you complete the above steps, install this add-on to prevent another search engine from modifying your preferences: https://addons.mozilla.org/en-US/firefox/addon/browserprotect/

more options

Thanks Xircal for the solution to remove imesh from Firefox.

more options

Ok guys i had this problem too you need to uninstall a program called mediabar. search for it (start,search) than type mediabar try to delete. if you cant enter the folder and click uninstall.

more options

Hey. I have trouble with I-mesh, i have do all things posted up here to solve (remoove) that toolbar but wont help me. :( Wont change the url, at restart its all the same

more options

I finally got rid of imesh. Had to clean up all the little files it left lying around including uninstalling it Mediabar. Then unistalled Firefox including all memorized info--passwords, etc. What a pain. Then I reinstalled it. No more imesh.

Hate those nasty programs that hang around when you are done with them!