X
Toca aquí para ir a una versión del sitio para dispositivos móviles.

Foro de asistencia

Screen Tearing on firefox 55.0.3

Publicadas

when ever i scroll up or down there is screen tearing within firefox, i've tried with addons disabled and i've disabled hardware acceleration and it's still tearing. i'm on win 10 64bit, using geforce experience with nvidia driver 385.41 (latest at the moment) and firefox is the 32bit version. taking screen shots isn't possible so please don't request that.

when ever i scroll up or down there is screen tearing within firefox, i've tried with addons disabled and i've disabled hardware acceleration and it's still tearing. i'm on win 10 64bit, using geforce experience with nvidia driver 385.41 (latest at the moment) and firefox is the 32bit version. taking screen shots isn't possible so please don't request that.

Solución elegida

Every solution to this problem that I've found so far is all about disabling hardware acceleration or updating grapics drivers - none of which worked for you.

Would you please check this setting :

3-bar menu (or 'Tools') => Advanced => General tab => under 'Browsing': 'Disable smooth scrolling' should be unchecked (at least that worked for some others)


Another thing to try :

Type in the address bar about:config (press Enter) (promise to be careful, if asked) Type and look for the preference : gfx.font_rendering.directwrite.force-enabled and set its value to true

However : if that doesn't make a difference, change the value back to false

Leer esta respuesta en su contexto 3

Datos adicionales del sistema

Plugins instalados

  • Shockwave Flash 26.0 r0

Aplicación

  • Firefox 55.0.3
  • Agente de usuario: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:55.0) Gecko/20100101 Firefox/55.0
  • URL de asistencia: https://support.mozilla.org/1/firefox/55.0.3/WINNT/en-GB/

Extensiones

  • MEGA 3.15.6 (firefox@mega.co.nz)
  • uBlock Origin 1.14.4 (uBlock0@raymondhill.net)
  • Adblock Plus 2.9.1 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}) (inactivo)
  • Bitdefender Wallet 21.1.10 (bdwtwe@bitdefender.com) (inactivo)
  • Logitech SetPoint 6.5 ({F003DA68-8256-4b37-A6C4-350FA04494DF}) (inactivo)

JavaScript

  • incrementalGCEnabled: True

Gráficos

  • adapterDescription: NVIDIA GeForce GTX 980 Ti
  • adapterDescription2:
  • adapterDeviceID: 0x17c8
  • adapterDeviceID2:
  • adapterDrivers: C:\WINDOWS\System32\DriverStore\FileRepository\nv_dispi.inf_amd64_ce1961376673184c\nvldumdx.dll,C:\WINDOWS\System32\DriverStore\FileRepository\nv_dispi.inf_amd64_ce1961376673184c\nvldumdx.dll,C:\WINDOWS\System32\DriverStore\FileRepository\nv_dispi.inf_amd64_ce1961376673184c\nvldumdx.dll,C:\WINDOWS\System32\DriverStore\FileRepository\nv_dispi.inf_amd64_ce1961376673184c\nvldumdx.dll C:\WINDOWS\System32\DriverStore\FileRepository\nv_dispi.inf_amd64_ce1961376673184c\nvldumd.dll,C:\WINDOWS\System32\DriverStore\FileRepository\nv_dispi.inf_amd64_ce1961376673184c\nvldumd.dll,C:\WINDOWS\System32\DriverStore\FileRepository\nv_dispi.inf_amd64_ce1961376673184c\nvldumd.dll,C:\WINDOWS\System32\DriverStore\FileRepository\nv_dispi.inf_amd64_ce1961376673184c\nvldumd.dll
  • adapterDrivers2:
  • adapterRAM: 6144
  • adapterRAM2:
  • adapterSubsysID: 49953842
  • adapterSubsysID2:
  • adapterVendorID: 0x10de
  • adapterVendorID2:
  • crashGuards: [{u'prefName': u'gfx.crash-guard.status.d3d11layers', u'type': u'd3d11layers'}]
  • currentAudioBackend: wasapi
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'']
  • directWriteEnabled: True
  • directWriteVersion: 10.0.15063.413
  • driverDate: 8-21-2017
  • driverDate2:
  • driverVersion: 22.21.13.8541
  • driverVersion2:
  • featureLog: {u'fallbacks': [], u'features': [{u'status': u'disabled', u'description': u'Compositing', u'log': [{u'status': u'available', u'type': u'default'}, {u'status': u'disabled', u'message': u'Disabled by pref', u'type': u'user'}], u'name': u'HW_COMPOSITING'}, {u'status': u'unavailable', u'description': u'Direct3D11 Compositing', u'log': [{u'status': u'unavailable', u'message': u'Hardware compositing is disabled', u'type': u'default'}], u'name': u'D3D11_COMPOSITING'}, {u'status': u'unavailable', u'description': u'Direct2D', u'log': [{u'status': u'unavailable', u'message': u'Direct2D requires Direct3D 11 compositing', u'type': u'default'}], u'name': u'DIRECT2D'}, {u'status': u'disabled', u'description': u'Direct3D11 hardware ANGLE', u'log': [{u'status': u'unavailable', u'message': u'D3D11 compositing is disabled', u'type': u'default'}, {u'status': u'disabled', u'message': u'D3D11 compositing is disabled', u'type': u'env'}], u'name': u'D3D11_HW_ANGLE'}, {u'status': u'unavailable', u'description': u'GPU Process', u'log': [{u'status': u'unavailable', u'message': u'Multi-process mode is not enabled', u'type': u'default'}], u'name': u'GPU_PROCESS'}, {u'status': u'unavailable', u'description': u'WebRender', u'log': [{u'status': u'opt-in', u'message': u'WebRender is an opt-in feature', u'type': u'default'}, {u'status': u'unavailable', u'message': u'ANGLE is disabled', u'type': u'runtime'}], u'name': u'WEBRENDER'}]}
  • info: {u'AzureCanvasAccelerated': 0, u'AzureCanvasBackend': u'skia', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'skia'}
  • isGPU2Active: False
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'']
  • numTotalWindows: 1
  • webgl1DriverExtensions: GL_ANGLE_depth_texture GL_ANGLE_framebuffer_blit GL_ANGLE_framebuffer_multisample GL_ANGLE_instanced_arrays GL_ANGLE_pack_reverse_row_order GL_ANGLE_request_extension GL_ANGLE_robust_client_memory GL_ANGLE_texture_compression_dxt3 GL_ANGLE_texture_compression_dxt5 GL_ANGLE_texture_usage GL_ANGLE_translated_shader_source GL_CHROMIUM_bind_generates_resource GL_CHROMIUM_bind_uniform_location GL_CHROMIUM_copy_texture GL_CHROMIUM_sync_query GL_EXT_blend_minmax GL_EXT_color_buffer_half_float GL_EXT_debug_marker GL_EXT_frag_depth GL_EXT_occlusion_query_boolean GL_EXT_read_format_bgra GL_EXT_robustness GL_EXT_shader_texture_lod GL_EXT_texture_compression_dxt1 GL_EXT_texture_filter_anisotropic GL_EXT_texture_format_BGRA8888 GL_EXT_texture_storage GL_EXT_unpack_subimage GL_KHR_debug GL_NV_fence GL_NV_pack_subimage GL_OES_EGL_image GL_OES_EGL_image_external GL_OES_depth32 GL_OES_element_index_uint GL_OES_get_program_binary GL_OES_packed_depth_stencil GL_OES_rgb8_rgba8 GL_OES_standard_derivatives GL_OES_texture_float GL_OES_texture_float_linear GL_OES_texture_half_float GL_OES_texture_half_float_linear GL_OES_texture_npot GL_OES_vertex_array_object
  • webgl1Extensions: ANGLE_instanced_arrays EXT_blend_minmax EXT_color_buffer_half_float EXT_frag_depth EXT_shader_texture_lod EXT_texture_filter_anisotropic MOZ_debug OES_element_index_uint OES_standard_derivatives OES_texture_float OES_texture_float_linear OES_texture_half_float OES_texture_half_float_linear OES_vertex_array_object WEBGL_color_buffer_float WEBGL_compressed_texture_s3tc WEBGL_debug_renderer_info WEBGL_debug_shaders WEBGL_depth_texture WEBGL_lose_context MOZ_WEBGL_lose_context MOZ_WEBGL_compressed_texture_s3tc MOZ_WEBGL_depth_texture
  • webgl1Renderer: Google Inc. -- ANGLE (NVIDIA GeForce GTX 980 Ti Direct3D9Ex vs_3_0 ps_3_0)
  • webgl1Version: OpenGL ES 2.0 (ANGLE 2.1.0.dec065540d5f)
  • webgl1WSIInfo: EGL_VENDOR: Google Inc. (adapter LUID: 00000000012686fe) EGL_VERSION: 1.4 (ANGLE 2.1.0.dec065540d5f) EGL_EXTENSIONS: EGL_EXT_create_context_robustness EGL_ANGLE_d3d_share_handle_client_buffer EGL_ANGLE_d3d_texture_client_buffer EGL_ANGLE_surface_d3d_texture_2d_share_handle EGL_ANGLE_query_surface_pointer EGL_ANGLE_window_fixed_size EGL_NV_post_sub_buffer EGL_KHR_create_context EGL_EXT_device_query EGL_KHR_image EGL_KHR_image_base EGL_KHR_gl_texture_2D_image EGL_KHR_gl_renderbuffer_image EGL_KHR_get_all_proc_addresses EGL_ANGLE_flexible_surface_compatibility EGL_ANGLE_create_context_webgl_compatibility EGL_CHROMIUM_create_context_bind_generates_resource EGL_EXTENSIONS(nullptr): EGL_EXT_client_extensions EGL_EXT_platform_base EGL_EXT_platform_device EGL_ANGLE_platform_angle EGL_ANGLE_platform_angle_d3d EGL_ANGLE_device_creation EGL_ANGLE_device_creation_d3d11 EGL_ANGLE_experimental_present_path EGL_KHR_client_get_all_proc_addresses
  • webgl2DriverExtensions: -
  • webgl2Extensions: -
  • webgl2Renderer: WebGL creation failed: * Error during ANGLE OpenGL init. * Error during ANGLE OpenGL init. * Error during ANGLE OpenGL init. * Error during ANGLE OpenGL init. * Error during ANGLE OpenGL init. * Exhausted GL driver caps.
  • webgl2Version: -
  • webgl2WSIInfo: -
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Basic

Preferencias modificadas

Miscelánea

  • JS del usuario: no
  • Accesibilidad: no
FredMcD
  • Top 10 Contributor
3707 soluciones 51020 respuestas
Publicadas

In order to better assist you with your issue please provide us with a screenshot. If you need help to create a screenshot, please see How do I create a screenshot of my problem?

Once you've done this, attach the saved screenshot file to your forum post by clicking the Browse... button below the Post your reply box. This will help us to visualize the problem.

Thank you!


Try to disable multi-process tabs in Firefox. You can disable multi-process tabs in Firefox by setting the related prefs to false on the about:config page.

browser.tabs.remote.autostart = false browser.tabs.remote.autostart.2 = false

http://www.ghacks.net/2016/07/22/multi-process-firefox/

Type about:config<enter> in the address bar. If a warning screen comes up, press the Be Careful button. At the top of the screen is a search bar.

In order to better assist you with your issue please provide us with a screenshot. If you need help to create a screenshot, please see [[How do I create a screenshot of my problem?]] Once you've done this, attach the saved screenshot file to your forum post by clicking the '''Browse...''' button below the ''Post your reply'' box. This will help us to visualize the problem. Thank you! ------------------- Try to disable multi-process tabs in Firefox. You can disable multi-process tabs in Firefox by setting the related prefs to false on the '''about:config''' page. '''browser.tabs.remote.autostart''' = false '''browser.tabs.remote.autostart.2''' = false http://www.ghacks.net/2016/07/22/multi-process-firefox/ Type '''about:config'''<enter> in the address bar. If a warning screen comes up, press the '''Be Careful''' button. At the top of the screen is a search bar.
Happy112 561 soluciones 5694 respuestas
Publicadas

In case the above doesn't do the trick :

Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches.

You will need to restart Firefox for this to take effect so save all work first (e.g., mail you are composing, online documents you're editing, etc.,) and then perform these steps:

In Firefox 54 and below:

  1. Click the menu button New Fx Menu and select Options (Windows) or Preferences (Mac, Linux).
  2. Select the Advanced panel and the General tab.
  3. Uncheck Use hardware acceleration when available.
  4. Close Firefox completely and then restart Firefox to see if the problem persists.

In Firefox 55 and above:

  1. Click the menu button New Fx Menu and select Options (Windows) or Preferences (Mac, Linux).
  2. Select the General panel.
  3. Under Performance, uncheck Use recommended performance settings. Additional settings will be displayed.
    Fx55Performance-disableHWA
  4. Uncheck Use hardware acceleration when available.
  5. Close Firefox completely and then restart Firefox to see if the problem persists.

Did this fix your problems? Please report back to us!

If the problem is resolved, you should check for updates for your graphics driver by following the steps mentioned in these Knowledge base articles:

Thank you.

In case the above doesn't do the trick : Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches. You will need to restart Firefox for this to take effect so save all work first (e.g., mail you are composing, online documents you're editing, etc.,) and then perform these steps: '''In Firefox 54 and below:''' # Click the menu button [[Image:New Fx Menu]] and select ''Options'' (Windows) or ''Preferences'' (Mac, Linux). # Select the ''Advanced'' panel and the ''General'' tab. # Uncheck '''Use hardware acceleration when available'''. # Close Firefox completely and then restart Firefox to see if the problem persists. '''In Firefox 55 and above''': # Click the menu button [[Image:New Fx Menu]] and select ''Options'' (Windows) or ''Preferences'' (Mac, Linux). # Select the ''General'' panel. # Under '''Performance''', uncheck ''Use recommended performance settings''. Additional settings will be displayed. #;[[Image:Fx55Performance-disableHWA|width=500]] # Uncheck '''Use hardware acceleration when available'''. # Close Firefox completely and then restart Firefox to see if the problem persists. Did this fix your problems? Please report back to us! If the problem is resolved, you should check for updates for your graphics driver by following the steps mentioned in these Knowledge base articles: * [[Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems#w_turn-off-hardware-acceleration]] * [[Upgrade your graphics drivers to use hardware acceleration and WebGL]] Thank you.

Autor de la pregunta

i appreciate the help guys, i should be clearer.

1) I've already disabled hardware acceleration 2) I've already tried with all Add-Ons disabled 3) I've reinstalled my graphics driver and currently using the latest (385.41 Driver Version) 4) a screenshot does NOT capture the problem and yes I have tried many times, something that happens in less than a second is difficult to capture.

All of which I've mentioned. Since the first post I've installed the 64 bit version of Firefox hoping it might help but that's just wishful thinking.

Thank you Fred for your suggestion but unfortunately disabling multi- process hasn't had an effect.

If anyone has any other suggestions I don't mind trying them out.

Thank You

i appreciate the help guys, i should be clearer. 1) I've already disabled hardware acceleration 2) I've already tried with all Add-Ons disabled 3) I've reinstalled my graphics driver and currently using the latest (385.41 Driver Version) 4) a screenshot does NOT capture the problem and yes I have tried many times, something that happens in less than a second is difficult to capture. All of which I've mentioned. Since the first post I've installed the 64 bit version of Firefox hoping it might help but that's just wishful thinking. Thank you Fred for your suggestion but unfortunately disabling multi- process hasn't had an effect. If anyone has any other suggestions I don't mind trying them out. Thank You
Happy112 561 soluciones 5694 respuestas
Publicadas

mabz said

i appreciate the help guys, i should be clearer.
1) I've already disabled hardware acceleration

No, you were perfectly clear, but I apologize for overlooking the fact that you already disabled hardware acceleration ........

''mabz [[#answer-1005095|said]]'' <blockquote> i appreciate the help guys, i should be clearer.<BR> 1) I've already disabled hardware acceleration </blockquote> No, you were perfectly clear, but I apologize for overlooking the fact that you already disabled hardware acceleration ........
Happy112 561 soluciones 5694 respuestas
Publicadas

Solución elegida

Every solution to this problem that I've found so far is all about disabling hardware acceleration or updating grapics drivers - none of which worked for you.

Would you please check this setting :

3-bar menu (or 'Tools') => Advanced => General tab => under 'Browsing': 'Disable smooth scrolling' should be unchecked (at least that worked for some others)


Another thing to try :

Type in the address bar about:config (press Enter) (promise to be careful, if asked) Type and look for the preference : gfx.font_rendering.directwrite.force-enabled and set its value to true

However : if that doesn't make a difference, change the value back to false

Every solution to this problem that I've found so far is all about disabling hardware acceleration or updating grapics drivers - none of which worked for you. Would you please check this setting : 3-bar menu (or 'Tools') => Advanced => General tab => under 'Browsing': 'Disable smooth scrolling' should be unchecked (at least that worked for some others) -------------------------------------------------------------------------------------------------------- Another thing to try : Type in the address bar '''about:config''' (press Enter) (promise to be careful, if asked) Type and look for the preference : '''gfx.font_rendering.directwrite.force-enabled''' and set its value to '''true''' However : if that doesn't make a difference, change the value back to '''false'''

Autor de la pregunta

Thank you for the reply. I'm sorry I didn't mean to sound rude. I've not been able to get a screenshot but I tried to get a video which you can find here. https://www.youtube.com/watch?v=lNo2h5M0N_U

I've tried to use nvidia's shadowplay to try and capture the tearing but that seems to have made it smoother using it so I ended up using my phone to capture it.

disabling gfx.font_rendering.directwrite.force-enabled didn't have an effect BUT after disabling smooth scrolling I wasn't able to notice the tearing then I re-enabled hardware acceleration and I still don't see any tearing. The scrolling isn't satisfyingly smooth but I think that fixed.

Thank You Very Much for your help

Thank you for the reply. I'm sorry I didn't mean to sound rude. I've not been able to get a screenshot but I tried to get a video which you can find here. [https://www.youtube.com/watch?v=lNo2h5M0N_U https://www.youtube.com/watch?v=lNo2h5M0N_U] I've tried to use nvidia's shadowplay to try and capture the tearing but that seems to have made it smoother using it so I ended up using my phone to capture it. disabling gfx.font_rendering.directwrite.force-enabled didn't have an effect BUT after disabling smooth scrolling I wasn't able to notice the tearing then I re-enabled hardware acceleration and I still don't see any tearing. The scrolling isn't satisfyingly smooth but I think that fixed. Thank You Very Much for your help
Happy112 561 soluciones 5694 respuestas
Publicadas

You're welcome  ! So glad that problem is finally solved  !

And you did absolutely not sound rude  !

You're welcome ! So glad that problem is finally solved ! And you did absolutely '' not'' sound rude !
cor-el
  • Top 10 Contributor
  • Moderator
16564 soluciones 149533 respuestas
Publicadas

Note that you can try to increase the value of the general.smoothScroll.mouseWheel.durationMaxMS pref on the about:config page a higher value like 1000 to see if that makes a difference with smooth scrolling enabled.

Note that you can try to increase the value of the general.smoothScroll.mouseWheel.durationMaxMS pref on the about:config page a higher value like 1000 to see if that makes a difference with smooth scrolling enabled.

Autor de la pregunta

cor-el said

Note that you can try to increase the value of the general.smoothScroll.mouseWheel.durationMaxMS pref on the about:config page a higher value like 1000 to see if that makes a difference with smooth scrolling enabled.

I've increased the value but i still get tearing, thanks for the tip though

''cor-el [[#answer-1005134|said]]'' <blockquote> Note that you can try to increase the value of the general.smoothScroll.mouseWheel.durationMaxMS pref on the about:config page a higher value like 1000 to see if that makes a difference with smooth scrolling enabled. </blockquote> I've increased the value but i still get tearing, thanks for the tip though
Happy112 561 soluciones 5694 respuestas
Publicadas

mabz said

I've increased the value but i still get tearing, thanks for the tip though

So your problem is not solved after all ........ Bummer  !

In that case : would you be a dear and remove the 'Chosen Solution' mark from my post  ? You can do that by clicking on the Undo button on the right side of that post.

''mabz [[#answer-1005152|said]]'' <blockquote> I've increased the value but i still get tearing, thanks for the tip though </blockquote> So your problem is ''not'' solved after all ........ Bummer ! In that case : would you be a dear and remove the 'Chosen Solution' mark from my post ? You can do that by clicking on the '''Undo''' button on the right side of that post.
FredMcD
  • Top 10 Contributor
3707 soluciones 51020 respuestas
Publicadas

If you don’t, others that can help may not read this post.

Go to that message, and use the Undo link to its right.

If you don’t, others that can help may not read this post. Go to that message, and use the '''Undo''' link to its right.

Autor de la pregunta

No I'm happy with smooth scrolling disabled, i don't need fancy scrolling to enjoy the internet. I just wanted to try cor-el's tip and see if that would make any visible difference. You've been great happy12

No I'm happy with smooth scrolling disabled, i don't need fancy scrolling to enjoy the internet. I just wanted to try cor-el's tip and see if that would make any visible difference. You've been great happy12
Happy112 561 soluciones 5694 respuestas
Publicadas

mabz said

No I'm happy with smooth scrolling disabled, i don't need fancy scrolling to enjoy the internet. I just wanted to try cor-el's tip and see if that would make any visible difference. You've been great happy12

Huge relief  !!! I honestly thought that the smooth scrolling disabled wasn't working for you after all. Phew ........

(thank you for being so sweet)

''mabz [[#answer-1005288|said]]'' <blockquote> No I'm happy with smooth scrolling disabled, i don't need fancy scrolling to enjoy the internet. I just wanted to try cor-el's tip and see if that would make any visible difference. You've been great happy12 </blockquote> Huge relief !!! I honestly thought that the smooth scrolling disabled wasn't working for you after all. Phew ........ (thank you for being so sweet)