No puedo agregar, cambiar ni guardar marcadores: cómo solucionarlo

Este artículo te muestra qué tienes que hacer si no puedes agregar nuevos marcadores ni realizar otros cambios en ellos.

Nota: si no encuentras los marcadores que guardaste anteriormente, consulta Marcadores desaparecidos.

No puedo agregar ni cambiar los marcadores

Si no puedes añadir nuevos marcadores o si los cambios que aplicas en la barra de herramientas no se guardan cuando reinicias Firefox, consulta el artículo La barra de herramientas se reinicia.

Si no puedes añadir nuevos marcadores ni realizar ningún cambio y tienes instalada alguna extensión para marcadores de Firefox, como por ejemplo, una extensión para sincronizar los marcadores, sigue las instrucciones que aparecen en el artículo Resolución de incidencias relacionadas con extensiones, temas y aceleración de hardware para solucionar problemas comunes de Firefox para ver si ese es el problema.

Puedo añadir o cambiar los marcadores, pero desaparecen cada vez que inicio Firefox

Si puedes añadir, eliminar, organizar y hacer cambios en tus marcadores, pero todo desaparece cada vez que reinicias Firefox, intenta lo siguiente:

Nota: Te recomendamos que desactives cualquier extensión relacionada con marcadores, tal y como se explica aquí, antes de continuar con el resto de soluciones que te proponemos más abajo.

Repara el archivo de marcadores

Si los cambios que aplicas a tus marcadores desaparecen cuando reinicias Firefox, el problema puede ser que el archivo que contiene esos marcadores esté protegido. Si lo está, el archivo no puede modificarse, lo que impide que Firefox guarde los cambios que apliques.

Permite que Firefox guarde los cambios que apliques a tus marcadores:

  1. Abre tu carpeta de perfil de usuario:

    En la parte superior de la ventana de Firefox, haz clic en el botón Firefox, desplázate hasta el menú AyudaEn la barra de menús, haz clic en el menú AyudaEn la parte superior de la ventana de Firefox, haz clic en el menú Ayuda y selecciona Información para solucionar problemas. Se abrirá la ventana de Información para solucionar problemas.

  2. Debajo de Configuración básica de la aplicación, haz clic en el botón Mostrar carpetaMostrar en FinderAbrir directorio. Se abrirá la ventana con los archivosla carpeta de tu perfil.
  3. Nota: Si te resulta imposible abrir o utilizar Firefox, sigue las instrucciones que se muestran en Buscar tu perfil sin necesidad de abrir Firefox.

  4. En la parte superior de la ventana de Firefox, haz clic en el botón Firefox y selecciona SalirEn la parte superior de la ventana de Firefox, elige el menú Archivo y selecciona SalirEn la barra de menú, selecciona Firefox y a continuación Salir de FirefoxEn la parte superior de la ventana de Firefox, haz clic en el menú Archivo y selecciona Salir.

    Haz clic en el botón Menú New Fx Menu y a continuación en SalirQuitar Close 29

  5. Haz clic con el botón secundario en el archivo plac​es.sqli​te y selecciona Propiedades para abrir la ventana Propiedades.
  6. En la ventana Propiedades, selecciona la pestaña General. Cerca de la parte inferior de la ventana, comprueba que NO esté seleccionado Sólo lectura.

    bookmarksnotsaved-readonly.png

Para permitir la escritura en el archivo de tus marcadores:

  1. Abre tu carpeta de perfil de usuario:

    En la parte superior de la ventana de Firefox, haz clic en el botón Firefox, desplázate hasta el menú AyudaEn la barra de menús, haz clic en el menú AyudaEn la parte superior de la ventana de Firefox, haz clic en el menú Ayuda y selecciona Información para solucionar problemas. Se abrirá la ventana de Información para solucionar problemas.

  2. Debajo de Configuración básica de la aplicación, haz clic en el botón Mostrar carpetaMostrar en FinderAbrir directorio. Se abrirá la ventana con los archivosla carpeta de tu perfil.
  3. Nota: Si te resulta imposible abrir o utilizar Firefox, sigue las instrucciones que se muestran en Buscar tu perfil sin necesidad de abrir Firefox.

  4. En la parte superior de la ventana de Firefox, haz clic en el botón Firefox y selecciona SalirEn la parte superior de la ventana de Firefox, elige el menú Archivo y selecciona SalirEn la barra de menú, selecciona Firefox y a continuación Salir de FirefoxEn la parte superior de la ventana de Firefox, haz clic en el menú Archivo y selecciona Salir.

    Haz clic en el botón Menú New Fx Menu y a continuación en SalirQuitar Close 29

  5. Selecciona el archivo plac​es.sqli​te.
  6. En la barra de menú, selecciona Archivo y, a continuación, Obtener información. Se abrirá la ventana con información sobre places.sqlite.
  7. En la venta con información sobre places.sqlite, elimina la marca de comprobación de la casilla Bloqueado.

Crea un nuevo archivo de marcadores

Los marcadores y el historial de navegación están almacenados en la carpeta de perfil de Firefox en un archivo que se llama places.sqlite. Si hay algún problema con este archivo, cada vez que inicies Firefox se perderán todos los cambios que hayas hecho. Si quieres que Firefox cree un nuevo archivo places.sqlite, tienes que eliminar el que ya existe.

Quizás quieras imprimir o copiar estas instrucciones, ya que tendrás que cerrar Firefox para poder eliminar el archivo.

Advertencia: una vez que elimines el archivo places.sqlite, perderás todo el historial de navegación.
  1. Abre tu carpeta de perfil de usuario:

    En la parte superior de la ventana de Firefox, haz clic en el botón Firefox, desplázate hasta el menú AyudaEn la barra de menús, haz clic en el menú AyudaEn la parte superior de la ventana de Firefox, haz clic en el menú Ayuda y selecciona Información para solucionar problemas. Se abrirá la ventana de Información para solucionar problemas.

  2. Debajo de Configuración básica de la aplicación, haz clic en el botón Mostrar carpetaMostrar en FinderAbrir directorio. Se abrirá la ventana con los archivosla carpeta de tu perfil.
  3. Nota: Si te resulta imposible abrir o utilizar Firefox, sigue las instrucciones que se muestran en Buscar tu perfil sin necesidad de abrir Firefox.

  4. En la parte superior de la ventana de Firefox, haz clic en el botón Firefox y selecciona SalirEn la parte superior de la ventana de Firefox, elige el menú Archivo y selecciona SalirEn la barra de menú, selecciona Firefox y a continuación Salir de FirefoxEn la parte superior de la ventana de Firefox, haz clic en el menú Archivo y selecciona Salir.

    Haz clic en el botón Menú New Fx Menu y a continuación en SalirQuitar Close 29

  5. En tu carpeta de perfil, elimina el archivo places.sqlite y, si existe, también el archivo places.sqlite-journal.
  6. (Opcional) Elimina también el archivo localstore.rdf. Esta acción restaurará cualquier personalización que tuvieras antes en la barra de marcadores.

Firefox creará un nuevo archivo places.sqlite e importará automáticamente el archivo de marcadores más reciente. Se almacenarán tus marcadores, pero no recuperarás tu historial de búsqueda.



Basado en información de Bookmarks not saved (mozillaZine KB)



Comparte este artículo: http://mzl.la/ON1mdk

¿Te resultó útil este artículo? Espera por favor...

Esta gente maravillosa ayudó a escribir este artículo: inma_610, avelper. Tú también puedes ayudar, descubre cómo hacerlo.