Showing questions tagged: Show all questions
  • Solved
  • Archived

Why do links not work in Firefox, but do on other browsers

The latest example is the button to sign into LinkedIn. It is not working in Firefox, but it does in other browsers. I have other examples just from today. I have used fi… (read more)

The latest example is the button to sign into LinkedIn. It is not working in Firefox, but it does in other browsers. I have other examples just from today. I have used firefox as default for many years. I assume this is a security thing, but these are basic links. I have no add-ons or other complications. Most times, I do not even realize there is a problem, but when I feel something is wrong, I try another browser and it works. Thank you.

Asked by HnLA 2 years ago

Answered by HnLA 2 years ago

  • Solved
  • Archived

Firefox doesn't remember the youtube login

I had the same problem like the link below when I use firefox. https://www.reddit.com/r/firefox/comments/tjxh7s/videos_freeze_when_window_isnt_in_focus/ So, did what th… (read more)

I had the same problem like the link below when I use firefox.

https://www.reddit.com/r/firefox/comments/tjxh7s/videos_freeze_when_window_isnt_in_focus/

So, did what the instruction says and it solved the problem regarding discord.

But, since I changed that setting, firefox doesn't remember my google login or dark skin settings of other websites (it was always automatically logged in when I use YouTube. Not like it remembers the password).

How can I solve it? I resetted firefox multiple times.

Asked by bgh1234554 2 years ago

Answered by FredMcD 2 years ago

  • Solved
  • Archived

Is Firefox being phased out as a browser?

I have just seen a clip on Youtube that concerns me. Is Firefox being phased out as a browser? I hope not. I have been using it for years and it is great. Please let me k… (read more)

I have just seen a clip on Youtube that concerns me. Is Firefox being phased out as a browser? I hope not. I have been using it for years and it is great. Please let me know. Many thanks Anthony

Asked by avwood 2 years ago

Answered by James 2 years ago

  • Solved
  • Archived

Missing Content Security Policy enable/disable setting on about:config

Hello, I noticed that a setting on the about:config page was removed: the "security.csp.enable" setting. I was using this setting to disable CSP to be able to load local… (read more)

Hello,

I noticed that a setting on the about:config page was removed: the "security.csp.enable" setting. I was using this setting to disable CSP to be able to load local JS scripts on some non-locally hosted sites, for debugging and development, work related purposes.

Was this setting really removed? Is there a way to disable CSP on Firefox on the latest version?

Thanks! Gabriel.

Asked by gabrielmuttiteixeira 2 years ago

Answered by cor-el 2 years ago

  • Solved
  • Archived

Opening New Tabs without Switching

So for starters I am fully aware of the "When you open a link, image or media in a new tab, switch to it immediately" setting, it is turned off. What I want to do is be … (read more)

So for starters I am fully aware of the "When you open a link, image or media in a new tab, switch to it immediately" setting, it is turned off.

What I want to do is be able to open new tabs from my bookmarks bar without immediately switching to them. Regardless of middle mouse click or right click and open new tab. Considering the mentioned setting is turned off I would assume that would solve the problem but it hasn't. It has however made it so when I'm browsing or looking through search engine results it doesn't open a new tab right away. But when I have a home/new tab open and am opening tabs from my bookmarks bar, it unfortunately switches to the new tab immediately. I have had this working on a previous install but am stumped as how to replicate.

Any help appreciated, thank you!

Asked by novagriffin14 2 years ago

Answered by Dropa 2 years ago

  • Solved
  • Archived

trying to access Facebook error

An error occurred during a connection to www.facebook.com. SSL_ERROR_DC_EXPIRED What in the world? does Facebook not keep up with its own security? or is this a Firefox t… (read more)

An error occurred during a connection to www.facebook.com. SSL_ERROR_DC_EXPIRED What in the world? does Facebook not keep up with its own security? or is this a Firefox thing?

Asked by judgeraye 2 years ago

Answered by cor-el 2 years ago

  • Solved
  • Archived

Uploading photos to Meetup

This sounds like it's a Meetup problem, and in fact it may be, but now I am having doubts. The problem is that I can't upload photos to a Meetup event. (This will most… (read more)

This sounds like it's a Meetup problem, and in fact it may be, but now I am having doubts.

The problem is that I can't upload photos to a Meetup event. (This will mostly just be a problem for Meetup organizers.) When I click on "Save photo", nothing happens. No error message, nothing. It's as if the "Save Photo" button has been disabled. Firefox is my browser while I access Meetup.com, and I have the latest and greatest version of Firefox.

I contacted Meetup and they haven't been able to solve the problem; they suggested that I clear my cache and my cookies and try again, but I get the same result. HOWEVER, when I go into Microsoft Edge, I can upload photos with no problem. So I have a work-around: use Microsoft Edge to upload photos. So my question to you centers around: why does this work perfectly in Microsoft Edge, but it doesn't in the latest version of Firefox?

To test the possibility that it's a bug on my personal desktop computer, I went to the public library and tried the same experiment, with the same result. So I don't think it's problem with my personal desktop computer.

One other piece of information: the exact same thing happens (failure to update photo, that is) when I have the photo open in another application (Photoshop), even if I try to "save photo" to Meetup in Microsoft Edge. Then when I close the other application (Photoshop in this case), Microsoft Edge lets me "save photo."

I know that Firefox really doesn't want me to try to revert to a previous version, and it makes me nervous too, but I am suspecting that something in the latest Firefox version actually introduced a problem. (Or maybe triggered a Meetup bug of some sort; I still haven't located the problem.) I've been on Meetup.com for years, I've had Firefox for years, they've worked together to upload photos in the past for years.

If you want to get into the details, below, for what it is worth, is my initial question to the Meetup support people (with whom I am still in a conversation).

- - - - - - - -

I can't upload a photo for my event. In fact, I cannot upload a photo for any event at all. I deleted a couple of photos and an album because maybe our group had too many, but that didn't work. I can't even upload a photo that I had previously uploaded to a different event, so I don't think that the problem is with the photo itself.

Here's what happens. 1. Edit the draft of my meetup. 2. Click on "upload photo." The photo is 1827 x 1009 pixels, total size 63 KB. 3. I click on "Upload photo", then in "add photo" I click on "upload photo" again. I browse for the photo and select it. 4. The "crop your photo" screen appears, with the selected photo in it. It's already the size I want, so I click on "Save Photo".(Cropping doesn't help either.) 5. Nothing happens. No error message, nothing. The only think I can click on is "cancel," which takes me out to the previous screen. - - - - - -

Asked by keith54 2 years ago

Answered by bonzcrystall 1 year ago

  • Solved
  • Archived

Firefox Automatically Redirecting from HTTP to HTTPS (RESOLUTION)

As per this issue I reported a while back, I was experiencing odd issue with automatic redirect to HTTPS for some private development sites. I finally found a fix for th… (read more)

As per this issue I reported a while back, I was experiencing odd issue with automatic redirect to HTTPS for some private development sites.

I finally found a fix for the issue. The problem appears to be with DuckDuckGo Privacy Essentials Extension which apparently *may automatically redirect to the http site. In order to prevent this, I added my development sites to 'Unprotected Sites' and this prevented DuckDuckGo from doing the automatic redirect to https.

  • - Odd thing is that I had multiple domains pointing to the same web instance and only one of the domains was having this issue with the DDG extension. Both were going to the same IP through a HTTP proxy. The proxy and web server were not the issue. This symptom points to an maybe an issue in Firefox....

In summary, be wary of odd redirects and the DuckDuckGo Privacy Essentials extension if you are doing web development work.

Asked by Timothy C. Quinn 2 years ago

Answered by Timothy C. Quinn 2 years ago

  • Solved
  • Archived

Credit Card Autofill

The credit card autofill shows all the credit cards but when I click on any of them it does not autofill. Ive used this hundreds of times before and it worked fine. I nev… (read more)

The credit card autofill shows all the credit cards but when I click on any of them it does not autofill. Ive used this hundreds of times before and it worked fine. I never changed any settings and the autofill setting is on.

Please help!

Alex

Asked by ad96321 2 years ago

Answered by YongHan 2 years ago

  • Solved
  • Archived

Unable to show File Picker

This was going to be a question about Firefox being unable to display the file picker dialog, but I managed to find a solution that worked for me along the way. Since it … (read more)

This was going to be a question about Firefox being unable to display the file picker dialog, but I managed to find a solution that worked for me along the way. Since it was nowhere near the top of Google's results, I thought I'll share my solution in the hopes that this would help someone facing this same issue.

The hardware:

  • Asus UM425IA Zenbook (AMD Ryzen 7 4700U CPU)

Worked in:

  • Ubuntu 20.04 LTS
  • Firefox provided by APT repository
  • Xorg display server

Not working in:

  • Ubuntu 22.04 LTS
  • Firefox 99.0.1 provided by snap
  • Wayland display server
  • File picker worked briefly on fresh install, but something (not sure what) quickly breaks file picker functionality

The symptoms:

  • Firefox stopped being able to open file picker dialogs
  • Right clicking an image and selecting "Save Image As..." does nothing
  • With forms that accept file upload (such as on this post question page "Add images (optional):"), clicking "Browse" does nothing
  • File downloads work correctly when set to "Save files to ..." under Settings, but nothing happens when set to "Always ask you where to save files"
  • No response to "Ctrl + O" open file shortcut

Similar questions and solutions:

Things I tried that did not work:

  • Disabling hardware acceleration
  • Starting with add-ons disabled
  • Troubleshoot mode
  • Clearing startup cache
  • Clearing cookies and site data
  • Clearing history
  • Refreshing Firefox
  • Creating and using a new profile
  • Deleting the `xulstore.json` file from the profile directory
  • Toggling all permissions under Ubuntu Settings > Applications > Firefox to off and then back to on
  • chmod 777 ~/Downloads
  • Disabling native file picker "ui.allow_platform_file_picker = false"

And finally, what fixed it for me was to go into "about:config" and change "widget.use-xdg-desktop-portal.file-picker" from "2" to "0". Credit to this post that clued me in.

I really hope this saves someone else 2 days of hair pulling and I would appreciate advice from someone more knowledgeable than me on:

  • Why this fixed the problem
  • Whether I should be opening a bug report either against Firefox, or Ubuntu
  • Whether I should also be changing "widget.use-xdg-desktop-portal.mime-handler" and "widget.use-xdg-desktop-portal.settings", both are currently set to "2"

Asked by James Fu 2 years ago

Answered by Kiki 1 year ago

  • Solved
  • Archived

Firefox not playing embedded Youtube videos in my phpBB forum

Firefox recently stopped playing embedded youtube videos on my phpBB forum site? i keep the latest firefox and only recently showed up embedded videos play fine on Chrom… (read more)

Firefox recently stopped playing embedded youtube videos on my phpBB forum site?

i keep the latest firefox and only recently showed up embedded videos play fine on Chrome and others

here's a link to my forum which includes an embedded Youtube video demonstrating the issue, does it play on your browser? (ONLY firefox has an issue on my computer, chrome, etc. work fine)

https://www.mchenrysoftware.com/board/viewtopic.php?t=2045

thanks for any tests/insight into what might be causing the issue

brian

ADDITIONAL COMMENT: why don't you include a date on these posting? a lot of wasted time on old posts? and also need a 'Preview' on these before posting?

Asked by Brian 2 years ago

Answered by FredMcD 2 years ago

  • Solved
  • Archived

Downloaded files are being downloaded twice even when using Always Ask option for all file types.

I have always set my option for all download file types to "Always Ask" and now Firefox not only asks me where I want to save the downloaded file, but also downloads a co… (read more)

I have always set my option for all download file types to "Always Ask" and now Firefox not only asks me where I want to save the downloaded file, but also downloads a copy to the Windows Download folder. Why am I getting double downloads? I only want one copy of a downloaded file, not two copies. Now I have to go to my Windows Download folder and delete the duplicate downloaded files. My question is, if my Firefox download option is set for all file types to "Always Ask", then why are you downloading the file twice??? I have specific folders where I want files to reside. I don't want to have to remember to go to my Windows Download folder and delete the duplicate files. How can this duplicate file download problem be fixed?

Long time user, Leo

Asked by bussysconsultant 2 years ago

Answered by James 2 years ago

  • Solved
  • Archived

YouTube Video GPU Decoding only works in Troubleshooting Mode

I recently upgraded graphics cards from an Nvidia GTX 1080 to an AMD 6900XT. Since then I noticed video stuttering on YouTube while playing 4k videos, especially noticeab… (read more)

I recently upgraded graphics cards from an Nvidia GTX 1080 to an AMD 6900XT. Since then I noticed video stuttering on YouTube while playing 4k videos, especially noticeable at 4k/60FPS (example video ). Prior to the upgrade, I was not experiencing issues.

I monitored task manager as the video was playing to see CPU usage, which was sitting at 25% (4 core 8 thread CPU). GPU usage was fluctuating from 1-3%.

I tried resetting all the changed configuration options in about:config, removing all add-ons, "Refreshing" Firefox, and ultimately uninstalling and reinstalling. Nothing has worked so far except for "Troubleshooting mode" in about:support. In that mode, I experience no stuttering and GPU usage rises to 25-35% with the video playing, even before I reinstalled.

This most likely isn't a networking issue as the "Stats for nerds" option on the YouTube video shows I have 10-20s of buffer while the video is still stuttering.

I would like to find out what's different about Troubleshooting Mode that is not giving me the same problem while in "Normal Mode". Any advice?

Asked by Jacob 2 years ago

Answered by Jacob 2 years ago

  • Solved
  • Archived

Logging into TikTok on desktop

Hi After updating to version 99.0. When I try to log into TikTok. This is what I get ( Continue on the TikTok App....For security purposes, continue on the TikTok App.… (read more)

Hi After updating to version 99.0.

When I try to log into TikTok. This is what I get ( Continue on the TikTok App....For security purposes, continue on the TikTok App. Don't have it installed? Text yourself a link to download your app )

I am using Windows 10 Pro on a desktop. When l log in using chrome,I am taking to TikTok web page. I am using same extensions in FF and Chrome.

Cheers

Asked by pedropete 2 years ago

Answered by pedropete 2 years ago

  • Solved
  • Archived

Font size became tiny since yesterday

Hi! Since yesterday, in Outlook, my font size became very tiny for subjects and categories. I can barely see it. Can you please restore them to normal sizes?? I am de… (read more)

Hi! Since yesterday, in Outlook, my font size became very tiny for subjects and categories. I can barely see it. Can you please restore them to normal sizes?? I am desperate trying to read them. Thank you! Shirley Savva

Asked by ShirleySavva 2 years ago

Answered by cor-el 2 years ago

  • Solved
  • Archived

Mozilla Firefox - Manage Bookmarks - Default Folder

Using Firefox version 99.0 (64bit). When I click "Bookmarks / Manage Bookmarks, the listing defaults to the "Other Bookmarks" folder. I would like it to default to the … (read more)

Using Firefox version 99.0 (64bit). When I click "Bookmarks / Manage Bookmarks, the listing defaults to the "Other Bookmarks" folder. I would like it to default to the "Bookmarks Menu" folder. How do I make it do that?

Asked by gtadamsesq 2 years ago

Answered by cor-el 1 year ago

  • Solved
  • Archived

past searches being saved even while private browsing

Hello! I always use private browsing so I thought that my history was totally not being saved, but discovered recently that when I started to type within the search fiel… (read more)

Hello!

I always use private browsing so I thought that my history was totally not being saved, but discovered recently that when I started to type within the search field, that many of my past searches were listed in the search field with the type highlighted in purple. I had to manually go in and delete all of these past searches. I don't want any search history to be saved. Is there a setting in preferences that I'm somehow missing? Why is Firefox saving these past searches if I have it set to Always Use Private Browsing?

Thank you!

Asked by amygrams7 2 years ago

Answered by amygrams7 2 years ago

  • Solved
  • Archived

Middle Mouse opens link in 2 tabs / closes 2 tabs constantly

Hi Firefoxes! I updated to the latest and greatest 99.0.1, whenever i use the middle mouse button it opens every link in 2 tabs. Also when i middle mouse on a tab, 2 tabs… (read more)

Hi Firefoxes! I updated to the latest and greatest 99.0.1, whenever i use the middle mouse button it opens every link in 2 tabs. Also when i middle mouse on a tab, 2 tabs are closed. Anyone came along this bug? Restarting FF and Windows did not help. Trying to get my notebook charged and check it on my macbook.

TYVM! Best regards, -John.

Asked by rayben1 2 years ago

Answered by rayben1 2 years ago

  • Solved
  • Archived

How can I print out my saved passwords in my Firefox? I do not use Chrome, just Firefox and my laptop. No cellphone.

Hi. I need to print out my saved passwords. I have no cellphone to access, just my laptop and printer. I only use Firefox and no other browser. If my laptop gets hacke… (read more)

Hi.

I need to print out my saved passwords. I have no cellphone to access, just my laptop and printer. I only use Firefox and no other browser. If my laptop gets hacked or breaks down, then I need to use someone else's computer to access my passwords in an emergency, and can't access my passwords to do so...so printing them out periodically is the smartest thing I can think of.

Help, anyone? This is pretty important to me. Thank you!

Asked by Hashachar70 2 years ago

Answered by Hashachar70 2 years ago