Showing questions tagged: Show all questions

Pop-up windows exceptions not working in private mode (Firefox 87.0)

Hi, After an update on Firefox 87.0 the pop-up exceptions defined are not working in private mode. A yellow bar appears that tells me that prevent the popups. If I choos… (read more)

Hi,

After an update on Firefox 87.0 the pop-up exceptions defined are not working in private mode. A yellow bar appears that tells me that prevent the popups. If I choose to allow the popups with the button on the left of url then the url is added on exceptions/allowed window with a ^privateBrowsingId=1 marked in the url. However this is not persisted on a next run of firefox on private mode.

If someone have setup exceptions is there for a reason and should not be broken in private mode. I also cannot add ^privateBrowsingId=1 on my own in the url on the exceptions, as it appeared as %5 in exceptions and it does not work to allow pop-up.

Thanks

Asked by JenniferRhodes1 4 months ago

Last reply by VVG 3 months ago

  • Solved

89.0b2 Revert new tab design

Today I updated my Firefox Developer Edition to version 89.0b2 and now I just can not look at this browser anymore, "Inspired new tab design" is taking too much space and… (read more)

Today I updated my Firefox Developer Edition to version 89.0b2 and now I just can not look at this browser anymore, "Inspired new tab design" is taking too much space and now became largest and at the same time least information-dense panel in my entire desktop! I searched around the web for a bit in hopes that I will find a theme or an add-on that will revert this particular change but no luck. I really want to revert to old UI look (at least tabs bar), there should be default theme or option to get back to old style. After some investigation I found userChrome.css but don't really want to install it (maybe this is actually the way of doing this kind of styling). Please help me revert UI design to old one.

Asked by PepeTheFrog21 3 months ago

Answered by TerryN21 3 months ago

May need to install the required video codecs

# My problem When i go to some site with video (for example https://www.openproject.org/ ) i have the following message : "To play video, you may need to install the requ… (read more)

# My problem

When i go to some site with video (for example https://www.openproject.org/ ) i have the following message : "To play video, you may need to install the required video codecs".

# Spec

I run Firefox Beta in Fedora, it's installed in /opt/ folder. I have the "normal" version of firefox too and the video works well.

# Some other infos

The video seem to be a mp4 video and i have the following package installed in my fedora GStreamer Multimedia Codecs (Multimedia plauback for APE, AVI, DV, FLAC, FLX, Flash, MKV, MP4, Speex, VP8, VP9 and WAV).

Asked by bouteiller.alan 3 months ago

Last reply by cor-el 1 month ago

  • Solved

How to stop the search from jumping to the address bar when typing on Firefox Home

I have Firefox home with a search engine as home page, but since the update to 89, when I try to type into the search box, it jumps to the address bar. This is very anno… (read more)

I have Firefox home with a search engine as home page, but since the update to 89, when I try to type into the search box, it jumps to the address bar. This is very annoying. Can it be fixed? I do not want to use the address bar this way. I found a help that said to open the application menu and click "customize" but there is no "customize" option there. In the attached photo, I clicked in the search box to place the cursor there, but as soon as I began typing, it jumped to the address bar. This has never happened to me before in the 15 years I have used Firefox. I am a recent convert to Linux (about 1 year now) and am using Mint 19.3, Cinnamon 4.4.8, if that makes a difference.

Asked by bonnie here 1 month ago

Answered by Franz_von_Suppe 1 month ago

Firefox 90.0 update problems

After the last update to version 90.0, I can't continue to use firefox browser. The problem is about opening google sites (youtube, gmail). Other websites seems to work n… (read more)

After the last update to version 90.0, I can't continue to use firefox browser. The problem is about opening google sites (youtube, gmail). Other websites seems to work normal, but I can't open youtube and gmail now (google.com itself works heavily). When I type url and click enter, it takes so much time to load, often not loading the site or partially load. Other browsers installed on the same system works normally with the "problematic" websites. I tried hard reload (ctrl+f5), cleaning all browser data, and uninstalling and reinstalling. None of the mentioned actions helped. Please help me to identify and solve the issue.

Asked by cahangirove 1 week ago

Last reply by jonzn4SUSE 3 hours ago

  • Solved

Firefox 90.0 no spund problem with Firejail

Hi i sandboxec firefox process, but i lose sound capabilities... This is the cmd line messages: (firefox:10): LIBDBUSMENU-GLIB-WARNING **: 08:49:34.055: Unable to get ses… (read more)

Hi i sandboxec firefox process, but i lose sound capabilities... This is the cmd line messages:

(firefox:10): LIBDBUSMENU-GLIB-WARNING **: 08:49:34.055: Unable to get session bus: Could not connect: Permission denied [Child 52, MediaDecoderStateMachine #1] WARNING: 7f7766fe13c0 OpenCubeb() failed to init cubeb: file /build/firefox-1MxnM8/firefox-90.0+build1/dom/media/AudioStream.cpp:324 [Child 52, MediaDecoderStateMachine #1] WARNING: Decoder=7f775c0f0c00 [OnMediaSinkAudioError]: file /build/firefox-1MxnM8/firefox-90.0+build1/dom/media/MediaDecoderStateMachine.cpp:3941

what is the workaround to fix sound?

Asked by bluestorm1724 1 week ago

Answered by TerryN21 3 days ago

  • Locked

ARE THERE NO DEVELOPERS OF ANY SOFTWARE WHO DO NOT USE GOOGLE SERVICES, THE WORLDS MOST EVIL FOREIGN ESPIONAGE AGENT?

I FIREWALL BLOCK GOOGLE! ARE THERE NO DEVELOPERS OF ANY SOFTWARE ANY WHERE WHO DO NOT USE GOOGLE SERVICES IN THEIR SOFTWARE? GOOGLE IS THE WORLDS MOST EVIL FOREIGN ESPION… (read more)

I FIREWALL BLOCK GOOGLE! ARE THERE NO DEVELOPERS OF ANY SOFTWARE ANY WHERE WHO DO NOT USE GOOGLE SERVICES IN THEIR SOFTWARE? GOOGLE IS THE WORLDS MOST EVIL FOREIGN ESPIONAGE AGENT! HOW STUPID HAS EVERYONE BECOME THAT THEY CANNOT SEE WHAT THEY HAVE DONE TO YOUR PRIVACY? EVERY STINKING PIECE OF CODE I LOOK INTO IN THE OPEN SOURCE WORLD CONTAINS GOOGLE CODE! THEY SPY ON EVERYONE ALL OVER THE WORLD! HOW STUPID HAVE YOU BECOME AMERICA? GET A CLUE! START WRITING YOUR OWN CODE AND AVOID AND BLOCK GOOGLE CODE! DO NOT GET CAUGHT WITH YOUR PANTS DOWN WHEN GOOGLE STARTS DEMANDING YOU SHUT DOWN YOUR WEBSITES BECAUSE YOU DISAGREE WITH THEIR POLICIES! EVER SINCE i HEARD THE STORY ABOUT GOOGLE WRITING CODE AND DOING A PROJECT FOR THE CHINESE MILITARY I HAVE BEEN FIREWALL BLOCKING ALL GOOGLE SERVICES! I HAVE DISCOVERED THAT EVERYONE USES THEIR SERVICES! WHAT HAPPENS TO YOUR CODE OR WEBSITE WHEN GOOGLE GOES PERMANENTLY DOWN BECAUSE OF A NUCLEAR STRIKE ON SAN FRANCISCO? i WILL TELL YOU WHEN THAT HAPPENS ALL YOUR WEBSITES GO DOWN AND YOU WILL NO LONGER BE ABLE TO REMAIN CONNECTED! STOP USING GOOGLE SERVICES! WRITE YOUR OWN SERVICES! THEN YOUR WEBSITES WILL CONTINUE TO FUNCTION WHEN THE WORST CASE SCENARIO OCCURS IN SAN FRANCISCO AND YOU WILL END UP BECOMING THE SAVIORS OF THE WORLD WIDE WEB OF CONNECTIVITY!

Asked by Virgil U 1 week ago

Last reply by Seburo 1 week ago

How to use the OpenXR API implementation?

I got hello_xr to run but how does one view WebXR spaces by using the monado service for Firefox? I can still develop for captured mouse mode or use the WebXR API Emulato… (read more)

I got hello_xr to run but how does one view WebXR spaces by using the monado service for Firefox? I can still develop for captured mouse mode or use the WebXR API Emulator add-on but I still have not found documentation about how to get Firefox to talk to the HMD or its tracking system using monado-service. Thank you in advance.

https://github.com/KhronosGroup/OpenXR-SDK-Source https://gitlab.freedesktop.org/monado/monado

Asked by JP 6 days ago

  • Solved

Web page displays graphics intead of text

I have encountered one web site that has several pages that display as graphics instead of text. I have visited this site before several months ago and the display was a… (read more)

I have encountered one web site that has several pages that display as graphics instead of text. I have visited this site before several months ago and the display was accurate then. The first image is how it looks now. The second image is how it looked several months ago. I am running Ubuntu 20.04.2 and Firefox 89.0.2. It's very strange that this is the only page that displays this way. I checked the page in Chromium and it displays correctly in that browser. Is this Firefox or quirky html?

Asked by ska.adley 6 days ago

Answered by ska.adley 5 days ago

Non-native scrollbar setting not working in Firefox 90

I'm using Firefox 90 on Linux (Fedora 33) and MATE Desktop. Before I upgraded to Firefox 90, I set widget.non-native-theme.enabled to false to revert the scrollbar appear… (read more)

I'm using Firefox 90 on Linux (Fedora 33) and MATE Desktop. Before I upgraded to Firefox 90, I set widget.non-native-theme.enabled to false to revert the scrollbar appearance to the system theme, as per this question: Scrollbar appearance changed after Firefox upgrade. It worked on Firefox 89, but as soon as I upgraded to Firefox 90, the scrollbars went back to the non-native appearance.

After the upgrade, the widget.non-native-theme.enabled is still set to false, but apparently ignored. However, I noticed that the other widget.non-native-theme.gtk.scrollbar.* settings that allow scrollbar appearance customization inside Firefox are ignored as well. If I set widget.non-native-theme.enabled back to true, then the other scrollbar settings work as expected. This tells me that widget.non-native-theme.enabled does work, but the system scrollbar theme is not picked up as expected. This looks like a bug to me.

Asked by Radu Rendec 6 days ago

Last reply by Radu Rendec 5 days ago

Firefox keeps obsessively asking for sync

I love Firefox (FF), I use it on my home PC, work laptop, and my smartphone. I use a FF account for synchronization which is quite handy. But why, WHY every time I log in… (read more)

I love Firefox (FF), I use it on my home PC, work laptop, and my smartphone. I use a FF account for synchronization which is quite handy. But why, WHY every time I log into my account I'm getting an email: "Last reminder to sync devices! bla bla bla" Can not FF learn that my account uses sync? I don't have more devices for extra synchronization :) Is that really hard?

Asked by Maksim 5 days ago

Last reply by Maksim 5 days ago

Firefox storages are broken

It has been a while that gmail and whatsapp web version wouldn't load on Firefox. After some time researching I saw that my Firefox ESR storage are broken. Especially: … (read more)

It has been a while that gmail and whatsapp web version wouldn't load on Firefox. After some time researching I saw that my Firefox ESR storage are broken. Especially:

  • QuotaManager
  • Bad: Totally Broken. (fullyBroken)
  • IndexedDB
  • Bad: Totally Broken. (fullyBroken)
  • Cache API
  • Bad: Totally Broken. (fullyBroken)

Is there any way to fix this? I'm using Firefox ESR on Linux and it seems there isn't new Firefox ESR updates.

Asked by thecowmilk 5 days ago

Last reply by cor-el 2 days ago

  • Solved

video support

I'm using Firefox 76 packaged with fedora 30 but it wont display a video (weirdly youtube does work). I'm getting the message: "this content requires adobe flash or HTML5… (read more)

I'm using Firefox 76 packaged with fedora 30 but it wont display a video (weirdly youtube does work). I'm getting the message: "this content requires adobe flash or HTML5 video support..." I don't want to install flash because I've seen some content somewhere about security concerns. I looked for an extension or add-on but none of them seem to be Mozilla approved and most of them don't seem to address this issue anyway. I can't find a setting to fix this in Firefox. I've seen an archived thread about this problem suggesting maybe some linux library issue, but it contained no solution. Maybe I'm missing something fundamental but it's 2021 now and I'd like my Firefox to support a bit of video here and there other than youtube. Has anyone got a solution?

Asked by clint 5 days ago

Answered by clint 1 day ago

  • Solved

The prompt "Please enter your primary password" appears multiple times in a session.

The prompt "Please enter your primary password" has started to appear multiple times in a session. When I enter the password everything seems to work the way it did befor… (read more)

The prompt "Please enter your primary password" has started to appear multiple times in a session. When I enter the password everything seems to work the way it did before, but after a while I'll click a link or access a bookmark and the prompt will pop up again.

Is this a deliberate change or a bug, or is my system broken or compromised?

Asked by Darrell 5 days ago

Answered by TyDraniu 5 days ago

Zoom gesture in Firefox on wayland

I am using linux kde neon on wayland. Firefox version 90. On ubuntu with gnome 40, my touchpad zoom works. I didn't have any problems on kubuntu either. But on Kde neon, … (read more)

I am using linux kde neon on wayland. Firefox version 90. On ubuntu with gnome 40, my touchpad zoom works. I didn't have any problems on kubuntu either. But on Kde neon, gestures don't work. I forced the MOZ_ENABLE_WAYLAND = 1 setting to enable wayland support. About: support shows that wayland is supported by the browser. Also I tried the settings MOZ_USE_XINPUT2 = 1 and GTK_USE_PORTAL = 1, but they didn't help either. Gestures in the system itself work.

Asked by zzzaaazzzsssddd 5 days ago

Last reply by zzzaaazzzsssddd 5 days ago

POST action turns into a GET, which is incorrect.

Using Apache2 to serve web pages. Debian Linux 5.10.0-8-amd64 #1 SMP Debian 5.10.46-2 (2021-07-20) x86_64 GNU/Linux The following appears in the access.log:- 127.0.0.1 - … (read more)

Using Apache2 to serve web pages.

Debian Linux 5.10.0-8-amd64 #1 SMP Debian 5.10.46-2 (2021-07-20) x86_64 GNU/Linux

The following appears in the access.log:-

127.0.0.1 - - [28/Jul/2021:15:17:42 +1000] "POST /scripts_php/memb_login.php HTTP/1.1" 302 314 "http://dev.webtest.info/htmlpages/login.html" "Mozilla/5.0 (X11; Linux x86_64; rv:78.0) Gecko/20100101 Firefox/78.0" 127.0.0.1 - - [28/Jul/2021:15:17:42 +1000] "GET /scripts_php/memb_login.php HTTP/1.1" 200 499 "http://dev.webtest.info/htmlpages/login.html" "Mozilla/5.0 (X11; Linux x86_64; rv:78.0) Gecko/20100101 Firefox/78.0"

The form method is POST and the action is to call a PHP script which expects a POST array. The "302 314" appears to be correct, but, a GET is returned immediately.

According to w3.org:-

Note: RFC 1945 and RFC 2068 specify that the client is not allowed

     to change the method on the redirected request.  However, most
     existing user agent implementations treat 302 as if it were a 303
     response, performing a GET on the Location field-value regardless
     of the original request method. The status codes 303 and 307 have
     been added for servers that wish to make unambiguously clear which
     kind of reaction is expected of the client.

This has just started to occur after a recent upgrade to Firefox. It might be caused by the browser but there might be some other explanation or configuration setting that needs tweaking. Could somebody please help.

Thanks.

Asked by rob2floripa 4 days ago

Last reply by TyDraniu 4 days ago

RSS feeds broken - content security policy issue?

Since I upgraded to Firefox 90.0, my RSS feeds can not longer be refreshed in my feed reader. I get a 403 error ("access denied"). When I check the debug information on t… (read more)

Since I upgraded to Firefox 90.0, my RSS feeds can not longer be refreshed in my feed reader. I get a 403 error ("access denied"). When I check the debug information on the URL, it says:

Content Security Policy: The page’s settings blocked the loading of a resource at inline (“script-src”).

I am using Feedbro on Firefox 90 on Ubuntu 20.04 on two different computers, and getting same problem.

Clearing the cache, trying other feed readers, deleting cookies etc do not help.

A sample feed URL: https://news.google.com/rss/search?hl=en-US&gl=US&q=mozilla&ceid=US:en In Firefox, I can open a tab and see the text file. But Feedbro, or any other reader, cannot detect the feeds on this page any more.

Any advice? I absolutely rely on RSS feeds for my work.

Thank you kindly!

Asked by oryza 4 days ago

Last reply by TyDraniu 4 days ago

How can I get a border around inactive tabs?

Hello, I updated firefox and it's now hard to tell when one tab ends and another begins when you have multiple inactive tabs next to each other, which is a major annoyanc… (read more)

Hello,

I updated firefox and it's now hard to tell when one tab ends and another begins when you have multiple inactive tabs next to each other, which is a major annoyance.

The way to solve this would be to have the inactive tabs have a border around them like the active tab, have them have a different background color from the toolbar, or otherwise have some kind of separator between them. I saw another answer that gave a temporary solution, but the same answer said the solution was going to stop working in a future update. Is there a permanent solution?

Asked by Andreas Eriksson 4 days ago

Last reply by JP 3 days ago

PDF.JS display chinese font issue.

when using firefox plugin PDF viewer (PDF.JS) display chinese content cause some issue, fontface and font doesn't display correctly. will this issue fix in next version??… (read more)

when using firefox plugin PDF viewer (PDF.JS) display chinese content cause some issue, fontface and font doesn't display correctly. will this issue fix in next version?? tks.

Asked by neko19720429 4 days ago

Last reply by cor-el 3 days ago