Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

'Use autoscrolling' and 'Enable DRM' settings keep being unset

  • 5 replies
  • 3 have this problem
  • 17 views
  • Last reply by cor-el

more options

Lately, Firefox unchecks the 'use autoscrolling' and 'play DRM-controlled content' options sometimes (but not every time) when it starts. Other settings don't seem to be affected. It does seem to unset both at once, never one or the other at a time.

I have begun using Firefox routinely on two computers, both signed into the same sync profile. My best guess is that maybe one profile is overwriting the other? Both of these options are set on the second system, but maybe there's something going wrong with the sync?

Thanks, Patrick

Lately, Firefox unchecks the 'use autoscrolling' and 'play DRM-controlled content' options sometimes (but not every time) when it starts. Other settings don't seem to be affected. It does seem to unset both at once, never one or the other at a time. I have begun using Firefox routinely on two computers, both signed into the same sync profile. My best guess is that maybe one profile is overwriting the other? Both of these options are set on the second system, but maybe there's something going wrong with the sync? Thanks, Patrick

All Replies (5)

more options

https://support.mozilla.org/en-US/kb/how-to-fix-preferences-wont-save

Note: Some software, like Advanced SystemCare with Surfing Protection, can protect files in the Firefox profile folder against changes. If you have such software then check the settings or uninstall this software.


Macs: Make sure you install Firefox properly and that you do not run Firefox from within the DMG (Disk Images) file. https://support.mozilla.org/en-US/kb/how-download-and-install-firefox-mac

more options

I have the exact same problem - one computer is a Windows laptop, the other is an Ubuntu desktop. The problem is in the prefs.js file, the Windows laptop defaults are "autoscroll on, DRM on" and in the Ubuntu they are "autoscroll off, DRM off".

When I enable the settings on Ubuntu, these two lines appear in the prefs.js file:

user_pref("general.autoScroll", true); user_pref("media.eme.enabled", true);

After that, Firefox syncs the prefs.js file to the Windows computer, which then sees the defaults written explicity and removes them, then syncs them back to the Ubuntu computer, which turns off those two settings. That is how I understand the problem that's happening, I haven't confirmed that that's the actual behavior.

more options

You can possibly try to set the related services.sync.prefs prefs to false to exclude them from Sync to see if that has effect.

  • services.sync.prefs.sync.general.autoScroll = false
  • services.sync.prefs.sync.media.eme.enabled = false
more options

Thank you, hopefully that'll solve the issue. May I ask why do the defaults differ between operating systems?

more options

Ubuntu is known to make a lot of changes to the branded version they offer via the repositories and they may have changed the default of some prefs..

You can try Firefox from the official Mozilla server if you currently use a version from the repositories of your Linux distribution to see if it behaves differently.