X
Tap here to go to the mobile version of the site.

Support Forum

Can't see add-ons in menu

Posted

On my Samsung Galaxy Note 2 using JB 4.1.2, when I tap on the menu button on the lower left hand corner, the menu that comes up won't display anything beyond "Settings", i.e., I can't see the addons, in particular the 'Clean & Quit' add-on button which is the one I most need. Rebooting the phone often fixes the problem, but only temporarily. Any ideas?

On my Samsung Galaxy Note 2 using JB 4.1.2, when I tap on the menu button on the lower left hand corner, the menu that comes up won't display anything beyond "Settings", i.e., I can't see the addons, in particular the 'Clean & Quit' add-on button which is the one I most need. Rebooting the phone often fixes the problem, but only temporarily. Any ideas?

Chosen solution

This is most likely bug 832990. The problem was solved for me after I deactivated the "don't keep activities" checkbox in the developer settings!

Read this answer in context 0

Additional System Details

Application

  • User Agent: Mozilla/5.0 (masking-agent; rv:25.0) Gecko/20100101 Firefox/25.0

More Information

jscher2000
  • Top 10 Contributor
8425 solutions 68745 answers

Helpful Reply

I don't have an Android tablet, but will the additional menu items appear if you rotate the screen so it has to redraw in the other orientation (e.g., landscape to portrait, or portrait to landscape)?

I don't have an Android tablet, but will the additional menu items appear if you rotate the screen so it has to redraw in the other orientation (e.g., landscape to portrait, or portrait to landscape)?

Question owner

The problem happens not on the tablet but on the phone (Samsung Galaxy Note 2). Turning it sideways didn't help. One thing that often does bring up the additional menu items is to do a hot boot and restart, but even then you have to use the other addons immediately. If you use Firefox the problem returns and the addons hide. Thanks for your help.

The problem happens not on the tablet but on the phone (Samsung Galaxy Note 2). Turning it sideways didn't help. One thing that often does bring up the additional menu items is to do a hot boot and restart, but even then you have to use the other addons immediately. If you use Firefox the problem returns and the addons hide. Thanks for your help.
kbrosnan
  • Moderator
575 solutions 3796 answers

The only know issue with the menu is that if the keyboard is open the menu is not panable.

The menu does have a max height and can be panned up or down to show items off the list.

The only know issue with the menu is that if the keyboard is open the menu is not panable. The menu does have a max height and can be panned up or down to show items off the list.

Question owner

Thanks for replying. I'm not seeing the presence of the keyboard having anything to do the problem. I count 7 items on the menu, the last of those being "settings" - beyond that you can't see anything. If you reboot you can see all the items including addons, but not after browsing a site or two. Also, moving your finger up and down the menu items doesn't make the other items appear.

Thanks for replying. I'm not seeing the presence of the keyboard having anything to do the problem. I count 7 items on the menu, the last of those being "settings" - beyond that you can't see anything. If you reboot you can see all the items including addons, but not after browsing a site or two. Also, moving your finger up and down the menu items doesn't make the other items appear.
kbrosnan
  • Moderator
575 solutions 3796 answers

Can you pan the menu such as http://www.youtube.com/watch?v=N_94HU8m97w

The menu location will differ slightly as the phone does not have a hardware menu key.

Can you pan the menu such as http://www.youtube.com/watch?v=N_94HU8m97w The menu location will differ slightly as the phone does not have a hardware menu key.

Question owner

I'm familiar with the fact that the menu is scrollable. The problem continues to be that nothing beyond "Setting" shows in the menu. If you reboot the phone you can bring those items back, but even then it'll only work if you don't surf to any site. After you've done that then they disappear once again. Wierd, eh?

I'm familiar with the fact that the menu is scrollable. The problem continues to be that nothing beyond "Setting" shows in the menu. If you reboot the phone you can bring those items back, but even then it'll only work if you don't surf to any site. After you've done that then they disappear once again. Wierd, eh?

Question owner

I'm still having this problem whereby the menu stops at "settings" and doesn't show anything beyond that no matter how much you scroll it. It's also happening on the tablet. Let me ask this: when you hit the menu button, is "Settings" supposed to come on right away? Mine is faded at first (i.e., inaccessable) then the addons show up (i.e., when it works). Often it just locks up and shows nothing beyond "Setting"? Let me ask: should "Settings" be faded first or should it be immediately usable?

I'm still having this problem whereby the menu stops at "settings" and doesn't show anything beyond that no matter how much you scroll it. It's also happening on the tablet. Let me ask this: when you hit the menu button, is "Settings" supposed to come on right away? Mine is faded at first (i.e., inaccessable) then the addons show up (i.e., when it works). Often it just locks up and shows nothing beyond "Setting"? Let me ask: should "Settings" be faded first or should it be immediately usable?
jscher2000
  • Top 10 Contributor
8425 solutions 68745 answers

On my Gingerbread device, yes, Settings is initially grayed and enables after a few moments.

On my Gingerbread device, yes, Settings is initially grayed and enables after a few moments.

Question owner

Thanks for replying. On both my android devices this happens *sometimes* - when it happens it means everything is OK. Other times the whole thing appears with no delay. Mostly it appears right away with no graying, but you can't see anything below "Settings" and it will not scroll - it's frozen. Finding a fix is important because otherwise I can't access the 'Clean & Quit' addon, not to mention all others. Other than a full reboot, the only way to make the addons come back is to go into applications and do a force stop on Firefox - then it works after graying first.

Either I'm doing something wrong somewhere or this is a very nasty bug that needs to be squashed. I hope the developers will look into this because otherwise FF works great and does what I want, just the the beloved desktop version.

Thanks for replying. On both my android devices this happens *sometimes* - when it happens it means everything is OK. Other times the whole thing appears with no delay. Mostly it appears right away with no graying, but you can't see anything below "Settings" and it will not scroll - it's frozen. Finding a fix is important because otherwise I can't access the 'Clean & Quit' addon, not to mention all others. Other than a full reboot, the only way to make the addons come back is to go into applications and do a force stop on Firefox - then it works after graying first. Either I'm doing something wrong somewhere or this is a very nasty bug that needs to be squashed. I hope the developers will look into this because otherwise FF works great and does what I want, just the the beloved desktop version.

Modified by humbz

jscher2000
  • Top 10 Contributor
8425 solutions 68745 answers

You might want to go ahead and file a bug report. Although the volunteers here interact with the applications as end users, we probably do not have technical insight on how add-ons get on the menu or why they might disappear.

https://bugzilla.mozilla.org/

You might want to go ahead and file a bug report. Although the volunteers here interact with the applications as end users, we probably do not have technical insight on how add-ons get on the menu or why they might disappear. https://bugzilla.mozilla.org/
DieterDietrich 2 solutions 4 answers

Chosen Solution

This is most likely bug 832990. The problem was solved for me after I deactivated the "don't keep activities" checkbox in the developer settings!

This is most likely [http://bugzil.la/832990 bug 832990]. The problem was solved for me after I deactivated the "don't keep activities" checkbox in the developer settings!