X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

how i can to download vedio downloadhelper to my firefox

Posted

the version of my firefox is 18.0 and also i tried 19.00 but every time there is a masseg told me that the ons is not compatible with my firefox and my android is 4.0.3

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.1 r115

Application

  • User Agent: Mozilla/5.0 (Android; Mobile; rv:19.0) Gecko/19.0 Firefox/19.0

More Information

Andrew
  • Top 25 Contributor
  • Moderator
252 solutions 3019 answers

Please contact the developer of the addon so they can make it compatible with the latest version of Firefox. Thank You!