Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

If I attempt to install some add-ons I get the message "This add-on is not available on your platform".

  • 4 replies
  • 1 has this problem
  • 31 views
  • Last reply by Jim

more options

Using an ASUS ZenPad 3S 10 running Andriod 7.0. The add-on I am attempting to install is LastPass. If I choose Help in Firefox I am taken to the support website and cannot determine my version of Firefox. Any ideas?

Modified by Jim

Chosen solution

I was looking at the wrong menu. You are right though the add-on really doesn't work with my configuration.

I will use the app.

Read this answer in context 👍 0

All Replies (4)

more options

On the add-on download page (https://addons.mozilla.org/en-US/firefox/addon/lastpass-password-manager/), open the menu and select "Request desktop site". You are then allowed to install the add-on. However, the interface is not optimized for tablets, therefore, it is recommended to use the LastPass app instead (https://play.google.com/store/apps/details?id=com.lastpass.lpandroid ).

Modified by Jan Hasebos

more options

There is no menu with "Request desktop site"

more options

Are you certain? It should be visible after pressing the three vertical dots in the top-right corner, as described in this help article: http://mzl.la/1xKt6XL

more options

Chosen Solution

I was looking at the wrong menu. You are right though the add-on really doesn't work with my configuration.

I will use the app.