Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Thunderbird does not use the right email to answer to a mailing list, what's happening ?

  • 28 replies
  • 2 have this problem
  • 52 views
  • Last reply by dahut

more options

I have several accounts in my Thunderbird, all under "Local Folders".

I have subscribed to several mailing lists using different emails.

When I want to answer to an email from a list, I click "Reply to the list" but the source email address Thunderbird uses to answer is the first account in Thunderbird. Thunderbird does not use the email which has received the mail from the list.

For example I have :

  • my.name@someplace.com
  • other.mail@mail.com
  • thirdmail@nospam.com

I've subscribed to python mailing list using "other.mail@mail.com". "other.mail@mail.com" is thus the mail which receives mails from python list. When I want to answer a mail from python list, I click on a mail and then click on "Reply to the list". Thunderbird opens a new window mail but the "From" email address is not good, Thunderbird uses "my.name@someplace.com" instead of "other.mail@mail.com".

I have to check the source of the mail I want to answer to know which email address I must put in the "From".

I have currently 34 mailing list subscription, I cannot remember which email goes with which mailing list.

Before Thunderbird did fill correctly the right "From", now it systematically uses the first account's mail !

What is happening ? What can I do ? Is it a bug ?

All Replies (20)

more options

For each account, you can set the Reply-to address in Account Settings and the name of the account, make sure that the Reply-to address is correct.

more options

By default there is no Reply-to address set. Setting it has no effect on my problem.

I have one email per account.

I have 5 emails (5 TB accounts).

The problem is that Thunderbird does not use the right email to answer mails I receive from mailing list.

Is this clearer ? (I'm not used to write in Shakespeare's language)

more options

I think having them all under Local Folders may be part of the problem.

You could try various add-ons that attempt to identify which identity to use, or force you to make a decision. e.g.

Correct Identity Identity Chooser

http://www.ramsden.org.uk/3_How_to_install_Add-ons_in_Thunderbird.html

Modified by Zenos

more options

I use Thunderbird since ~10 years. I have always had these 5 emails into 5 different accounts all into LocalFolders.

Actually I have the same configuration since years.

The only thing I do is updating my Linux system (Mandrake, Mandriva, Fedora, Ubuntu) which provides me Thunderbird updates.

Since a couple of months, Thunderbird behaviour about "Reply-to an email I have received from a mailing list" has changed.

As I said, I uses TB and the lists I'm talking about for years. So I approximately know which mail goes with which list. That's why I point the problem only now (a couple of months later).

So, before TB worked perfect, it has always selected the right mail. Now, it always uses the first email/account that appears in TB accounts parameters.

more options

I believe that I set my reply-to addresses for my accounts using the settings in about:config. The wording for that is clearer there than in the account settings. I do use the global inbox. It is no problem.

more options

We are taking a wrong way.

Setting a "Reply-to" address modifies the mailing list behaviour. For example, I have a mailing list where normally the answers should be sent to the list when users click Reply-to. If I set a Reply-to address in TB, users who answer to my mail send mails only to me. In other words, I force the Reply-to address where I must not do that.

So the solution to my problem is elsewhere. There is a bug in Thunderbird and it has to be corrected.

more options

If you want people on the mailing list to reply to the list service, you would need to have its address in the reply-to field. That would work the same way newsgroups do.

more options

Did you read my original question and did you read carefully my other comments ? If no, you should, if yes, then its serious...

more options

I have a question:

You have five mail accounts. Can you post the following information: In thunderbird Help > Troubleshooting Information click on 'Copy text to clipboard' bitton paste infor into this forum question.

I need to see what Outgoing Server SMTP you are using for each of these accounts.

more options

Can you tell me the relationship between the outgoing smtp servers and the fact that TB uses a wrong "From" email when answering to a mailing list ?

At that point, I've received an email from a list and have clicked "Reply-to", SMTP stuff has not been used yet so I wonder how SMTP can have an impact on the wrong "From"...

more options

Gmail, in particular, requires a unique SMTP "account" for each identity. A gmail smtp server will actually overwrite whatever "from:" address you choose and substitute the gmail address associate with the selected gmail smtp server.

If you're not using gmail, this almost certainly isn't an issue. I haven't yet encountered any other mail provider who does this substitution. A few providers will refuse to send an email using a "foreign" from: identity, but that's a different situation.

However, the "wrong smtp" suggestion occasionally crops up here on the forum, enough so that I have to ask myself if my own experience is specific to the ISPs here in the UK I have used. It may be different in other parts of the world.

Your Troubleshooting Information dump would answer most of the implied questions about your set-up. But I think you're fighting a fairly long-standing quirk of Thunderbird; the very existence of add-ons for choosing an appropriate identity suggests to me that the authors of those add-ons saw the same problem themselves. I agree with you that the "wrong SMTP" is unlikely to be your issue; you get the problem when composing, not after sending.

more options

Is the email you are 'replying to' currently located in a mail account or Local Folders?

more options
  • 5 different accounts
  • 1 email per account
  • all accounts in "Local Folders"
  • in Local Folders, 1 sub-folder per mailing list
  • filters to move mails (if necessary) in sub-folder when received

(thanks for your answers)

more options

I don't understand why you're being so cagey. Your answer just provokes more questions, such as "POP or IMAP?". I assume POP since you can't put IMAP-connected accounts into Local Folders. But you keep making us guess.

more options

Folder Accounts might help you. It lets you associate a specific from: identity with each folder.

more options

I use POP, all emails are downloaded on my computer and removed from the server.

I would like to keep all my emails in Local Folders, this simplifies my work.

Everything worked well since ~2005, this bug has appeared since a couple of month.

(smtp servers I use is an information I prefer keep personal, that's why I asked questions before giving informations)

more options

I should not worry about smtp servers details as many are used by thousands of different people. In other words, it is common data and does not include username or password data.

The point being that if information is requested, then it helps us to understand your setup and what you are using. No one is asking for personal information. so please provide the requested info.

  • In Thunderbird
  • Help > Troubleshooting Information
  • Do NOT check 'include account name'
  • click on 'Copy text to clipboard' button
  • paste info into this forum question.


Confirm:

  • Do you use Message filtering to put emails into Local Folders?

Confirm what setting you have used here~:

  • Tools > Account Settings > Server setting for each pop mail account:
  • click on 'Advanced' button

Have you selected ?

  • 'inbox for different account' : Global Inbox (Local Folders)
  • Include this server when getting new mail


I do recall issues with Global accounts in Local Folders.

Basically, if Thunderbird does not know what account to use, it defaults to send using the designated default mail account settings.

more options

Emails go from themselves to Local Folders. I use filters only for mails coming from mailing lists to move them into sub-folders.

I confirm that I've :

  • "inbox for different account" : Global Inbox (Local Folders)
  • "Include this server when getting new mail"
====
 Paramètres de base de l'application
   Nom: Thunderbird
   Version: 31.4.0
   Agent utilisateur: Mozilla/5.0 (X11; Linux i686; rv:31.0) Gecko/20100101 Thunderbird/31.4.0
   Répertoire de profil: Ouvrir le dossier correspondant
             (Lecteur local)
   Identifiant de compilation de l'application: 20150114084236
   Plugins activés: about:plugins
   Configuration de compilation: about:buildconfig
   Utilisation mémoire: about:memory
 Comptes courrier et groupes
   account1:
     INCOMING: account1, , (none) Local Folders, plain, passwordCleartext
   account2:
     INCOMING: account2, , (pop3) pop.xxxxxx.fr:110, plain, passwordCleartext
     OUTGOING: smtp.xxxxxx.fr:25, plain, none, true
   account3:
     INCOMING: account3, , (pop3) pop.yyyyyy.net:995, SSL, passwordCleartext
     OUTGOING: smtp.yyyyyy.net:465, SSL, passwordCleartext, true
   account4:
     INCOMING: account4, , (nntp) news:119, plain, passwordCleartext
     OUTGOING: smtp.xxxxxx.fr:25, plain, none, true
   account5:
     INCOMING: account5, , (pop3) pop.yyyyyy.net:995, plain, passwordCleartext
     OUTGOING: smtp.yyyyyy.net:25, plain, passwordCleartext, true
   account6:
     INCOMING: account6, , (pop3) pop.yyyyyy.net:110, plain, passwordCleartext
     OUTGOING: smtp.yyyyyy.net:25, plain, passwordCleartext, true
   account7:
     INCOMING: account7, , (nntp) news.zzzzzzzz.org:119, plain, passwordCleartext
     OUTGOING: smtp.xxxxxx.fr:25, plain, none, true
   account8:
     INCOMING: account8, , (nntp) news.aaaaaaaaaa.aa:119, plain, passwordCleartext
     OUTGOING: smtp.xxxxxx.fr:25, plain, none, true
 Rapports de plantage
   http://crash-stats.mozilla.com/report/index/bp-3b4c46ec-5eb9-46b5-b779-6de652120919 (19/09/2012)
   http://crash-stats.mozilla.com/report/index/bp-9a0de9aa-7fd2-4d8b-9cf1-70bae2120919 (19/09/2012)
   http://crash-stats.mozilla.com/report/index/bp-f74c068c-de0a-453c-9146-34a462120904 (04/09/2012)
   http://crash-stats.mozilla.com/report/index/bp-f5b6b854-40d1-4446-a892-273af2120904 (04/09/2012)
 Extensions
   British English Dictionary, 1.19.1, true, en-GB@dictionaries.addons.mozilla.org
   Dictionnaire français «Réforme 1990», 4.3, true, fr-reforme1990@dictionaries.addons.mozilla.org
   Lightning, 3.3.3, true, {e2fda1a4-762b-4020-b5ad-a41df1933103}
   Remove Duplicate Messages, 0.1.14, true, {12345678-1234-1234-1234-123456789abc}
 Préférences modifiées importantes
   Nom: Valeur
     accessibility.typeaheadfind.flashBar: 0
     browser.cache.disk.capacity: 10240
     browser.cache.disk.smart_size.enabled: false
     browser.cache.disk.smart_size.first_run: false
     browser.cache.disk.smart_size.use_old_max: false
     extensions.lastAppVersion: 31.4.0
     gfx.blacklist.suggested-driver-version: <Anything with EXT_texture_from_pixmap support>
     mail.openMessageBehavior.version: 1
     mailnews.database.global.datastore.id: f28a2dce-f937-4511-bd5b-678a76f3a4d
     network.cookie.prefsMigrated: true
     network.protocol-handler.warn-external.file: true
     network.protocol-handler.warn-external.ftp: true
     network.protocol-handler.warn-external.http: true
     network.protocol-handler.warn-external.https: true
     places.database.lastMaintenance: 1333010881
     places.history.expiration.transient_current_max_pages: 95128
     places.history.expiration.transient_optimal_database_size: 151827250
     plugin.importedState: true
     print.printer_CUPS/PSC.print_command: lpr ${MOZ_PRINTER_NAME:+'-P'}${MOZ_PRINTER_NAME}
     print.printer_CUPS/PSC.print_downloadfonts: true
     print.printer_CUPS/PSC.print_in_color: true
     print.printer_CUPS/PSC.print_paper_height: 279,40

[...] (removed to be below the 10,000 characters limit)

     print.tmp.printerfeatures.Samsung_ML-1210_USB_1.supports_spoolercommand_change: false
 Accélération graphique
     Description de la carte: X.Org -- Gallium 0.4 on AMD PALM
     ID du vendeur: X.Org
     ID du périphérique: Gallium 0.4 on AMD PALM
     Version du pilote: 3.0 Mesa 10.3.3
     Rendu WebGL: false
     Fenêtres avec accélération graphique: 0
     AzureCanvasBackend: cairo
     AzureSkiaAccelerated: 0
     AzureFallbackCanvasBackend: none
     AzureContentBackend: cairo
 JavaScript
 Ramasse-miettes incrémentiel: 1
 Accessibilité
   Activée: 0
   Empêcher l'accessibilité: 0
 Versions des bibliothèques
     Version minimale attendue
     Version utilisée
     NSPR
     4.10.7
     4.10.8
     NSS
     3.17.3 Basic ECC
     3.17.4 Extended ECC
     NSS Util
     3.17.3
     3.17.4
     NSS SSL
     3.17.3 Basic ECC
     3.17.4 Extended ECC
     NSS S/MIME
     3.17.3 Basic ECC
     3.17.4 Extended ECC
more options

Can you also check something else for me: In one of those mailing list emails which selects wrong email address. select the email: click on 'Other Actions' and select ' view source'

  • Is there a 'Delivered-to' header?
  • Does it display the correct email address?
  • Is it the same email address as entered in the 'TO' header ?
  • Is this the email address of the correct mail account?
  • Is this the email address you would expect to use as FROM when you REply-to all ?
more options

Given that you've mentioned "newslists", does this addressing problem affect only the nntp accounts 4, 7 and 8?

  1. 1
  2. 2