X
Tap here to go to the mobile version of the site.

Support Forum

Firefox has stopped opening the browser tabs I set

Posted

I defined my home page as https://www.google.co.uk/|https:uk.yahoo.com/ Firefox no longer open on this but instead opens a new tab.

Can I correct this by resetting values in about:config. If so what values do I have to change?

I defined my home page as https://www.google.co.uk/|https:uk.yahoo.com/ Firefox no longer open on this but instead opens a new tab. Can I correct this by resetting values in about:config. If so what values do I have to change?
guigs 1072 solutions 11697 answers

Helpful Reply

Hi Aldhelm2, I understand that you have two pages that open up as a homepage, however I am not sure if you have set it up to open two pages or just. Nonetheless I have provided the steps to change the homepage and the new tab via the about:config entry.

It sounds like a setting was changed on your new tab page. I understand that you would like to know how to change the home page back as well. Below are the instructions on how to change the new tab page if you need to change this as well.

  1. In the Location bar, type about:config and press Enter. The "This might void your warranty!" warning page may appear.
  2. Click I'll be careful, I promise! to continue to the about:config page.
  3. Type browser.newtab.url in the search box to find it on the list.
  4. Double-click on browser.newtab.url and type in about:newtab in the window that pops up.

Restart Firefox and open a new tab to make sure the change was made. To change the homepage:search for browser.startup.homepage and doubleclick on the entry to enter the url. Please post back with your results, we are happy to help.

Hi Aldhelm2, I understand that you have two pages that open up as a homepage, however I am not sure if you have set it up to open two pages or just. Nonetheless I have provided the steps to change the homepage and the new tab via the about:config entry. It sounds like a setting was changed on your new tab page. I understand that you would like to know how to change the home page back as well. Below are the instructions on how to change the new tab page if you need to change this as well. # In the [[Location bar autocomplete|Location bar]], type '''about:config''' and press '''Enter'''. The "''This might void your warranty!''" warning page may appear. # Click '''I'll be careful, I promise!''' to continue to the about:config page. # Type '''browser.newtab.url''' in the search box to find it on the list. # Double-click on '''browser.newtab.url''' and type in ''about:newtab'' in the window that pops up. Restart Firefox and open a new tab to make sure the change was made. To change the homepage:search for browser.startup.homepage and doubleclick on the entry to enter the url. Please post back with your results, we are happy to help.

Question owner

Thanks for you advice guigs2 but unfortunately it did not solve my problem.

For my next attempt at solving the problem I uninstalled Firefox and re-installed it. It now opens 2 tabs: it opens Google but still will not load www.uk.yahoo.com

Can anyone suggest a fix?

Thanks for you advice guigs2 but unfortunately it did not solve my problem. For my next attempt at solving the problem I uninstalled Firefox and re-installed it. It now opens 2 tabs: it opens Google but still will not load www.uk.yahoo.com Can anyone suggest a fix?
FredMcD
  • Top 10 Contributor
4220 solutions 58899 answers

Bookmark this; Mozilla Search Reset {web link} This add-on is very simple: on installation, it backs up and then resets your search preferences and home page to their default values, and then uninstalls itself. This affects the search bar, URL bar searches, and the home page.

Bookmark this; '''[https://addons.mozilla.org/en-US/firefox/addon/searchreset/ Mozilla Search Reset]''' {web link} This add-on is very simple: on installation, it backs up and then resets your search preferences and home page to their default values, and then uninstalls itself. This affects the search bar, URL bar searches, and the home page.
FredMcD
  • Top 10 Contributor
4220 solutions 58899 answers

Run the above program. Then try to redo your settings.

Run the above program. Then try to redo your settings.
cor-el
  • Top 10 Contributor
  • Moderator
17407 solutions 157253 answers

You can check the target line in the Firefox desktop shortcut (right-click: Properties) to make sure that nothing is appended after the path to the Firefox program.

You can check the startup setting:

  • Tools > Options > General > Startup: "When Firefox Starts":
    "Show my windows and tabs from last time"
    "Show my home page"
    "Show a blank page"
You can check the target line in the Firefox desktop shortcut (right-click: Properties) to make sure that nothing is appended after the path to the Firefox program. You can check the startup setting: *Tools > Options > General > Startup: "When Firefox Starts":<br>"Show my windows and tabs from last time"<br>"Show my home page"<br>"Show a blank page"