Αναζήτηση στην υποστήριξη

Προσοχή στις απάτες! Δεν θα σας ζητήσουμε ποτέ να καλέσετε ή να στείλετε μήνυμα σε κάποιον αριθμό τηλεφώνου ή να μοιραστείτε προσωπικά δεδομένα. Αναφέρετε τυχόν ύποπτη δραστηριότητα μέσω της επιλογής «Αναφορά κατάχρησης».

Learn More

No option to Uncheck Underline Links

  • 7 απαντήσεις
  • 15 έχουν αυτό το πρόβλημα
  • 373 προβολές
  • Τελευταία απάντηση από cor-el

more options

Just updated to the latest firefox version 119, and noticed that the url links are now all underlined again. Checked the support page that says it can be undone in settings, but when I opened up to the said setting page, there's no option to uncheck underline links. Where else can underline links be disabled?

Just updated to the latest firefox version 119, and noticed that the url links are now all underlined again. Checked the support page that says it can be undone in settings, but when I opened up to the said setting page, there's no option to uncheck underline links. Where else can underline links be disabled?
Συνημμένα στιγμιότυπα

Επιλεγμένη λύση

It is still there in ua.css

:any-link {
  cursor: pointer;
  text-decoration: underline;
}

You do not want to force it for all cases like SVG links.

a:any-link {
  /* We don't want SVG link to be underlined */
  text-decoration: none;
}

See also:

  • 1664278 - Feature request: “Always underline links in text” option in Firefox
Ανάγνωση απάντησης σε πλαίσιο 👍 0

Όλες οι απαντήσεις (7)

more options

This was removed by Bug 1853323, apparently it didn't work consistently anyway.

Equivalent userContent.css:

*|*:any-link { 
  text-decoration: none; 
}

Χρήσιμο;

more options

Επιλεγμένη λύση

It is still there in ua.css

:any-link {
  cursor: pointer;
  text-decoration: underline;
}

You do not want to force it for all cases like SVG links.

a:any-link {
  /* We don't want SVG link to be underlined */
  text-decoration: none;
}

See also:

  • 1664278 - Feature request: “Always underline links in text” option in Firefox

Χρήσιμο;

more options

Thanks zeroknight and cor-el.

The solution presented by both of you solved the issue through CSS.

Χρήσιμο;

more options

To elaborate on cor-el's solution, for those who have no experience with the userContent.css, here is how you now change your preference to not underline links by default:

Go to "about:config" Toggle "toolkit.legacyUserProfileCustomizations.stylesheets" to "true"

Go to "about:support" Look for "Profile Folder" Click "Show in Finder" (on Mac), "Show Folder" (Windows), "Open Directory" (Linux) or "Open Containing Folder".

In that profile folder, look for "chrome" folder, create if not present

In "chrome" folder, edit or create "userContent.css" file, put this in there:

 *|*:any-link {
   text-decoration: none;
 }

Restart Firefox

Τροποποιήθηκε στις από το χρήστη Scarabaeus23

Χρήσιμο;

more options

I need more help. Where do I find about:config? I am using MacOS 13.5.2 and Firefox 119.0.1. And why is it so hard to get rid of the underlining? The ability to disable link underlining is why I first started using Firefox many years ago. Thank you.

Χρήσιμο;

more options

The easiest way is to install the extension "Default links not to be underlined" made by a Firefox developer.

Χρήσιμο;

more options

Note that Firefox 120 will have a pref to force underlining of links and Firefox 121 exposes this pref in "Settings -> General -> Browsing: Always underline links", so make sure you do not enable this setting.

Χρήσιμο;

Υποβολή ερώτησης

Πρέπει να συνδεθείτε στον λογαριασμό σας για να απαντήσετε σε δημοσιεύσεις. Ξεκινήστε μια νέα ερώτηση εάν δεν διαθέτετε ακόμα λογαριασμό.