Search Support

How to set the font for plain-text messages?

  • 14 απαντήσεις
  • 4 έχουν αυτό το πρόβλημα
  • 506 προβολές
  • Τελευταία απάντηση από malpal

more options

In simple language, how do I set the font in which plain-text e-mail messages are displayed in Thunderbird 68? They seem to show up in a very small sans-serif monospace font, but I would like to display them in a larger serif monospace (like Courier New).

I expected to find the setting in Tools/Options/Display/Formatting/Plain Text Messages, but there is only a provision to distinguish quoted plain text replies, not to set the main font.

I am running Thunderbird 68.4.1 under Windows 10.

Τροποποιήθηκε στις από το χρήστη Rich Pasco

Επιλεγμένη λύση

Tools/Options/Display/Formatting/Fonts & Colors, Advanced..., set the Sizes and fonts with Fonts for: Latin, repeat with Fonts for: Other Writing Systems. Uncheck 'Allow messages to use other fonts'. Sizes are in pixels, which are about 50% smaller than points, so 18px ~ 9pt.

http://kb.mozillazine.org/Font_settings_in_Thunderbird

Ανάγνωση απάντησης σε πλαίσιο 👍 2

All Replies (14)

more options

Επιλεγμένη λύση

Tools/Options/Display/Formatting/Fonts & Colors, Advanced..., set the Sizes and fonts with Fonts for: Latin, repeat with Fonts for: Other Writing Systems. Uncheck 'Allow messages to use other fonts'. Sizes are in pixels, which are about 50% smaller than points, so 18px ~ 9pt.

http://kb.mozillazine.org/Font_settings_in_Thunderbird

Helpful?

more options

Thanks, sfhowes, for the detailed steps. Worked like a charm!

Helpful?

more options

I don't understand. Messages are displayed in various fonts, depending on whether they're proportional or fixed-width, which is fine by me. But I find the font too small for my liking. But whatever value I Enter at Tools/Options/Display/Formatting/Fonts & Colors, Advanced..., nothing changes. Or to be more precise: if I set them to the maximum, I see a change in the preview window of collapsed discussions, and the occasional single maessage. But most of the individual messages are displayed in the same tiny font I had to begin with.

Is something broken in the new Thunderbird?

On another page I see some very obscure instructions about editing config, but surely there must be an easier way to change the display font size of incoming messages than that?

Helpful?

more options

Frank said

I don't understand. Messages are displayed in various fonts, depending on whether they're proportional or fixed-width, which is fine by me. But I find the font too small for my liking. But whatever value I Enter at Tools/Options/Display/Formatting/Fonts & Colors, Advanced..., nothing changes. Or to be more precise: if I set them to the maximum, I see a change in the preview window of collapsed discussions, and the occasional single maessage. But most of the individual messages are displayed in the same tiny font I had to begin with. Is something broken in the new Thunderbird? On another page I see some very obscure instructions about editing config, but surely there must be an easier way to change the display font size of incoming messages than that?

The settings in Options/Display...Advanced apply to message content, but you seem to be referring to the font in the Threads Pane, i.e. the list of messages in a folder. That is a separate setting that can be changed by adjusting a Config. editor preference or with a userChrome.css file:

https://support.mozilla.org/en-US/questions/1269361

Helpful?

more options

On the contrary. I *want* to change the font size of the message content. But changing the font sizes at Tools/Options/Display/Formatting/Fonts & Colors, Advanced... has no effect whatsoever in that regard.

However, if I change the font size at Tools/Options/Display/Formatting/Fonts & Colors, Advanced..., the font in the threads pane (and the font in a small number of messages) *does* change, without changing config editor or anything like that.

Helpful?

more options

Sorry, my bad. The problem seemed to be that I should switch folders after changing the options. If I just clicked back between messages in the same folder I had open before I made the changes, the view wasn't refreshed for some reason. After switching to a different folder or a different account the changes in display settings do take effect.

Helpful?

more options

Actually not, that's not true. The fonts are all over the place. For a minute it looked as though they'd grown bigger, but that was apparently just because I zoomed. Now they're small again. No matter what value I give them in Tools&cblablabbla.

I had prepared screenshots to show what size, but *now* suddenly plain text messages are a *little* bigger. And if I switch from one of those messages to a folder mainly containing styles messages, they look bigger at first, but when I click on another messages in the folder they're smaller again.

Also, the plain text message that looks bigger, looks bigger in the preview window. But when i double click it to open in a separate window, the letters are small again.

And I mean, on Usenet... that's all plain text, right? Some messages are displayed in a big font now, and some in a small font. How is that even possible?

Why is the simple display of font sizes in TB so incredibly difficult and esoteric?

Also, is there an indicator *somewhere* where you can see to what percentage you've zoomed, if you've zoomed?

By the way, is there a Usenet support group for TB somewhere? This whole webforum interface isn't really my thing.

Helpful?

more options

I mean this is how Usenet looks. That's plain crazy. Two messages in a row, displayed totally differently. Without changing the settings in between. Plus a screensot of the settings I get this with. Not that it changes anything if I change any of those settings...

Must be something I'm not getting. I just don't get what it is.

Helpful?

more options

One thing often overlooked is to set the sizes and fonts in the Advanced section with Fonts for: Other Writing Systems.

The news.mozilla.org server has a mozilla.support.thunderbird group, which you can also access via Google Groups.

Helpful?

more options

Thanks, that was it. & found it, it thanks again.

Helpful?

more options

I don't have 'Option' under "Tools" menu. I'm running Thunderbird 77.0b1 on Linux OS.

Where is that font setting?

Helpful?

more options

egbertst1 said

I don't have 'Option' under "Tools" menu. I'm running Thunderbird 77.0b1 on Linux OS. Where is that font setting?

Edit/Preferences/Display/Formatting/Fonts & Colors, Advanced..., for TB 68,

Edit/Preferences/General/Language & Appearance/Fonts & Colors, Advanced..., for TB 77b.

Helpful?

more options

I've just installed Thunderbird. I wish to change the incoming message font type but Options/Display/Fonts&colours/Advanced refuses to change from Latin to Other Writing Systems or Serif from Cambria to Times New Roman. There is no save changes button so when I click on the cross everything reverts to default. Help me too please.

Helpful?

more options

Subsequently I have discovered the Fonts & Encodings window was displaying only two thirds. The whole thing appeared after I had "turned it off and turned it on again". The required buttons then became apparent.

Helpful?

Κάντε μια ερώτηση

Πρέπει να συνδεθείτε στο λογαριασμό σας για να απαντήσετε στις δημοσιεύσεις. Παρακαλούμε ξεκινήστε μια νέα ερώτηση, αν δεν έχετε ήδη λογαριασμό.