Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I am searching for a server-side fix (with f.e. css) for the fact that Firefox uses the systems DPI settings, which makes my website look (too) big.

  • 3 ŋuɖoɖowo
  • 1 masɔmasɔ sia le esi
  • 14 views
  • Nuɖoɖo mlɔetɔ diho

more options

My website is displayed way too big in firefox. And I want all browsers to view my website properly. I know there are settings wihtin firefox which fix this. But I am searching for a server-side fix, so that visitors of my website don't have to be bothered with changing their settings.

My website is displayed way too big in firefox. And I want all browsers to view my website properly. I know there are settings wihtin firefox which fix this. But I am searching for a server-side fix, so that visitors of my website don't have to be bothered with changing their settings.

Ŋuɖoɖo si wotia

You may have to change your site soon as Chrome 30 and IE 11 will also use the system DPI setting (like Firefox does now).

Possible solution:

  • Type about:config into the Firefox address bar and tap on the Enter key.
  • If the warning This might void your warranty appears, click I'll be careful, I promise.
  • Search for layout.css.devPixelsPerPx

Fx22layout.css.devPixelsPerPx

  • Double-click on layout.css.devPixelsPerPx to modify its value. The default is -1.0 in Firefox 22 and above. Change it to 1.0 to make it work like in previous Firefox versions.

If necessary, further adjust the value in 0.1 or 0.05 steps. Use values between 1.0 and about 0.5 to reduce elements in size. Use values greater than 1.0 to increase size. For example, a value of 1.25 will increase font size to 125% to accommodate the default DPI setting in Windows 8. Double check the value that you enter. Setting a too small value will make everything disappear and a too large value will blow things up.

If web pages still need to be adjusted then you can look at the Default FullZoom Level or NoSquint extension.

To adjust the font size for the user interface, you can use the Theme Font & Size Changer extension.

Xle ŋuɖoɖo sia le goya me 👍 0

All Replies (3)

more options

Ɖɔɖɔɖo si wotia

You may have to change your site soon as Chrome 30 and IE 11 will also use the system DPI setting (like Firefox does now).

Possible solution:

  • Type about:config into the Firefox address bar and tap on the Enter key.
  • If the warning This might void your warranty appears, click I'll be careful, I promise.
  • Search for layout.css.devPixelsPerPx

Fx22layout.css.devPixelsPerPx

  • Double-click on layout.css.devPixelsPerPx to modify its value. The default is -1.0 in Firefox 22 and above. Change it to 1.0 to make it work like in previous Firefox versions.

If necessary, further adjust the value in 0.1 or 0.05 steps. Use values between 1.0 and about 0.5 to reduce elements in size. Use values greater than 1.0 to increase size. For example, a value of 1.25 will increase font size to 125% to accommodate the default DPI setting in Windows 8. Double check the value that you enter. Setting a too small value will make everything disappear and a too large value will blow things up.

If web pages still need to be adjusted then you can look at the Default FullZoom Level or NoSquint extension.

To adjust the font size for the user interface, you can use the Theme Font & Size Changer extension.

kobe trɔe

more options

Reset the page zoom on pages that cause problems.

  • View > Zoom > Reset (Ctrl+0 (zero); Command+0 on Mac)
more options

@Waka_Flocka_Flame, Thanks for your help and information, I guess the only option to fix this on my part is making my website layout more fluid.

@cor-el, I already knew how to do that, re-read my question, because that was not wat I asked for. Anway, still thanks for your effort.