Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox 68.8.0-ESR in Raspbian cannot find webcam or microphone

  • 1 ŋuɖoɖo
  • 1 masɔmasɔ sia le esi
  • 10 views
  • Nuɖoɖo mlɔetɔ cor-el

more options

I have a Raspberry Pi 4 running Raspbian (Buster). It has both Chromium and Firefox 68.8.0-ESR installed and has a Logitech C370 USB webcam.

Firefox cannot find either the camera or microphone on the webcam. I see only "Default Video Device" and "Default Audio Device" as choices when I try to select devices. The C370 cannot be located with the Raspbian version of Firefox.

Trying to use the webcam in https://meet.jit.si just results in a blank gray window. Trying to use the webcam in https://webcamtests.com results in a blank test window with solid cycling colors.

I have no problem using the C370 webcam using Chromium or using Firefox 71 under Ubuntu for Raspberry Pi, so I know that the hardware works fine and the Firefox could work too.

Does anyone know if I need to change any preference settings, etc under Firefox 68.8.0-ESR to make things work? Or is this a lost cause?

I have a Raspberry Pi 4 running Raspbian (Buster). It has both Chromium and Firefox 68.8.0-ESR installed and has a Logitech C370 USB webcam. Firefox cannot find either the camera or microphone on the webcam. I see only "Default Video Device" and "Default Audio Device" as choices when I try to select devices. The C370 cannot be located with the Raspbian version of Firefox. Trying to use the webcam in https://meet.jit.si just results in a blank gray window. Trying to use the webcam in https://webcamtests.com results in a blank test window with solid cycling colors. I have no problem using the C370 webcam using Chromium or using Firefox 71 under Ubuntu for Raspberry Pi, so I know that the hardware works fine and the Firefox could work too. Does anyone know if I need to change any preference settings, etc under Firefox 68.8.0-ESR to make things work? Or is this a lost cause?

All Replies (1)

more options

Try the Raspberry forum.