Where did you install Firefox from? Help Mozilla uncover 3rd party websites that offer problematic Firefox installation by taking part in our campaign. There will be swag, and you'll be featured in our blog if you manage to report at least 10 valid reports!

Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

ProductCode (ProductID) after Firefox Setup 68.5.0esr.msi is installed - Not the same as .MSI installer

  • 1 ŋuɖoɖo
  • 1 masɔmasɔ sia le esi
  • 11 views
  • Nuɖoɖo mlɔetɔ Mike Kaply

more options

The ProductCode (ProductID) after Firefox Setup 68.5.0esr.msi is installed does not match to the ProductCode (ProductID) of the Firefox Setup 68.5.0esr.msi. We use SCCM to create the application deployment for Firefox ESR x64 and to install all the endpoints. When creating the deployment, SCCM automatically extracts the ProductCode, and uses the same to detect the presence of the application - if it's not present, it installs. The main issue is that when SCCM checks again the presence after it's installed, the deployment fails because the ProductCode after it's installed is different than what came with the MSI installer. I noticed that this is the case as well for Firefox Setup 68.4.0x esr.msi whereas in the past this was not the case.

See the attached file to see the screenshots.

The ProductCode (ProductID) after Firefox Setup 68.5.0esr.msi is installed does not match to the ProductCode (ProductID) of the Firefox Setup 68.5.0esr.msi. We use SCCM to create the application deployment for Firefox ESR x64 and to install all the endpoints. When creating the deployment, SCCM automatically extracts the ProductCode, and uses the same to detect the presence of the application - if it's not present, it installs. The main issue is that when SCCM checks again the presence after it's installed, the deployment fails because the ProductCode after it's installed is different than what came with the MSI installer. I noticed that this is the case as well for Firefox Setup 68.4.0x esr.msi whereas in the past this was not the case. See the attached file to see the screenshots.
Screen ƒe photowo kpe ɖe eŋu

All Replies (1)

more options

Can you check to see if this bug covers your situation?

https://bugzilla.mozilla.org/show_bug.cgi?id=1505436