X
Tippen Sie hierhin, um die Version dieser Website für Mobilgeräte aufzurufen.

Hilfeforum

Firefox doesn't randomly load webpages

Veröffentlicht

Hi,

I use Firefox v590.0.2 (64 bits) with Windows 10.

I use Firefox at my work, only for browsing our intranet. I'm a web developer so I load many pages on our intranet. Since a few weeks, I noticed that the pages are not always loaded correctly: the page starts to be loaded, and then it stops and it's loading forever (with the "Waiting for XXX" message at the bottom left). If I refresh the page it will eventually load as expected.

I tried to install a new Firefox on *another* computer, and I use it to browse the same website. And the same behavior appears: it works very fast and well for some pages, and then randomly stops working for some random pages.

On my main computer I tried to create new profiles, delete everything, without success.

I also tried to deactivate the hardware acceleration on both Firefox, without success.

When I check the Network tab from the web developer bar, I can see that some CSS files (it's not always the same, and it can be 1 or several CSS files) are not loaded (see the attachment) and appears with a grey dot, just like if the browser was trying to load them but it cannot, blocking the page. (I've also noticed it could impact other resources, like, at least images)

Before v59 I've never seen this behavior.

Note :

 - our intranet is on Sharepoint, with NTLM auth
 - at home I use Firefox on my personal computer and it works normally (but I don't browser the work intranet)
 - at work, because it's on the intranet, the network doesn't go thru a proxy
 - I'm now using Chrome because of this issue with Firefox, and the problem doesn't occur in Chrome

Thanks for any help.

Hi, I use Firefox v590.0.2 (64 bits) with Windows 10. I use Firefox at my work, only for browsing our intranet. I'm a web developer so I load many pages on our intranet. Since a few weeks, I noticed that the pages are not always loaded correctly: the page starts to be loaded, and then it stops and it's loading forever (with the "Waiting for XXX" message at the bottom left). If I refresh the page it will eventually load as expected. I tried to install a new Firefox on *another* computer, and I use it to browse the same website. And the same behavior appears: it works very fast and well for some pages, and then randomly stops working for some random pages. On my main computer I tried to create new profiles, delete everything, without success. I also tried to deactivate the hardware acceleration on both Firefox, without success. When I check the Network tab from the web developer bar, I can see that some CSS files (it's not always the same, and it can be 1 or several CSS files) are not loaded (see the attachment) and appears with a grey dot, just like if the browser was trying to load them but it cannot, blocking the page. (I've also noticed it could impact other resources, like, at least images) Before v59 I've never seen this behavior. Note : - our intranet is on Sharepoint, with NTLM auth - at home I use Firefox on my personal computer and it works normally (but I don't browser the work intranet) - at work, because it's on the intranet, the network doesn't go thru a proxy - I'm now using Chrome because of this issue with Firefox, and the problem doesn't occur in Chrome Thanks for any help.
Angefügte Screenshots

Geändert am von AymKdn

Ausgewählte Lösung

I've just tried to update to beta channel, Firefox v60.0b11, and so far the issue seems fixed... !

Diese Antwort im Kontext lesen 0

Mehr Details zum System

Installierte Plugins

  • Shockwave Flash 29.0 r0

Anwendung

  • User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:59.0) Gecko/20100101 Firefox/59.0

Weitere Informationen

FredMcD
  • Top 10 Contributor
4272 Lösungen 59919 Antworten
Veröffentlicht

Make sure you are not blocking content.

Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?


One issue that seems more common lately is Firefox's Tracking Protection feature. When it is blocking content in a page, a shield icon will appear at the left end of the address bar next to the padlock icon. This article has more info on managing this feature: Tracking Protection {web link}

Make sure you are not blocking content. [https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode] {web link} by holding down the '''<Shift> ''(Mac=Options)''''' key, and then starting Firefox. A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Is the problem still there? --------------- One issue that seems more common lately is Firefox's Tracking Protection feature. When it is blocking content in a page, a shield icon will appear at the left end of the address bar next to the padlock icon. This article has more info on managing this feature: [https://support.mozilla.org/en-US/kb/tracking-protection Tracking Protection] {web link}
Veröffentlicht

Fragesteller

Thanks @FredMcD, but starting Firefox in Safe Mode doesn't help. Also there is no "shield icon" in the URL bar (as shown in my screenshot), so it's probably not related to Tracking Protection.

As I said, it's totally random and will happen maybe once every ten pages loaded.

Thanks @FredMcD, but starting Firefox in Safe Mode doesn't help. Also there is no "shield icon" in the URL bar (as shown in my screenshot), so it's probably not related to Tracking Protection. As I said, it's totally random and will happen maybe once every ten pages loaded.
FredMcD
  • Top 10 Contributor
4272 Lösungen 59919 Antworten
Veröffentlicht

Let's make sure your system is clean.

You may have ad/mal-ware. Further information can be found in this article; https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-caused-malware?cache=no

Run most or all of the listed malware scanners. Each works differently. If one program misses something, another may pick it up.

Let's make sure your system is clean. You may have ad/mal-ware. Further information can be found in this article; https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-caused-malware?cache=no Run most or all of the listed malware scanners. Each works differently. If one program misses something, another may pick it up.
Veröffentlicht

Fragesteller

I don't have any malware or virus (my system is protected by my enterprise antivirus with high level of protection, and I tried to install Firefox on a brand new system on a virtual machine, and the same problem appears).

I don't have any malware or virus (my system is protected by my enterprise antivirus with high level of protection, and I tried to install Firefox on a brand new system on a virtual machine, and the same problem appears).

Geändert am von AymKdn

Veröffentlicht

Ausgewählte Lösung

I've just tried to update to beta channel, Firefox v60.0b11, and so far the issue seems fixed... !

I've just tried to update to beta channel, Firefox v60.0b11, and so far the issue seems fixed... !
FredMcD
  • Top 10 Contributor
4272 Lösungen 59919 Antworten
Veröffentlicht

That was very good work. Well done.

AymKdn said

my system is protected by my enterprise antivirus

Not all antivirus can detect malware. Your choice.

That was very good work. Well done. ''AymKdn [[#answer-1099433|said]]'' <blockquote> my system is protected by my enterprise antivirus </blockquote> Not all antivirus can detect malware. Your choice.
Sebbl 0 Lösungen 3 Antworten
Veröffentlicht

Hi, I have the same problem. - SharePoint 2007 with NTLM Auth - SharePoint 2013 with Kerberos Auth and Delegation - Custom ASP.NET Applications with NTLM and Kerberos Auth

Firefox randomly loads the obove mentioned pages indefinitly. The content of the pages is displayed, but the loading animation of the tab won't disappear. I am using Firefox 61.0.2 64bit. My coworkers also have this problem. @AymKdn: Have done some additional tweaking or just updated to the latest Firefox version?

Hi, I have the same problem. - SharePoint 2007 with NTLM Auth - SharePoint 2013 with Kerberos Auth and Delegation - Custom ASP.NET Applications with NTLM and Kerberos Auth Firefox randomly loads the obove mentioned pages indefinitly. The content of the pages is displayed, but the loading animation of the tab won't disappear. I am using Firefox 61.0.2 64bit. My coworkers also have this problem. @AymKdn: Have done some additional tweaking or just updated to the latest Firefox version?
Veröffentlicht

Fragesteller

I decided to reduce my use of Firefox at work because it really became an issue for my day-to-day job, and I now use Chrome as my main browser... It works much better :-)

So, no additional tweaks to provide to you :(

I decided to reduce my use of Firefox at work because it really became an issue for my day-to-day job, and I now use Chrome as my main browser... It works much better :-) So, no additional tweaks to provide to you :(
krnr 0 Lösungen 1 Antworten
Veröffentlicht

Hi,

@Sebbl, could you try to disable Firefox cache and test for a while ?

We're having this issue with sharepoint 2013 (and other web app using NTLM auth) and so far this is the only workaround we found... Actually, in our case, this just mean that something is going wrong with firefox caching (auth, font/css/js loading, something else...)

Hi, @Sebbl, could you try to disable Firefox cache and test for a while ? We're having this issue with sharepoint 2013 (and other web app using NTLM auth) and so far this is the only workaround we found... Actually, in our case, this just mean that something is going wrong with firefox caching (auth, font/css/js loading, something else...)
Sebbl 0 Lösungen 3 Antworten
Veröffentlicht

@krnr We will try this and investigate further.

The issue is hard to reproduce for us since the network tab of the Firefox developer tools is only populated if the developer tools were open when initiating the request and reloading the site solves the issue. We will try some Fiddler / Wireshark / Message Analyzer in our next Sprint since we start getting more and more complaints from our internal customers.

@krnr We will try this and investigate further. The issue is hard to reproduce for us since the network tab of the Firefox developer tools is only populated if the developer tools were open when initiating the request and reloading the site solves the issue. We will try some Fiddler / Wireshark / Message Analyzer in our next Sprint since we start getting more and more complaints from our internal customers.
Sebbl 0 Lösungen 3 Antworten
Veröffentlicht

Cross-linking to this Bugzilla post: https://bugzilla.mozilla.org/show_bug.cgi?id=1484149

Cross-linking to this Bugzilla post: https://bugzilla.mozilla.org/show_bug.cgi?id=1484149
FredMcD
  • Top 10 Contributor
4272 Lösungen 59919 Antworten
Veröffentlicht

krnr said

this just mean that something is going wrong with firefox caching

Try removing the cache.

Location of the cache/cache2 folder; Windows: *C:\Users\<user>\AppData\Local\Mozilla\Firefox\Profiles\<profile>\ Mac: ~/Library/Caches/Firefox/Profiles/ Linux: ~/.cache/mozilla/firefox/

Close Firefox. Open your file browser to the above, and remove the folder.

''krnr [[#answer-1150982|said]]'' <blockquote> this just mean that something is going wrong with firefox caching </blockquote> Try removing the cache. '''Location of the cache/cache2 folder;''' '''Windows: ''' *C:\Users\<user>\AppData\Local\Mozilla\Firefox\Profiles\<profile>\ '''Mac: ''' ~/Library/Caches/Firefox/Profiles/ '''Linux: ''' ~/.cache/mozilla/firefox/ '''Close Firefox. ''' Open your file browser to the above, and remove the '''folder. '''
Honza Bambas 0 Lösungen 1 Antworten
Veröffentlicht

Hello all, the bug has been identified in Firefox and we are working on a fix here .

A functioning workaround is following: - go to about:config - search for network.http.rcwn.enabled - switch it to false

Hello all, the bug has been identified in Firefox and we are working on a fix [https://bugzilla.mozilla.org/show_bug.cgi?id=1484149 here] . A functioning workaround is following: - go to '''about:config''' - search for '''network.http.rcwn.enabled''' - switch it to '''false'''