Hilfe durchsuchen

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Right click fires the left click as well immediately selecting the first item in the menu. What is happening?

  • 14 Antworten
  • 5 haben dieses Problem
  • 30 Aufrufe
  • Letzte Antwort von _x3ro_

more options

When I right click, a left click is immediately fired which causes the first item to be selected. This is frustrating because the menu closes immediately.

Not sure what's going on. I tried downgrading Firefox and I tried a fresh profile. Nothing seemed to resolve this.

Initially I thought this was maybe a GTK3 issue, but I does not occur any other GTK3 application.

Any help?

Thank, Disco-Dave

Alle Antworten (14)

more options

Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?


Try using another mouse. Is the problem still there?

more options

FredMcD said

Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox. A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

Try using another mouse. Is the problem still there?

No luck, still happened. Still happens with other mice as well.

This problem only occurs in firefox, it does not occur in any other program on my computer, including GTK3 apps.

Geändert am von disco-dave

more options

When did the mouse problem start?

disco-dave said

I tried downgrading Firefox and I tried a fresh profile.

Did you use the new profile 'as is?'

more options

FredMcD said

When did the mouse problem start? disco-dave said
I tried downgrading Firefox and I tried a fresh profile.

Did you use the new profile 'as is?'

I downgraded to Firefox 54 and tried in safe mode and with a fresh new profile.

more options

And . . . . .

more options

FredMcD said

And . . . . .

And the same problem persists. The menu still acts as described in original post.

more options

Let’s do a full clean re-install;

Download Firefox For All languages And Systems {web link}

Save the file. Then Close Firefox.

Using your file browser, open the Programs Folder on your computer.

Windows: C:\Program Files C:\Program Files (x86)

Mac: Open the "Applications" folder. https://support.mozilla.org/en-US/kb/how-download-and-install-firefox-mac

Linux: Check your user manual. If you installed Firefox with the distro-based package manager, you should use the same way to uninstall it. See Install Firefox on Linux; https://support.mozilla.org/en-US/kb/install-firefox-linux

If you downloaded and installed the binary package from the Firefox download page, simply remove the folder Firefox in your home directory. http://www.mozilla.org/firefox#desktop ++++++++++++++++++++++++++++ Do Not remove the profiles folder.

Look for, and rename any Mozilla or Firefox program folders by adding .old to them. Do not rename the Mozilla Thunderbird folder if there is one.

more options

I removed firefox and renamed ~/.mozilla/firefox folder to ~/.mozilla/firefox.old

I then tried firefox with a fresh install and the right click issue still happened.

more options
more options

Can you try another mouse?

more options

I did try with a new profile and I did try with another mouse.

The problem still persisted.

more options

Start your Computer in safe mode with network support. Then start Firefox. Try Safe websites. Is the problem still there?

http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode Starting Any Computer In Safe Mode; Free Online Encyclopedia

more options

FredMcD said

Start your Computer in safe mode with network support. Then start Firefox. Try Safe websites. Is the problem still there? http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode Starting Any Computer In Safe Mode; Free Online Encyclopedia

I'm using linux. There is no safemode

more options

I'm having the exact same issue.

I've also tried everything described here with no success. Also disabling hardware acceleration did not help (as described in a similar question here: https://support.mozilla.org/en-US/questions/1180792 )

OS: Arch Linux (64-bit) Firefox: 58.0.2 (64-bit) Window Manager: i3wm (i3 version 4.14.1 (2017-09-24)) uname -rsom: Linux 4.15.4-1-ARCH x86_64 GNU/Linux

I've noticed that, when right-clicking and holding the button down, the context menu stays open and you can select another item by hovering over it and releasing the right mouse button.

Might this be a feature?

If so, it would be great if it could be turned off. With a regular mouse this is not a big deal. You could just hold the right button down and select the item you want. But with a laptop + touch pad and two-finger-right-click it is almost impossible (I have managed to select another item with my touch pad doing a rapid double-right-click-and-hold and then releasing one finger to move the cursor to the selected item but it's a real pain in the ***)