Blockierung des Java-Plugins aufheben

Dieser Artikel wird nicht länger gewartet, darum ist dessen Inhalt möglicherweise veraltet.

Firefox setzte in letzter Zeit ältere Versionen des Java-Plugins auf die Sperrliste, wodurch sie deaktiviert wurden. Dies wurde gemacht, weil diese alten Versionen für Angriffe anfällig waren und die Kontrolle über Ihren Computer übernehmen könnten. Dieser Artikel beschreibt die Schritte, um Java zu aktualisieren und das Plugin wieder funktionstüchtig zu machen.

Alte Versionen des Java-Plugins sind anfällig für Angriffe, die ohne Ihr Wissen die Kontrolle über Ihren Computer übernehmen könnten, um Zugang zu Ihren Dateien zu bekommen oder vertrauliche Informationen wie etwa Bankdaten zu stehlen. Dieser Artikel beschreibt die Schritte, um Java zu aktualisieren und das Plugin wieder funktionstüchtig zu machen.

Java aktualisieren

Firefox blockiert nur anfällige Versionen von Java, also müssen Sie Java auf die neueste Version aktualisieren. Unglücklicherweise reicht es nicht aus, eine neue Version von Java zu installieren, da die alten Installationen so nicht von Ihrem Computer entfernt werden, wodurch Sie weiter angreifbar bleiben. Sie müssen also alle alten Versionen von Java deinstallieren, bevor Sie auf die neue Version aktualisieren.

  1. Laden Sie das neueste Installationsprogramm für Java von der Java Download-Seite herunter, aber führen Sie es noch nicht aus.
  2. Klicken Sie oben im Firefox-Fenster auf die Schaltfläche Firefox und wählen Sie dort den Eintrag Beenden.Klicken Sie oben im Firefox-Fenster auf das Menü Datei und wählen Sie dort den Eintrag Beenden.Klicken Sie in der Menüleiste auf das Menü Firefox und wählen Sie dort den Eintrag Firefox beenden.Klicken Sie oben im Firefox-Fenster auf das Menü Datei (oder auf die Schaltfläche Firefox, falls keine Menüleiste sichtbar ist) und wählen Sie dort den Eintrag Beenden.

    Klicken Sie auf die Menüschaltfläche New Fx Menu und wählen Sie dann BeendenBeenden Firefox 29 Schließen .

  3. Klicken Sie auf die Windows-„Start“-Schaltfläche und wählen Sie die „Systemsteuerung“ aus. Die Systemsteuerung öffnet sich.
    Windows 7 Systemsteuerung öffnen
  4. Öffnen Sie die Programmliste.
    • (Windows Vista/7) Klicken Sie auf Programme und dann auf Programme und Funktionen.
    • (Windows 2000/XP) Klicken Sie mit der Maus doppelt auf Software.
  5. Wählen Sie alle Java- oder Java-Runtime-Programme.
  6. So starten Sie die Deinstallation:
    • (Windows Vista/7) Klicken Sie auf Deinstallieren über der Liste.
    • (Windows 2000/XP) Klicken Sie auf Entfernen rechts von den ausgewählten Einträgen.
      Hinweis: Warten Sie, bis der Deinstallationsprozess abgeschlossen ist, bevor Sie fortfahren.
  7. Führen Sie das Installationsprogramm aus, das Sie in Schritt 1 heruntergeladen haben.
  8. Starten Sie Firefox.

Java sollte nun wie erwartet funktionieren.

Firefox blockiert nur anfällige Versionen von Java, also müssen Sie Java auf die neueste Version aktualisieren.

  1. Laden Sie das neueste Installationsprogramm für Java von der Java Download-Seite herunter.
  2. Klicken Sie oben im Firefox-Fenster auf die Schaltfläche Firefox und wählen Sie dort den Eintrag Beenden.Klicken Sie oben im Firefox-Fenster auf das Menü Datei und wählen Sie dort den Eintrag Beenden.Klicken Sie in der Menüleiste auf das Menü Firefox und wählen Sie dort den Eintrag Firefox beenden.Klicken Sie oben im Firefox-Fenster auf das Menü Datei (oder auf die Schaltfläche Firefox, falls keine Menüleiste sichtbar ist) und wählen Sie dort den Eintrag Beenden.

    Klicken Sie auf die Menüschaltfläche New Fx Menu und wählen Sie dann BeendenBeenden Firefox 29 Schließen .

  3. Führen Sie das Installationsprogramm aus, das Sie in Schritt 1 heruntergeladen haben.
  4. Starten Sie Firefox.

Java sollte nun wie erwartet funktionieren.

Sie müssen Java auf die neueste Version aktualisieren.

  1. Klicken Sie oben im Firefox-Fenster auf die Schaltfläche Firefox und wählen Sie dort den Eintrag Beenden.Klicken Sie oben im Firefox-Fenster auf das Menü Datei und wählen Sie dort den Eintrag Beenden.Klicken Sie in der Menüleiste auf das Menü Firefox und wählen Sie dort den Eintrag Firefox beenden.Klicken Sie oben im Firefox-Fenster auf das Menü Datei (oder auf die Schaltfläche Firefox, falls keine Menüleiste sichtbar ist) und wählen Sie dort den Eintrag Beenden.

    Klicken Sie auf die Menüschaltfläche New Fx Menu und wählen Sie dann BeendenBeenden Firefox 29 Schließen .

  2. Wählen Sie Software-Update... aus dem Apple Menü.
  3. Wählen Sie das Java-Update aus und klicken Sie auf Installieren. Warten Sie, bis der Updateprozess abgeschlossen ist.
  4. Starten Sie Firefox.

Java sollte nun wie erwartet funktionieren.

Falls Sie zuvor im Blockier-Dialog Deaktivieren ausgewählt haben, müssen Sie Java wieder aktivieren:

  1. Klicken Sie oben im Firefox-Fenster auf die Schaltfläche FirefoxKlicken Sie in der Menüleiste auf ExtrasKlicken Sie oben im Firefox-Fenster auf das Menü Extras und wählen Sie dann Add-ons. Der Tab mit der Add-ons-Verwaltung wird sich öffnen.

    FehlerbehebungPluginsWinXP_01 FehlerbehebungPluginsWin_01 FehlerbehebungPluginsMac_01 Fehlerbehebung Plugins Linux 01
    Klicken Sie auf die Menüschaltfläche New Fx Menu und wählen Sie Add-ons, um die Add-ons-Verwaltung zu öffnen.

    Windows: Australis - Add-ons öffnen Linux: Australis - Add-ons öffnen


  2. Finden Sie den Eintrag Java Platform oder Java Runtime und klicken Sie auf Aktivieren.

Die Sperrliste ignorieren

Falls Sie nicht in der Lage sind, Java zu aktualisieren, und es wichtig für Sie ist, es weiter nutzen zu können, können Sie die blockierte Version wieder aktivieren.

Warnung: Dadurch bleiben Sie anfällig für Angriffe. Einfaches Surfen auf einer gefährlichen Website kann dazu führen, dass Ihr Computer angegriffen wird.

Java aktivieren

  1. Klicken Sie oben im Firefox-Fenster auf die Schaltfläche FirefoxKlicken Sie in der Menüleiste auf ExtrasKlicken Sie oben im Firefox-Fenster auf das Menü Extras und wählen Sie dann Add-ons. Der Tab mit der Add-ons-Verwaltung wird sich öffnen.

    FehlerbehebungPluginsWinXP_01 FehlerbehebungPluginsWin_01 FehlerbehebungPluginsMac_01 Fehlerbehebung Plugins Linux 01
    Klicken Sie auf die Menüschaltfläche New Fx Menu und wählen Sie Add-ons, um die Add-ons-Verwaltung zu öffnen.

    Windows: Australis - Add-ons öffnen Linux: Australis - Add-ons öffnen


  2. Finden Sie den Eintrag Java Platform oder Java Runtime und klicken Sie auf Aktivieren.



Teile diesen Artikel: http://mzl.la/MN0qiT

Diese netten Menschen haben geholfen, diesen Artikel zu schreiben: ThomasLendo, boersenfeger, mope. Auch Sie können helfen – erfahren Sie, wie.