X
Tryk her for at gå til webstedets mobilversion.

Supportforum

How do I make Firefox open the links that I click on in my email program without having to click the 'allow' button each time?

Skrevet

When I am in Gmail and I click on a link , Firefox ALWAYS pops up a tab asking me if I want to allow this. I do not want to have to do this every time I want to access a link. How do I make it automatically go to the link w/o any intervention from me.

I'm using Firefox v.11.0

When I am in Gmail and I click on a link , Firefox ALWAYS pops up a tab asking me if I want to allow this. I do not want to have to do this every time I want to access a link. How do I make it automatically go to the link w/o any intervention from me. I'm using Firefox v.11.0

Valgt løsning

Go to your Firefox Advanced panel - Accessibility, browsing, network, updates, and other advanced settings in Firefox. In the General Tab under Accessibility, uncheck the option, "Warn me when websites try to redirect or reload the page".

Ref: http://kb.mozillazine.org/accessibility.blockautorefresh

Læs dette svar i sammenhæng 5

Yderligere systemdetaljer

Installerede plugins

  • Shockwave Flash 11.1 r102
  • Next Generation Java Plug-in 1.6.0_31 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Google Update
  • Version 2.7.5.6365
  • Google Talk Plugin Video Accelerator version:0.1.44.15
  • VLC media player Web Plugin 2.0.0-rc
  • GEPlugin
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.2
  • Winamp Application Detector
  • 5.0.61118.0
  • AmazonMP3DownloaderPlugin 1.0.15
  • NPWLPG

Program

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:11.0) Gecko/20100101 Firefox/11.0

Yderligere information

Luk
AliceWyman
  • Moderator
240 løsninger 2594 svar

I just went to https://mail.google.com/mail/#inbox
.... then I signed into my gmail account and tried a link in one of my e-mails and had no problems.

Could you post the exact text of the error message that comes up in a Firefox tab when you click on a link in an e-mail from your GMail inbox?

You may have a Firefox extension that is causing the message to appear. Go to the Firefox menu button and click on "Help -> Troubleshooting Information" (which opens the about:support page) and copy the contents to the clipboard and paste here. This will list certain Firefox information, such as installed extensions and modified preferences, that can help identify the problem. See Use the Troubleshooting Information page to help fix Firefox issues.


It might also help if you could test in Firefox Troubleshoot Firefox issues using Safe Mode - see Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems.

I just went to https://mail.google.com/mail/#inbox <br> .... then I signed into my gmail account and tried a link in one of my e-mails and had no problems. Could you post the exact text of the error message that comes up in a Firefox tab when you click on a link in an e-mail from your GMail inbox? You may have a Firefox extension that is causing the message to appear. Go to the Firefox menu button and click on "Help -> Troubleshooting Information" (which opens the '''about:support''' page) and copy the contents to the clipboard and paste here. This will list certain Firefox information, such as installed extensions and modified preferences, that can help identify the problem. See [[Using the Troubleshooting Information page]]. It might also help if you could test in Firefox [[Safe Mode]] - see [[Troubleshooting extensions and themes]].

Spørgsmålsstiller

There is no error message. There is simply a bar that pops up at the top of the screen which says 'Firefox prevented this page from automatically redirecting to another page' on the left side. On the right side is a box that says 'allow' and a 'x'. If I click on 'allow', it works. If I click on the 'x' it closes the window.

If i right-click on the link in Gmail and select 'open in new tab' it works just fine. It only happens when I click on the link directly.

I will look into the 'safe mode' and other info you talked about.

There is no error message. There is simply a bar that pops up at the top of the screen which says 'Firefox prevented this page from automatically redirecting to another page' on the left side. On the right side is a box that says 'allow' and a 'x'. If I click on 'allow', it works. If I click on the 'x' it closes the window. If i right-click on the link in Gmail and select 'open in new tab' it works just fine. It only happens when I click on the link directly. I will look into the 'safe mode' and other info you talked about.

Spørgsmålsstiller

Okay, I started in safe mode and coped the info to the clipboard. Here it is.


 Application Basics
       Name
       Firefox
       Version
       11.0
       User Agent
       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:11.0) Gecko/20100101 Firefox/11.0
       Profile Directory
         Open Containing Folder
       Enabled Plugins
         about:plugins
       Build Configuration
         about:buildconfig
       Crash Reports
         about:crashes
       Memory Use
         about:memory
 Extensions
       Name
       Version
       Enabled
       ID
       Download Statusbar
       0.9.10
       false
       {D4DD63FA-01E4-46a7-B6B1-EDAB7D6AD389}
       DownloadHelper
       4.9.8
       false
       {b9db16a4-6edc-47ec-a1f4-b86292ed211d}
       Free Download Manager plugin
       1.5.5
       false
       fdm_ffext@freedownloadmanager.org
       Freemake Video Converter Plugin
       1.0.0
       false
       fmconverter@gmail.com
       Google Shortcuts
       2.1.7.1
       false
       {5C46D283-ABDE-4dce-B83C-08881401921C}
       Greasemonkey
       0.9.18
       false
       {e4a8a97b-f2ed-450b-b12d-ee082ba24781}
       My Homepage
       1.2
       false
       myhomepage_manishjain9@gmail.com
       NetVideoHunter
       1.9.1
       false
       netvideohunter@netvideohunter.com
       Skype Click to Call
       5.9.0.9216
       false
       {82AF8DCA-6DE9-405D-BD5E-43525BDAD38A}
 Modified Preferences
     Name
     Value
       accessibility.blockautorefresh
       true
       browser.display.background_color
       #C0C0C0
       browser.display.use_system_colors
       true
       browser.places.smartBookmarksVersion
       2
       browser.startup.homepage
       https://www.google.com/
       browser.startup.homepage_override.buildID
       20120312181643
       browser.startup.homepage_override.mstone
       rv:11.0
       browser.tabs.loadInBackground
       false
       extensions.lastAppVersion
       11.0
       gfx.blacklist.layers.opengl
       5
       gfx.blacklist.webgl.opengl
       5
       network.cookie.prefsMigrated
       true
       places.database.lastMaintenance
       1331247118
       places.history.expiration.transient_current_max_pages
       104858
       privacy.donottrackheader.enabled
       true
       privacy.sanitize.migrateFx3Prefs
       true
       security.warn_viewing_mixed
       false
 Graphics
       Adapter Description
       ATI Radeon HD 4600 Series
       Vendor ID
       1002
       Device ID
       9490
       Adapter RAM
       512
       Adapter Drivers
       aticfx64 aticfx64 aticfx32 aticfx32 atiumd64 atidxx64 atiumdag atidxx32 atiumdva atiumd6a atitmm64
       Driver Version
       8.930.0.0
       Driver Date
       12-5-2011
       Adapter Description (GPU #2)
       ATI Radeon 3000 Graphics
       Vendor ID (GPU #2)
       1002
       Device ID (GPU #2)
       9616
       Adapter RAM (GPU #2)
       256
       Adapter Drivers (GPU #2)
       aticfx64 aticfx64 aticfx32 aticfx32 atiumd64 atidxx64 atiumdag atidxx32 atiumdva atiumd6a atitmm64
       Driver Version (GPU #2)
       8.930.0.0
       Driver Date (GPU #2)
       12-5-2011
       Direct2D Enabled
       false
       DirectWrite Enabled
       false (6.1.7601.17776)
       ClearType Parameters
       DISPLAY1 [ Gamma: 2200 Pixel Structure: RGB ClearType Level: 100 Enhanced Contrast: 50 ] DISPLAY3 [ Gamma: 1800 Pixel Structure: RGB ClearType Level: 100 Enhanced Contrast: 0 ]
       WebGL Renderer
       Google Inc. -- ANGLE (ATI Radeon HD 4600 Series) -- OpenGL ES 2.0 (ANGLE 1.0.0.930)
       GPU Accelerated Windows
       0
Okay, I started in safe mode and coped the info to the clipboard. Here it is. ---------------------------------------------------------------------------- Application Basics Name Firefox Version 11.0 User Agent Mozilla/5.0 (Windows NT 6.1; WOW64; rv:11.0) Gecko/20100101 Firefox/11.0 Profile Directory Open Containing Folder Enabled Plugins about:plugins Build Configuration about:buildconfig Crash Reports about:crashes Memory Use about:memory Extensions Name Version Enabled ID Download Statusbar 0.9.10 false {D4DD63FA-01E4-46a7-B6B1-EDAB7D6AD389} DownloadHelper 4.9.8 false {b9db16a4-6edc-47ec-a1f4-b86292ed211d} Free Download Manager plugin 1.5.5 false fdm_ffext@freedownloadmanager.org Freemake Video Converter Plugin 1.0.0 false fmconverter@gmail.com Google Shortcuts 2.1.7.1 false {5C46D283-ABDE-4dce-B83C-08881401921C} Greasemonkey 0.9.18 false {e4a8a97b-f2ed-450b-b12d-ee082ba24781} My Homepage 1.2 false myhomepage_manishjain9@gmail.com NetVideoHunter 1.9.1 false netvideohunter@netvideohunter.com Skype Click to Call 5.9.0.9216 false {82AF8DCA-6DE9-405D-BD5E-43525BDAD38A} Modified Preferences Name Value accessibility.blockautorefresh true browser.display.background_color #C0C0C0 browser.display.use_system_colors true browser.places.smartBookmarksVersion 2 browser.startup.homepage https://www.google.com/ browser.startup.homepage_override.buildID 20120312181643 browser.startup.homepage_override.mstone rv:11.0 browser.tabs.loadInBackground false extensions.lastAppVersion 11.0 gfx.blacklist.layers.opengl 5 gfx.blacklist.webgl.opengl 5 network.cookie.prefsMigrated true places.database.lastMaintenance 1331247118 places.history.expiration.transient_current_max_pages 104858 privacy.donottrackheader.enabled true privacy.sanitize.migrateFx3Prefs true security.warn_viewing_mixed false Graphics Adapter Description ATI Radeon HD 4600 Series Vendor ID 1002 Device ID 9490 Adapter RAM 512 Adapter Drivers aticfx64 aticfx64 aticfx32 aticfx32 atiumd64 atidxx64 atiumdag atidxx32 atiumdva atiumd6a atitmm64 Driver Version 8.930.0.0 Driver Date 12-5-2011 Adapter Description (GPU #2) ATI Radeon 3000 Graphics Vendor ID (GPU #2) 1002 Device ID (GPU #2) 9616 Adapter RAM (GPU #2) 256 Adapter Drivers (GPU #2) aticfx64 aticfx64 aticfx32 aticfx32 atiumd64 atidxx64 atiumdag atidxx32 atiumdva atiumd6a atitmm64 Driver Version (GPU #2) 8.930.0.0 Driver Date (GPU #2) 12-5-2011 Direct2D Enabled false DirectWrite Enabled false (6.1.7601.17776) ClearType Parameters DISPLAY1 [ Gamma: 2200 Pixel Structure: RGB ClearType Level: 100 Enhanced Contrast: 50 ] DISPLAY3 [ Gamma: 1800 Pixel Structure: RGB ClearType Level: 100 Enhanced Contrast: 0 ] WebGL Renderer Google Inc. -- ANGLE (ATI Radeon HD 4600 Series) -- OpenGL ES 2.0 (ANGLE 1.0.0.930) GPU Accelerated Windows 0
AliceWyman
  • Moderator
240 løsninger 2594 svar

Valgt løsning

Go to your Firefox Advanced panel - Accessibility, browsing, network, updates, and other advanced settings in Firefox. In the General Tab under Accessibility, uncheck the option, "Warn me when websites try to redirect or reload the page".

Ref: http://kb.mozillazine.org/accessibility.blockautorefresh

Go to your Firefox [[Options window - Advanced panel]]. In the General Tab under Accessibility, uncheck the option, "Warn me when websites try to redirect or reload the page". Ref: http://kb.mozillazine.org/accessibility.blockautorefresh

Nyttigt svar

That did it. Thanks a million. I have been looking into the pop-up blocker cause I figured it was something simple like that. Just not familiar enough with Firefox yet.

That did it. Thanks a million. I have been looking into the pop-up blocker cause I figured it was something simple like that. Just not familiar enough with Firefox yet.