Søg i Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

The Flash plug-in causes Firefox to crash for about 2 minutes every 20 seconds, it is the newest Flash update. It has happened to me both with Firefox 3.6 and 4!

  • 25 svar
  • 53 har dette problem
  • 25 visninger
  • Seneste svar af Xircal

more options

Firefox for me has been fine for the past couple of years or so. Then all of a sudden about 5 months ago, everytime i would use Firefox it would crash after browsing for about 1 minute. I uninstalled and reinstalled numerous times to no avail. I then got sick of the problem and then used IE till now. However, i heard about Firefox 4 and thought maybe this would fix it. Unfortunately, the same problem occurred! I then heard about being able to start Firefox with add-ons disabled to find any sources of problems, and i've found that the cause if Flash! It is the newest version and always has been, so i don't know what i can do, since Flash is important for most websites nowadays!?

Valgt løsning

That's good news!

Could you please click the "Solved It" button to take your post out of the loop?

And thanks for the compliment by the way. :)

Læs dette svar i sammenhæng 👍 0

Alle svar (20)

more options

Check your firewall logs to determine whether the firewall is blocking plugin_container.exe

The latter is a kind of sandbox within Firefox which isolates Flash in the event of a crash so that you can carry on using the browser. Without it, the browser will crash.

I've uploaded an image to illustrate which permissions plugin_container.exe needs in a firewall.

To check which version of Flash you have installed and whether you need to update at all, go to the Plugins Check page.

Ændret af Xircal den

more options

Would the firewall logs be found in my anti-virus software? In such case i have Norton Internet Security 2010, and i couldn't find any related logs or the 'plugin_container.exe' that you mention?

more options

Firefox has been updated now to 4.0.1 and you should update it too via Help | About Firefox | Check For Updates. See Mozilla patches Firefox and Thunderbird

However, Norton will become incompatible with Firefox again. There is however a workaround on the Norton forums which you could use pending a new patch: Help with FF4 Compatibility Update

You mentioned starting Firefox in Diagnose Firefox issues using Troubleshoot Mode allowed you to identify Flash as the culprit. But Flash is a plugin and those aren't disabled in Safe Mode.

What you should do here is restart Firefox in Safe Mode again and then click "Disable All Add-ons". Then click the Make changes and restart button.

After that, re-enable your add-ons one-by-one until the problem recurs. Then you'll know that it was the last one you re-enabled which is the culprit.

more options

Yes, i apologise for the lack of detail in my original post but that is what i did until i found the 'Shockwave Flash' is the culprit. With it disabled all is fine (though obviously i cannot view videos or other Flash-bases activities), and as soon as it is enabled the freezing begins every 20 seconds.

I have installed the Firefox update but the problem still persists. Regarding Norton, the only reason i mentioned it is because you may have suggested that it's settings may be causing the problem? But the only problem that i have had is the with Flash add-on.

I thank for for your help so far and i look forward once again to your response.

more options

Could you please do the following.

Download the following two files and save to your desktop. These are direct download links so you'll only see the dialog boxes which looks like the ones you see in the screenshot.

Next, close Firefox via File | Exit (it's important that you do it this way and not just by clicking the close button)

Next, double click the uninstall_flash_player.exe file you downloaded earlier and then reboot. A reboot is necessary to remove the setting from the Windows Registry.

Next, double click the install_flash_player.exe file to reinstall Flash.

Finally, restart Firefox and see if it made any difference.

more options

I followed your instructions to the tee but unfortunately the problem still remains. :(

more options

OK, in the location bar, type: about:crashes and hit Enter.

You should see a series of links each of which comprises of a series of random characters. Could you please right click the top two and choose "Copy Link Location" to copy it to the Windows clipboard. You'll have to do it one at a time, but there's no need to close Firefox.

Then come back you your next post and then right click and choose Paste to paste them.

more options
more options

@ shuffy, do you have exactly the same problem to the letter as SirMerkatron? If not, could you please start a new thread.

more options

the problem is identical, everything runs fine as long as i disable flash. Its only started happening with me since i upgraded to firefox 4 last week. Sorry to have jumped in on someone's post! i have also tried the above recommendations to no avail :(

Ændret af shuffy den

more options

@ shuffy, please try running Firefox in Diagnose Firefox issues using Troubleshoot Mode to eliminate an add-on as the cause of the problem.

From your crash report, the faulting module is the Real Player plugin. Try disabling it in the Plugins menu.

Could you also please let us know what your operating system is and what plugins you have installed together with their respective versions. You'll find the latter by clicking the orange Firefox button, go to Add-ons and then click Plugins.

Ændret af Xircal den

more options
more options

@ SirMerkatron, there are instructions on the Norton forum about how to view Norton firewall logs

Could you do that and see if you can find any reference to plugin_container.exe please.

more options


I just started getting back to back crashes, in the crash bar it always says "the adobe flash plugin has crashed" the below link is the most recent but i have had upwards of 10 crashes between 6:45pm and 9:45pm.

Have not tried uninstalling plugin as yet, but am close to doing that next time it crashes.


Thank you for your help

more options

I have found the plugin-container.exe blocked in my firewall logs! I've shown this in the image attached, but i do not know where to locate the settings that i need to alter as you suggested in your previous post?

more options

Here's the relevant article which illustrates how to configure Firefox. Norton Internet Security

Allow Firefox access the next time you go on the web again.

You may possibly see plugin_container.exe appear as a second alert in which case, click "Allow".

more options

I followed the instructions in that link, but every time i remove 'Firefox' from that list and press apply and ok, the problem still occurs. In addition, when i reopen the Program Control again in Norton, 'Firefox' still appears?

I also tried to turn 'Smart Firewall' off completely, as that is what section Program Control is in and the problem still persists.

I also tried not removing Firefox from the list in Program Control, but just changing the Access from 'Auto' to 'Allow', and the problem still persists.

Once again, i am stumped.

more options

Have you updated to 4.0.1 by any chance? Norton doesn't work with that version, but you might find it resolves the problems you're experiencing.

Update via Help | About Firefox | Check For Updates.

more options

Yes i am currently on 4.0.1 and since downloading, i am afraid to say nothing has changed. :(

more options
  1. 1
  2. 2