Søg i Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox, as well as Waterfox, completely crawl compared to my Chromium browsers. 40+ seconds to load a website.

  • 7 svar
  • 0 har dette problem
  • 13 visninger
  • Seneste svar af jonzn4SUSE

more options

I used to have Firefox as my main browser for awhile. But after updating to Windows 10, It has become unusably slow for awhile now. It is so bad that I have simply switched to Brave, which works perfectly fine. It looks like it's loading one element at a time. Waterfox does the same thing. I wonder if it's something with Gecko on my computer. A few things that may help. My internet connection is fine. I have no extensions. I have tried different Firefox profiles. I have tried the Help page's suggestion of removing and re-adding Firefox to my Windows Defender firewall. Nothing seems to work.

Please help me!

I used to have Firefox as my main browser for awhile. But after updating to Windows 10, It has become unusably slow for awhile now. It is so bad that I have simply switched to Brave, which works perfectly fine. It looks like it's loading one element at a time. Waterfox does the same thing. I wonder if it's something with Gecko on my computer. A few things that may help. My internet connection is fine. I have no extensions. I have tried different Firefox profiles. I have tried the Help page's suggestion of removing and re-adding Firefox to my Windows Defender firewall. Nothing seems to work. Please help me!

Alle svar (7)

more options

Did you download the current version from Mozilla? https://www.mozilla.org/en-US/firefox/all/#product-desktop-release

What version of Win10? If Pro, can you fire up Windows Sandbox and see if you have the same issues in the VM? https://www.howtogeek.com/399290/how-to-use-windows-10s-new-sandbox-to-safely-test-apps/

Nyttig?

more options

jonzn4SUSE said

Did you download the current version from Mozilla? https://www.mozilla.org/en-US/firefox/all/#product-desktop-release What version of Win10? If Pro, can you fire up Windows Sandbox and see if you have the same issues in the VM? https://www.howtogeek.com/399290/how-to-use-windows-10s-new-sandbox-to-safely-test-apps/

I apologize for the late reply. Holidays really got in the way, and I didn't see your response. Yes, I do have the current version. I tried the sandbox, and Firefox seems to work perfectly there.

Nyttig?

more options

Nyttig?

more options

Dropa said

Next step would be to use Firefox in Private Mode window to verify Addons are not the issue here. https://support.mozilla.org/en-US/kb/private-browsing-use-firefox-without-history#:~:text=for%20easy%20access%3A-,Click%20the%20Menu,mode%20icon%20in%20the%20taskbar.

It is a completely fresh install, there are no addons. It is still slow in private mode.

Also, for reference, here's how slow it is being:

Nyttig?

more options

Sandbox Firefox works fine... good. That means something in Windows is causing the issue. What security software are you running?

Nyttig?

more options

jonzn4SUSE said

Sandbox Firefox works fine... good. That means something in Windows is causing the issue. What security software are you running?

Just Windows Defender. It shows up in my about:support as Windows Firewall under Firewall.

Nyttig?

more options

Interesting... Looks like you're going to have to investigate what on your system is causing this issue. After rebooting, look at what processes are running and kill the Edge browser process and see if it makes a difference. I've noticed in the pass when Firefox would freeze that Edge was running ( just a conspiracy of mine ;-)) ).

Nyttig?

Stil et spørgsmål

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.