Søg i Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cut and paste no longer works with Google Translate on linux

more options

This problem has been around since the latest version of the old version, and has carried across into the new version. Ctrl+A, Ctrl+C and Ctrl+V no longer work with Google Translate on linux. I have tested in other browsers and it they all work fine. Firefox on Windows also works fine, this problem seems specific to linux.

When you press any of the Ctrl combinations it simply deselects everything and moves the cursor to the end of the text. Mouse works, but it's not practical if you are cutting and pasting all day long.

Site: https://translate.google.com Firefox version: 89.0.2 (64-bit) OS: Ubuntu 20.04

Google Translation is critical to my work so my current solution is I no longer use Firefox. I hope that someone knows of a quick fix, or if it's a bug it's easy to fix as I'd hate to permanently move away from Firefox for something like this.

Thanks!

Valgt løsning

So after weeks of on and off trying to find the cause of this, I finally isolated the culprit. It was something in the GNOME dconf configuration. After resetting it (and losing all my customization) Firefox now works properly with google translate like all the other browsers.

I still don't know what in particular caused it but if someone else runs into the problem then run the following commands to backup and reset, then just redo your settings:

$dconf dump / > backup.txt

$dconf reset -f /

Thanks very much to @jonzn4SUSE, @cor-el and @FredMcD for helping with this. I never would have guessed it was something only local to me after checking on 3 different computers.

Læs dette svar i sammenhæng 👍 1

Alle svar (11)

more options

Start Firefox using Troubleshoot(Safe) Mode {web link}

A small dialog should appear. Click Start In Troubleshoot(Safe) Mode (not Refresh). Is the problem still there?

Nyttig?

more options

Thanks for the reply Fred.

Unfortunately the problem persists in safe mode too.

Nyttig?

more options

Do the alternatives work for you ?

Use keyboard shortcuts in case the buttons on the webpage or other methods aren't working.

  • Copy: Ctrl+C or Ctrl+Insert (Mac: Command+C)
  • Paste: Ctrl+V or Shift+Insert (Mac: Command+V)
  • Cut: Ctrl+X or Shift+Delete (Mac: Command+X)

Try the Firefox version from the official Mozilla server if you currently use a version from the repositories of your Linux distribution.

Nyttig?

more options

I'm not able to replicate the issue. see screenshot Do you have the same issue with a different user on the same computer?

Operating System: openSUSE Tumbleweed 20210711 KDE Plasma Version: 5.22.3 KDE Frameworks Version: 5.83.0 Qt Version: 5.15.2 Kernel Version: 5.13.0-1-default (64-bit) Graphics Platform: X11 Processors: 8 × Intel® Core™ i7-4810MQ CPU @ 2.80GHz Memory: 31.0 GiB of RAM Graphics Processor: Mesa DRI Intel® HD Graphics 4600

Nyttig?

more options

Thank you for the replies!

I am sorry, my explanation was not very clear. I should have left exact steps on what the problem is and how to reproduce. This is exactly the test I did just now:

1. Paste this text into google translate: 豊島区では、身近なかかりつけ医による「個別接種」を基本に新型コロナウイルスのワクチン接種を進め、7月15日現在、高齢者の80.7%が1回目、65.3%が2回目の接種を終えました。

2. Copy just the first 3 characters with ctrl+c 豊島区

3. Paste with ctrl+v It will re-paste the entire text from step 1 instead of the new copied text

4. Copy just the first 3 characters with right-click "copy" 豊島区

5. Paste with either ctrl+v or right-click "paste" It will paste the correct text

6. Highlight any of the text, and press ctrl+x It will not do anything except move the cursor to the end of the selected text

7. Highlight any of the text, and right-click "cut" It will correctly cut the text out

This should reproduce 2 of the issues. I have tried with a different profile, also on different computers and the result is always the same though limited to Ubuntu 20.04 since I don't have another distro installed.

Using the official Firefox also has the same issue. As does private mode and ESR version.

I hope this clarifies the issue. Again, I am sorry for not explaining properly to begin with :(

Ændret af decaffeinated tea den

Nyttig?

more options

In between steps 2 and 3, shouldn't there be a ctrl+A to highlight all the text in the box and then crtl+V. Are you running KDE or Gnome? I'm in KDE and can watch the clipboard to see that the first 3 characters are copied. see screenshot

I'm running 89 from OS and local copy, Nightly, and ESR, but not able to replicate the issue. Also no issues with crtl+X in any browser.

Ændret af jonzn4SUSE den

Nyttig?

more options

thank you @jonzn4SUSE for your reply!

there is no ctrl+a between steps 2 and 3. The aim is to only copy the 3 characters, not the whole text (which would already be on the clipboard for doing step 1).

The clipboard is working correctly, since right-click copy/cut/paste with the mouse works fine. It's only the keyboard shortcuts that have an issue. If you were able to ctrl+c just the 3 characters then this is already something that I cannot do.

I use vanilla Ubuntu 20.04, so gnome + any default updates (ironically to try and avoid any strange issues). I don't think that gnome is the problem though, since all other browsers work fine. This issue only happens with Firefox :(

by the way, did ctrl+x also work for you?

Ændret af decaffeinated tea den

Nyttig?

more options

Since SUSE seems to work I tried the following:

1. Installed Tumbleweed VM. No issues. 2. Installed Leap VM. No issues. 3. Installed Ubuntu 21.04. No issues. 4. Ran Ubuntu 20.04 live. No issues.

I think that safely concludes whatever the issue is, it is related to an Ubuntu 20.04 update that is affecting Firefox (unless by some bizarre circumstances it is only affecting my PC, laptop and test VM in the same way).

Needle in a haystack :(

Ændret af decaffeinated tea den

Nyttig?

more options

Nyttig?

more options

Thanks for the link, I certainly didn't know about this, and the fact it points out Firefox in particular is notably flaky doesn't inspire me with confidence!

I did another test that I probably should have done first in hindsight; which is create another user on my system and see if there were any issues.

There were none. So that now narrows it down to something in my user profile that is clashing with Firefox (my PC, laptop and test VM all have basically identical profiles which is why they all had the same issue).

Have no idea what it would be though, I don't use any tools that remap keys or do anything weird with the X system.

Nyttig?

more options

Valgt løsning

So after weeks of on and off trying to find the cause of this, I finally isolated the culprit. It was something in the GNOME dconf configuration. After resetting it (and losing all my customization) Firefox now works properly with google translate like all the other browsers.

I still don't know what in particular caused it but if someone else runs into the problem then run the following commands to backup and reset, then just redo your settings:

$dconf dump / > backup.txt

$dconf reset -f /

Thanks very much to @jonzn4SUSE, @cor-el and @FredMcD for helping with this. I never would have guessed it was something only local to me after checking on 3 different computers.

Ændret af decaffeinated tea den

Nyttig?

Stil et spørgsmål

Du skal logge ind på din konto for at svare på et indlæg. Start et nyt spørgsmål, hvis du ikke har en konto endnu.