Søg i Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox do not ask confirmation when exit/close with multiple tabs open

  • 17 svar
  • 6 har dette problem
  • 6831 visninger
  • Seneste svar af Karmus

more options

I am having same issue like user there: https://support.mozilla.org/en-US/questions/1139845 (only i have different OS)

When having multiple tabs open, Firefox never ask me for confirmation when i click Firefox window close button in the corner (usually accidentally). And i want confirmation.

in about:config i have:

browser.showQuitWarning true (this is marked as customized (bold) value, like default is false)

browser.tabs.closeWindowWithLastTab true

and when i close Firefox (usually accidentally) i receive crash reporter window which i usually submit.


update: one member claims that close confirmation is never shown for single window Firefox, only multiple Firefox windows. I think this is bad idea s probably half people not using multiple windows, only multiple tabs.

Ændret af #367259 den

Valgt løsning

the-edmeister said

All you need to do is to use Restore Previous Session, from either the default about:home homepage in the lower-right corner or from History > Restore Previous Session. ...

Thank You for the input. Indeed, i go to Options/General and set "When Firefox starts:" to "Show my home page" and when i click X close button of the FF, then FF asks:

"Do you want Firefox to save your tabs for the next time it starts?" I click "Save and Quit" When i start FF, tabs are automatically re-opened ! :-) That is great, very happy.

I never thought tabs will be reopened when blank page is set at start. And i did not tried because i usually have many tabs open so not wanted to risk. For me the issue is solved. Thx

Læs dette svar i sammenhæng 👍 1

Alle svar (17)

more options

Hi   !
A little bit different from what you mentioned:
Type in the address bar   about:config (promise to be careful) Type and search for browser.tabs.warnOnClose and set it's value to   true

more options

Happy112 said

browser.tabs.warnOnClose and set it's value to   true

thx, but it is True by default and i had it already set to True.

more options

You may have dismissed the warning once, so you need to re-enable the Warn me when closing multiple tabs setting that should have become available afterwards. However and if I remember well, if you close a single window and have set Firefox to restore tabs and windows from the last time, you won’t see a confirmation dialog either.

See the Tab preferences and settings and Startup, home page, tabs, and download settings articles for more details, as well as this question and bug 1063625.

Edit: changed the option text (used the wrong one)

Ændret af Tonnes den

more options

Another user,  who had the same problem,  reported that toggling the settings once again fixed it for him. Worth a try   .......

more options

Happy112 said

toggling the settings once again fixed it for him.

i just tried, but not worked. i restarted firefox couple times, but still it never ask me confirmation to close FF. I have set to re-open tabs from last time/session and someone suggested here to disable this option, but that would be even worse for me i think, because i usually have many tabs open and i want to continue working on them.. unless Firefox give me option to recover them all at once (History menu)? in that case i would try disabling that option in aim to make FF ask confirmation before close.

Ændret af #367259 den

more options

Tonnes said

...

I think you may be near the cause of my issue, but i am unsure what do you suggest to me, i read yours linked pages.

more options

Sorry, copied the wrong option text in my previous message so edited it.

The option to show a warning dialog when closing multiple tabs in the Firefox options/preferences was changed to appear conditionally in order to free up space in the user interface, so it’s only available after the option itself has been unchecked in the warning dialog before dismissing it (which toggles browser.tabs.warnOnClose to false). If that happened, one needs to re-enable it in Options/Preferences as documented in the Startup, home page, tabs, and download settings support article - it should then be available.

If you only have one window and multiple tabs open, there is no use showing the warning if Firefox is set to restore tabs and windows from last time in the Startup settings, so in this case, it will only appear when a blank or custom start page is set there. When exiting in a way that’s likely to be intentional (and in any scenario), i.e. using File > Exit/Quit in the menu bar or the button in the app menu on the right, the dialog will not be displayed either.

In short: a dialog should only appear when clicking the top right X if the Startup settings are set to Show a blank page or Show my home page. If not, try Firefox’s Safe Mode to eliminate the chance of an add-on interfering.

If the intention is to get a warning dialog when closing/exiting Firefox in general, assumingly intentional using the menu options, you need to set browser.showQuitWarning to true in about:config (not browser.warnOnQuit), which is false by default. Likewise, this will only work if Firefox is not set to restore tabs and windows at startup, as it would happen anyway.

The browser.tabs.closeWindowWithLastTab preference you mentioned controls whether closing a last tab (= the only one left after closing others) closes the window and may not be what you want.

I did some tests for several versions including 49 and it works (at least on Windows), even though some bugs are filed for this and related issues.

more options

Tonnes said

If you only have one window and multiple tabs open, there is no use showing the warning if Firefox is set to restore tabs and windows from last time in the Startup settings

This is my case. I use one window. When i open second, it start showing the Warning.

And i disagree with you that there is no issue. I have some work there in Firefox and when i close it accidentally, the pages gets refreshed on next start. Also loading tens of tabs + possibly gets logged out of member sections -> not good. It is happening to me repeatedly that i accidentally close Firefox and i would welcome if i can see confirmation. Certainly it should not be by default, but i should be able to somehow enable this for single window even if i have to edit about:config manually, currently there is no way to show close confirmation for single window? when i want to close Firefox, i usually have there many tabs open and setting not to open them on next start is not good, unless i can restore them from history by a single click. Is that possible? Thank you

Ændret af #367259 den

more options

I haven't seen that warning for single window for many years now. Once the Session Restore feature was improved back in the days of (like) Firefox 20 or so, that warning was removed for single windows.

All you need to do is to use Restore Previous Session, from either the default about:home homepage in the lower-right corner or from History > Restore Previous Session. Never failed to restore a session that was in a single that I absentmindedly closed when I intended to close a tab instead.

Also works to Restore a session of multiple windows that were closed on purpose, too. Not sure how long that has been a function of the Session Restore feature.

iirc, there was a pref in about:config for that for a few versions after it was changed, but it's been long gone, as I remember.

more options

I didn’t say there was no issue, hence mentioned there are bugs for it. Most of them consider the current behavior as a tradeoff though. I agree the about:config options are confusing, but without touching them, regular users should not suffer any issues. Please keep in mind that right-clicking the red X is not a regular way to close the program, and current behavior makes sense by design. Also, something accidentally should not happen too often, i.e. there is some user responsibility involved. If Firefox would be a little "overprotective", other complaints could follow.

From what I read in your last reply, things work as they should. If you don’t get the dialog, you need to set up the start page other than to restore tabs and windows. For the regular start page, there is a button in the right bottom for restoring the previous session by one click. If you have set it up to use a blank page, you can restore the previous session using History > Restore previous session.

more options

Valgt løsning

the-edmeister said

All you need to do is to use Restore Previous Session, from either the default about:home homepage in the lower-right corner or from History > Restore Previous Session. ...

Thank You for the input. Indeed, i go to Options/General and set "When Firefox starts:" to "Show my home page" and when i click X close button of the FF, then FF asks:

"Do you want Firefox to save your tabs for the next time it starts?" I click "Save and Quit" When i start FF, tabs are automatically re-opened ! :-) That is great, very happy.

I never thought tabs will be reopened when blank page is set at start. And i did not tried because i usually have many tabs open so not wanted to risk. For me the issue is solved. Thx

more options

Tonnes said

If you don’t get the dialog, you need to set up the start page other than to restore tabs and windows. For the regular start page, there is a button in the right bottom for restoring the previous session by one click. If you have set it up to use a blank page, you can restore the previous session using History > Restore previous session.

yes, thx, it is a solution to this issue.

more options

It was already mentioned above, but glad it helped. (See "In short:...") ;)

more options

Tonnes said

It was already mentioned above, but glad it helped. (See "In short:...") ;)

Yes, but that would not be solution for me, because i care to restore my tabs and when blank page is set, it given an user impression that he loose his session. But actually when blank page/home page is set, user is asked (upon FF close) if he/she want to save tabs which is good, there is a tickbox not to ask and i really hope i will not click it as i would have to start googling and finding how to restore that back :-P

more options

Obviously you are only repeating all I wrote above and offered as the solution for all demands, but that’s your way of learning. ;)

Ændret af Tonnes den

more options

Tonnes said

...

Yes, i used your and the-edmeister advices to sumarize a solution for other readers with similar issue. It could not be solved without your effort. thank you

Ændret af #367259 den

more options

Usually happens to me multiple times a week, when I hit Ctrl+Q instead of Ctrl+W. As #367259 says, it's really annoying because your tabs get updated, and you may be in the middle of some work where you are writing text in a form field, and that text gets lost.

I really think us "Restore previous tabs"-users should have a confirmation dialog that works with browser.showQuitWarning even though we are quite irregular users and run a continuous session throughout years, because we - unfortunately - never finish all of what we start working with. It shouldn't be that hard to implement.

When Firefox shut down the addon-bar, I immediately downloaded an extension. I think it's sad that the codebase has become so increasingly full of garbage (like the Pocket-feature and similar), that we can't have nice things in the core, so we have to patch our losses with extensions on extensions. I have over 20 extensions that I use regularly, which means that I can never fully migrate to another browser without knowing all the alternatives. It simply shouldn't be like that.