Søg i Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox does not run smooth while loading websites.

  • 3 svar
  • 5 har dette problem
  • 56 visninger
  • Seneste svar af Adi

more options

Firefox does not work smoothly when it is loading any webpage. Specially, when I open new tabs and load new websites while it is still loading last website in other tab, the situation becomes worse. Main problems that occur are - page will not scroll, or scrolling hangs for a sec or so, works a little bit and it happens repeatedly, new tabs will open but not smoothly, website loading also gets affected in similar way. The dot that revolves on tabs while loading any webpage gets really annoying. It revolves intermittently. Imagine a car engine not starting, it starts, stops, starts, stops. That's what happens with Firefox. But once all webpages are completely loaded and scrolled 2 or 3 times from top to bottom of the page, then it is all good. All the problems occur when page is still loading in fore- or background in any or all of the tabs. I tried to run Firefox with all add-on and plugins disabled, tried to refresh Firefox from troubleshoot information. But nothing helps. I even uninstalled and reinstalled Firefox. I guess my laptop is not having memory issues. I am using Windows 7 x64 based system. RAM is 4 GB. All other software work well. Most importantly, Chrome has no such issues in comparison to Firefox. Also, when IDM (internet download manager) takes over some downloads, the Firefox hangs for few seconds. Please help. Thank you.

Ændret af Adi den

Alle svar (3)

more options

You can try to disable hardware acceleration in Firefox.

  • Tools > Options > Advanced > General > Browsing: "Use hardware acceleration when available"

You need to close and restart Firefox after toggling this setting.

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window
more options

Thanks for replying. I tried the steps you mentioned above, but nothing seems to be helping much. I am attaching a snapshot of details of my graphic card driver. Probably, you can tell if I need a better graphic card.

more options

Though, toggling webgl.disabled to true and keeping "hardware acceleration when available" enabled, Firefox is running better now. Thanks a lot for the suggestion.